"only free software" option installs linux-restricted-modules

Bug #290925 reported by Martin Pitt on 2008-10-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Jurhan Bazari
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

intrepid final (20081029.5) i386 desktop, selected "only free software".

/etc/apt/sources looks correct (no restricted/multiverse), but I do have linux-restricted-modules-2.6.27-7-generic installed.

To reproduce:
Press F6 twice at the CD bootloader and select "Use only free software". Hit escape to exit that menu, then hit enter to boot.
Run through a full install and then check to see if linux-restricted-modules-2.6.27-7-generic is installed.

Martin Pitt (pitti) wrote :
Martin Pitt (pitti) wrote :
Evan (ev) wrote :

Somehow l-r-m is ending up in base:

evan@bunny:~$ dpkg-query -W -f='${Package} ${Version} ${Section}\n' | grep restricted
fglrx-modaliases 2:8.543-0ubuntu4 restricted/misc
linux-generic 2.6.27.7.11 restricted/metapackages
linux-restricted-modules-2.6.27-7-generic 2.6.27-7.12 base
linux-restricted-modules-common 2.6.27-7.12 restricted/misc
linux-restricted-modules-generic 2.6.27.7.11 restricted/metapackages
nvidia-173-modaliases 173.14.12-1-0ubuntu4 restricted/misc
nvidia-177-modaliases 177.80-0ubuntu2 restricted/misc
nvidia-71-modaliases 71.86.04-0ubuntu10 restricted/misc
nvidia-96-modaliases 96.43.05-0ubuntu10 restricted/misc
restricted-manager 0.33.1 admin
restricted-manager-core 0.33.1 admin
ubuntu-restricted-extras 25 metapackages

Changed in ubiquity:
status: New → Confirmed
Evan (ev) on 2008-10-30
Changed in ubuntu-release-notes:
status: New → Fix Released

On Thu, Oct 30, 2008 at 03:01:29AM -0000, Evan Dandrea wrote:
> Somehow l-r-m is ending up in base:

> evan@bunny:~$ dpkg-query -W -f='${Package} ${Version} ${Section}\n' | grep restricted

This shows you the content of the dpkg database, which is based on what is
present in the .deb control files - not what's in the Packages file used by
apt, which is set using overrides in the archive.

Hopefully, the Packages files on the CDs are also correct?

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Evan (ev) wrote :

On the live CD the following code snippet produces the correct result ('restricted/base'):
from apt.cache import Cache
cache = Cache()
print cache['linux-restricted-modules-2.6.27-7-generic'].section

When run from within the chrooted installed system, it produces 'base'.

/target/var/lib/apt/lists/... has the package in restricted/base

Evan (ev) on 2008-10-30
description: updated
Michael Vogt (mvo) wrote :

I looked into this and I can reproduce it too.

The reason is that in the target filesystem there is no "restricted" packages list anymore (because that is removed from the sources.list in target). So when apt tries to figure out the section it can not find a Packages file and falls back to /var/lib/dpkg/status. That has "base". This comes directly from the deb package that has "base" too instead of "restricted/base".

To fix we need to add "Section: restricted/base" to the deb or gather the information what is restricted and needs to be removed before removing "restricted" from the sources.list (plus we need to have indexfiles that match the current mirror in sources.list - it seems like this is not always the case on the /target filesystem).

Evan (ev) wrote :

I've spoken with Colin and we should be able to fix this by caching it in generate_blacklist (removing it from the blacklist conditional) and then using the cache in do_remove.

Evan (ev) on 2008-10-30
Changed in ubiquity:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.11.0

---------------
ubiquity (1.11.0) jaunty; urgency=low

  [ Evan Dandrea ]
  * Check to make sure a gdk window is mapped before calling
    cairo_create (LP: #208800).
  * Reset next_go_backup after encountering a question marked as seen
    (LP: #290760).
  * Save an apt.cache.Cache() so we retain the package information on
    restricted packages even after removing restricted from the
    sources.list (LP: #290925).
  * Provide operating system titles in segmented_bar.
  * Notify the user of what operating systems will be deleted if they choose
    to use the entire disk.
  * Move finding the release name into its own function now that multiple
    locations need to know it.
  * Correct debian/ubiquity.install-any to refer to the new location of tzmap
    in tzsetup.
  * Use preseed_as_c in the partman component for automatically_partition and
    select_disk as those questions now require it.
  * Install check-missing-firmware as part of hw-detect.
  * Automatic update of included source packages: base-installer
    1.86ubuntu8, choose-mirror 2.27ubuntu1, clock-setup 0.97ubuntu1,
    console-setup 1.28ubuntu3, debian-installer-utils 1.65ubuntu1, grub-
    installer 1.35ubuntu4, hw-detect 1.70ubuntu3, localechooser
    2.08ubuntu1, partconf 1.30, partman-auto 83ubuntu1, partman-base
    128ubuntu2, partman-basicfilesystems 62ubuntu1, partman-basicmethods
    42, partman-ext3 55ubuntu1, partman-jfs 29ubuntu1, partman-newworld
    20ubuntu1, partman-partitioning 64ubuntu1, partman-reiserfs
    44ubuntu1, partman-target 58ubuntu1, partman-xfs 43ubuntu1, preseed
    1.41ubuntu1, silo-installer 1.15ubuntu1, tzsetup 1:0.24, user-setup
    1.23ubuntu1, yaboot-installer 1.1.14ubuntu1.

  [ Colin Watson ]
  * Add an intro message noting that we're alpha again.
  * Autoconf likes to have a version in AC_INIT, but start omitting our
    sub-minor version from it so that we don't have to regenerate configure
    with every single upload.
  * Remove obsolete Encoding: lines from .desktop files, since
    desktop-file-validate complains about them.
  * Remove seen flag from console-setup/model and console-setup/codeset to
    make sure that they don't get misinterpreted as preseeding (LP: #94177).

  [ Mario Limonciello ]
  * Install Mythbuntu's ubiquity desktop file as the right file
    name to get snagged by casper.
  * Drop old update-rc.d hacks in apply-type since they are available
    now in casper.
  * Correct a small typo on a mythbuntu specific glade file
    (LP: #276900)

 -- Evan Dandrea <email address hidden> Tue, 02 Dec 2008 15:36:52 -0500

Changed in ubiquity:
status: Fix Committed → Fix Released
tags: added: iso-testing
Changed in ubuntu-release-notes:
assignee: nobody → Jurhan Bazari (jurhanbazari)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers