kubuntu - plymouth not shown

Bug #1171099 reported by Fabio Marconi on 2013-04-21
54
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Andy Whitcroft
kubuntu-settings (Ubuntu)
High
Harald Sitter
Raring
Medium
Harald Sitter
Saucy
High
Harald Sitter

Bug Description

=== Release notes text ===

On boot of the installed system the graphical display is not initialised until late in the boot exposing boot messages unnecessarily. Updating kubuntu-settings will resolve this for subsequent boots.

===

SRU: kubuntu-settings
----
[Impact]
After installation Kubuntu will not show a boot splash until update-grub is triggered. Instaed it will display native tty output which not only looks bad but can worry users for no good reason (such as bluetooth daemon startup saying 'fail' simply because there is no adaptor).

[Test Case]
Boot Kubuntu; there should be a graphical boot splash.

[Regression Potential]
None. The post-installation fix/workaround is a no-change upload of kubuntu-settings to trigger update-grub via the plymouth theme's postinst script.

----
Original Description
----

Hallo
Testing kubuntu 20130421 amd64, at the start plymouth is not shown, only vt.
Attached screenshot with lvm passphrase request.
Reproduced in vbox and real hardware
Thanks
Fabio

ProblemType: BugDistroRelease: Ubuntu 13.04
Package: plymouth 0.8.8-0ubuntu6
ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
Uname: Linux 3.8.0-19-generic x86_64
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
CurrentDmesg:
 [ 18.232161] intel8x0: measured clock 227115 rejected
 [ 18.232162] intel8x0: clocking to 48000
 [ 18.817762] init: plymouth-upstart-bridge main process (791) killed by TERM signal
Date: Sun Apr 21 11:05:24 2013
DefaultPlymouth: /lib/plymouth/themes/kubuntu-logo/kubuntu-logo.plymouth
InstallationDate: Installed on 2013-04-21 (0 days ago)
InstallationMedia: Kubuntu 13.04 "Raring Ringtail" - Release amd64 (20130421)
Lsusb:
 Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: innotek GmbH VirtualBox
MarkForUpload: True
ProcCmdLine: BOOT_IMAGE=/vmlinuz-3.8.0-19-generic root=/dev/mapper/kubuntu--vg-root ro
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.8.0-19-generic root=/dev/mapper/kubuntu--vg-root roSourcePackage: plymouth
TextPlymouth: /lib/plymouth/themes/kubuntu-text/kubuntu-text.plymouth
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.board.name: VirtualBox
dmi.board.vendor: Oracle Corporation
dmi.board.version: 1.2
dmi.chassis.type: 1
dmi.chassis.vendor: Oracle Corporation
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH

Fabio Marconi (fabiomarconi) wrote :
Fabio Marconi (fabiomarconi) wrote :

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

description: updated
tags: added: kubuntu
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1171099

tags: added: iso-testing
description: updated
summary: - kubuntu - plymouth not showed
+ kubuntu - plymouth not shown
description: updated
Changed in plymouth (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plymouth (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) wrote :

> ProcCmdLine: BOOT_IMAGE=/vmlinuz-3.8.0-19-generic root=/dev/mapper/kubuntu--vg-root ro

This shows that your system has been booted without the 'splash' option - so the console-only prompt is the expected behavior. Was this how the bootloader was configured after install, or are you doing something to pass non-default options to the kernel?

Changed in plymouth (Ubuntu):
status: Confirmed → Incomplete
Steve Langasek (vorlon) wrote :

I have just reproduced this problem here in a VM. Apparently, a freshly-installed Kubuntu 13.04 system does not set either 'quiet' or 'splash' in the kernel commandline. Reassigning to ubiquity.

affects: plymouth (Ubuntu) → ubiquity (Ubuntu)
Changed in ubiquity (Ubuntu):
status: Incomplete → Confirmed
Steve Langasek (vorlon) wrote :

Suggested text for a release note:

 A bug in the installer for Kubuntu 13.04 causes users to be shown a console screen with verbose kernel messages after install instead of the expected Kubuntu splash screen. Users can work around this bug by running the following commands:

  sudo sed -i -e's/^GRUB_CMDLINE_LINUX_DEFAULT=/&"quiet splash"/' /etc/default/grub
  sudo update-grub

Changed in kubuntu-settings (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Harald Sitter (apachelogger)
Changed in kubuntu-settings (Ubuntu Saucy):
status: Triaged → Invalid
Changed in kubuntu-settings (Ubuntu Raring):
status: New → Triaged
importance: Undecided → Critical
importance: Critical → Medium
assignee: nobody → Harald Sitter (apachelogger)
Changed in kubuntu-settings (Ubuntu Saucy):
importance: Medium → Undecided
assignee: Harald Sitter (apachelogger) → nobody
description: updated
description: updated
Changed in kubuntu-settings (Ubuntu Raring):
status: Triaged → In Progress
Alexis (alxju) wrote :

"quiet splash" in present in /etc/default/grub but i (still) have this issue.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu Raring):
status: New → Confirmed

Hello Fabio, or anyone else affected,

Accepted kubuntu-settings into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/kubuntu-settings/1:13.04ubuntu12 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in kubuntu-settings (Ubuntu Raring):
status: In Progress → Fix Committed
tags: added: verification-needed
Harald Sitter (apachelogger) wrote :

Analysis of the problem:

<apachelogger> slangasek, ScottK: I think kubuntu-settings-desktop (providing etc/default/grub.d/05_kubuntu.cfg) needs to pre-depend grub-pc ... grub-pc.postinst looks for etc/default/grub OR etc/default/grub.d/* and if found it will try to read the grub_default_cmdline from there, however since 05_kubuntu does not define the cmdline it ends up empty (as seen on the kubuntu iso's default/grub)
<apachelogger> grub-installer then runs update-grub on /target and only afterwards injects "quiet splash" as default without re-running update-grub, hence why after grub-installer ran the config appears in order on the target system but the grub.cfg does not

And ramblings on the proposed solution for saucy, pending discussion:
<apachelogger> kubuntu-settings-desktop needs to pre-depend grub
<apachelogger> but since active probably uses -desktop that sounds le fishy
<apachelogger> so perhaps we need kubuntu-settings-grub
<apachelogger> so kubuntu-settings-desktop suggests kubuntu-settings-grub pre-depends grub-pc
<apachelogger> desktop seed recommends kubuntu-settings-grub
<apachelogger> also that way a user may use something other than grub

Changed in kubuntu-settings (Ubuntu Saucy):
assignee: nobody → Harald Sitter (apachelogger)
importance: Undecided → High
status: Invalid → Triaged
Changed in ubiquity (Ubuntu Raring):
status: Confirmed → Invalid
Changed in ubiquity (Ubuntu Saucy):
status: Confirmed → Invalid
Scott Kitterman (kitterman) wrote :

The proposed raring problem resolves the issue for me.

tags: added: verification-done
removed: verification-needed
Fabio Marconi (fabiomarconi) wrote :

Fix for me too, but jump into bug 1083190
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

bear7 (bear7) on 2013-05-04
Changed in kubuntu-settings (Ubuntu Raring):
status: Fix Committed → Fix Released
Alexis (alxju) wrote :

Not fixed for me with the proposed packages.

Harald Sitter (apachelogger) wrote :

Then it's a different issue, unless you were doing upgrades during installation which may not work around that (IIRC updates are installed before grub-installer is ran). To that extent the fix is only partial, but I don't think there is much opportunity for improvement unfortunately, due to exactly that fact.

Alexis (alxju) wrote :

I made a clean install (except home partition) of Kubuntu 13.04 beta. I made all updates including proposed packages.

Scott Kitterman (kitterman) wrote :

Don't use the beta images anymore. Use the final ones. Do the install with those, then update to the proposed packages. If that doesn't solve it, you have a different bug. Also, this is still fix committed, since the new package hasn't been released to -updates yet.

Changed in kubuntu-settings (Ubuntu Raring):
status: Fix Released → Fix Committed
Alexis (alxju) wrote :

Other people can confirm that is really fixed?

Adolfo Jayme (fitojb) on 2013-05-06
no longer affects: ubiquity (Ubuntu)
no longer affects: ubiquity (Ubuntu Raring)
no longer affects: ubiquity (Ubuntu Saucy)

On a fresh install, it was fixed for me once I ran the updates and rebooted.

Alexis (alxju) wrote :

I follow your advice, Scott. To fixe that bug i've reinstalled my OS (great logic).
On the bootable key and after the install, on the first boot, plymouth was ok.

But on my system, KDE and all the system totaly freeze with the free graphic driver.

On rescue mode, i've installed nvidia-current (304) to be able to use kde.

After that, plymouth was again buggy, just like before. But, finaly, i found a way to fix that using superbootmanager (http://www.sourceslist.eu/projects/super-boot-manager/). Superbootmanager/plymouthmanager has an option to fix plymouth issues with non-free graphic driver. And THAT fixed that bug.

Thank you for your great help .
Thank you encourage people to try the beta release and report bugs.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Scott Kitterman (kitterman) wrote :

OK, then you are experiencing a different bug than this one (even though the symptoms are similar). You should file a new bug.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-settings - 1:13.04ubuntu12

---------------
kubuntu-settings (1:13.04ubuntu12) raring-proposed; urgency=low

  * No-change upload to trigger update-grub to ensure that the boot entries
    contain 'quiet splash' (LP: #1171099)
 -- Harald Sitter <email address hidden> Mon, 29 Apr 2013 14:56:17 +0200

Changed in kubuntu-settings (Ubuntu Raring):
status: Fix Committed → Fix Released
Jonathan Riddell (jr) on 2013-07-04
Changed in kubuntu-settings (Ubuntu Saucy):
milestone: none → ubuntu-13.10
Harald Sitter (apachelogger) wrote :

Should be fixed through grub postinst fixes in saucy.

Changed in kubuntu-settings (Ubuntu Saucy):
status: Triaged → Fix Released
Andy Whitcroft (apw) on 2013-10-17
description: updated
Changed in ubuntu-release-notes:
assignee: nobody → Andy Whitcroft (apw)
status: New → In Progress
Andy Whitcroft (apw) on 2013-10-17
Changed in ubuntu-release-notes:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers