The recommender should always return a full set of recommendations on a recommend_me, even if they are somewhat generic

Reported by Gary Lasker on 2012-03-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-recommender
Medium
Łukasz Czyżykowski

Bug Description

Currently, if a person opts into the recommendations service in the Ubuntu Software Center but has not yet actually reviewed/rated any software, then zero results are returned by the recommend_me call. This has the the unpleasant result that Software Center hides the panel (this hiding is a side-effect of the fact that this code in USC is shared with the categories screen recommendations and with the current implementation it's a valid condition that there may be no uninstalled recommended items for any given category).

Anthony mentioned that this will change and a full set of recommendations will always be returned on opt-in once we start using the uploaded profile data, but currently it is the case. So, before Precise goes out, we will have to do one of:

  1. Implement the ratings based on profile data functionality, such that a full set of recommendations are returned, or
  2. We always return a full set of recommendations, even if they are initially somewhat generic as we continue to fine-tune the recommender.

Of course, a third possibility is to prompt the user to review/rate some items after opt-in for the case where no items are returned, but that doesn't seem a satisfactory user experience.

So, in summary, the goal is that we always return a full set of 60 items on a recommend_me call, and we fine tune that set as the recommender engine is tuned.

Changed in ubuntu-recommender:
status: New → Confirmed
importance: Undecided → Medium
Changed in ubuntu-recommender:
assignee: nobody → Łukasz Czyżykowski (lukasz-czyzykowski)
Changed in ubuntu-recommender:
status: Confirmed → In Progress
Changed in ubuntu-recommender:
status: In Progress → Fix Committed
Changed in ubuntu-recommender:
status: Fix Committed → Confirmed
Gary Lasker (gary-lasker) wrote :

As the software-center client and server teams have discussed on IRC during the week, the current fix can return too few results (sometimes just a single item) to prevent the usability issue described in the bug description. That is, the unexpected disappearance of the recommendations panel after opt-in. The reason this can happen is because we do not display recommended items if they are currently installed on the computer, so a small list of recommendations has a high probability of hitting an item that is installed, with the result that the panel is hidden.

If possible, a full set of 60 items would be ideal, as this will also help insure that there will be a good chance of recommendations in the categories screens as well.

Many thanks!

Gary Lasker (gary-lasker) wrote :

I'll set this to in-progress, as I believe that Łukasz already has this one underway.

Thanks again!!

Changed in ubuntu-recommender:
status: Confirmed → In Progress
Dave Morley (davmor2) on 2012-04-10
Changed in ubuntu-recommender:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers