Ubuntu SDK does not install on clean 12.04 LTS (64bit)

Bug #1281814 reported by Peter Hooper on 2014-02-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
[obsolete] Ubuntu QtCreator Plugins
Undecided
Unassigned

Bug Description

I have a VM of a clean 12.04 64bit - taken from our Continuous Integration system so it is a tried and tested VM. However, when using it and following the instructions on the site (http://developer.ubuntu.com/apps/create/get-the-sdk/) it fails to install. I have mangaed to track down the failed dependencies to this:

$ sudo apt-get install qtdeclarative5-ubuntu-ui-toolkit-plugin
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
qtdeclarative5-ubuntu-ui-toolkit-plugin : Depends:
qtdeclarative5-unity-action-plugin (>= 1.1.0)
but 1.0.0bzr25precise0 is to be installed
E: Unable to correct problems, you have held broken packages.

I have found that there is a 2.8.1.2bzr90precise0 here :
    https://launchpadlibrarian.net/166279521/qtcreator-plugin-ubuntu_2.8.1.2bzr90precise0_amd64.deb

However attempting to install this results in:

$ sudo dpkg -i /home/smokey/Downloads/qtcreator-plugin-ubuntu_2.8.1.2bzr90precise0_amd64.deb
Selecting previously unselected package qtcreator-plugin-ubuntu.
(Reading database ... 265942 files and directories currently installed.)
Unpacking qtcreator-plugin-ubuntu (from .../qtcreator-plugin-ubuntu_2.8.1.2bzr90precise0_amd64.deb) ...
dpkg: dependency problems prevent configuration of qtcreator-plugin-ubuntu:
 qtcreator-plugin-ubuntu depends on android-tools-adb; however:
  Package android-tools-adb is not installed.
 qtcreator-plugin-ubuntu depends on devscripts; however:
  Package devscripts is not installed.
 qtcreator-plugin-ubuntu depends on libqt5scripttools5; however:
  Package libqt5scripttools5 is not installed.
 qtcreator-plugin-ubuntu depends on ubuntu-ui-toolkit-doc; however:
  Package ubuntu-ui-toolkit-doc is not installed.
 qtcreator-plugin-ubuntu depends on ubuntu-ui-toolkit-examples; however:
  Package ubuntu-ui-toolkit-examples is not installed.
dpkg: error processing qtcreator-plugin-ubuntu (--install):
 dependency problems - leaving unconfigured
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Errors were encountered while processing:
 qtcreator-plugin-ubuntu

The documentation suggests that the SDK is compatible with 12.04, so how come it can't be installed with a clean VM? Am I missing some other dependency that is not included in the documentation? Is the PPA broken?

Peter Hooper (pdhooper) wrote :

This bug has been marked as obsolete ... what does that mean? That 12.04 is not supported? If so why as its the current LTS release and its the only version you can buy on a new machine?

Peter Hooper (pdhooper) wrote :

Whoops! My mistake it was linked through to an obsolete bug automagically - interesting!

Peter Hooper (pdhooper) wrote :

OK. I have managed to get the SDK installed now. So my next task it to repeat it again on a clean VM and this time record exactly what is wrong and what actually fixed it. What I think fixed it was purging the ppa (using ppa-purge) after the installation of qtcreator-plugin-ubuntu_2.8.1.2bzr90precise0_amd64.deb and then the command "sudo apt-get install ubuntu-sdk" worked. But I want to confirm this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers