Click packaging should also support Cordova HTML apps

Bug #1216046 reported by Pat McGowan on 2013-08-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
[obsolete] Ubuntu QtCreator Plugins
Critical
Zoltan Balogh
qtcreator (Ubuntu)
Undecided
Unassigned

Bug Description

Currently the support is restricted to QML apps. We also need click packaging for cordova apps.

Zoltan Balogh (bzoltan) on 2013-08-25
Changed in ubuntu-qtcreator-plugins:
status: New → Confirmed
Zoltan Balogh (bzoltan) wrote :

Raising importance, as we do want to enable cordova apps in the contest.

Changed in ubuntu-qtcreator-plugins:
importance: High → Critical
Zoltan Balogh (bzoltan) wrote :

The 2.7.1-0ubuntu5~[saucy/raring/quantal/precise]1~test7 version of the QtCreator in the SDK Staging PPA (https://launchpad.net/~ubuntu-sdk-team/+archive/staging) has the fix.

Changed in ubuntu-qtcreator-plugins:
status: Confirmed → Fix Committed
tags: added: appstore
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtcreator (Ubuntu):
status: New → Confirmed
Jamie Strandboge (jdstrand) wrote :

I tried 2.7.1-0ubuntu7~saucy1~test3 from the staging ppa, and I see the following:
Searching for desktop file..
 /!\ no desktop file found /!\
  You will have to create one.

[08:12:04] ls: cannot access *.desktop: No such file or directory
[08:12:04] ls: cannot access *.desktop: No such file or directory
ls: cannot access *.qmlproject: No such file or directory

It looks like cordova projects use *.cordovaproject instead of *.qmlproject.

Once I created the desktop file, the click packaging worked. It would be nice to create a desktop file. Here is an example:
[Desktop Entry]
Name=test-cordova
Comment=Description of test-cordova
Exec=cordova-ubuntu-2.8 .
Icon=...
Terminal=false
Type=Application
X-Ubuntu-Touch=true

Note that for now the Exec line must be cordova-ubuntu-2.8, but this could conceivably change in the future (see bug #1216066).

Zoltan Balogh (bzoltan) on 2013-08-26
Changed in ubuntu-qtcreator-plugins:
status: Fix Committed → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtcreator - 2.7.1-0ubuntu7

---------------
qtcreator (2.7.1-0ubuntu7) saucy; urgency=low

  * debian/patches/qtcreator-plugin-ubuntu.patch:
    - Support manifest format which is compatible with click hooks
      (LP: #1214623)
    - The title is filled with the application name in the manifest
      (LP: #1214626)
    - The description field is added to the manifest file (LP: #1214612)
    - Some initial work on #1215133: Replace "_" with "-" in the name of the
      security manifest file
    - Enable Click packaging for Cordova projects (LP: #1216046)
 -- Timo Jyrinki <email address hidden> Mon, 26 Aug 2013 09:48:45 +0300

Changed in qtcreator (Ubuntu):
status: Confirmed → Fix Released
Zoltan Balogh (bzoltan) wrote :

The .desktop is added to the template

Changed in qtcreator (Ubuntu):
status: Fix Released → Fix Committed
Changed in ubuntu-qtcreator-plugins:
status: Confirmed → Fix Committed
Zoltan Balogh (bzoltan) wrote :

The 0.1bzr15 version of the qtcreator-plugin-ubuntu in the SDK PPA will hold the fix

Zoltan Balogh (bzoltan) wrote :

The 0.1-0ubuntu3 version of the qtcreator-plugin-ubuntu-cordova-common, qtcreator-plugin-ubuntu-common packages in the archive fix this issue.

Changed in ubuntu-qtcreator-plugins:
status: Fix Committed → Fix Released
Changed in qtcreator (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers