Gmail messages might be missed after clearing notifications

Bug #1451510 reported by Niklas Wenzel on 2015-05-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Pat McGowan
Ubuntu Push Notifications
Fix Released
Undecided
Niklas Wenzel
ubuntu-push (Ubuntu)
Undecided
Niklas Wenzel
Vivid
Undecided
Niklas Wenzel

Bug Description

IMPORTANT: Please install the fix for LP: #1434521 or don't use the "Clear all" button for removing messages.

Sometimes no notifications are shown for emails which arrive directly after clearing existing notifications from the messaging menu.

How to reproduce:

1) Send yourself three emails and wait for the Gmail overflow item to appear in the messaging menu.
2) Remove all Gmail notifications from the messaging indicator.
3) Immediately send yourself another mail.

Expected behaviour:

Another notification should be shown the next time account-polld is poked.

What happens:

No notification is shown.

Why that happens:

ubuntu-push still passes the removed messages to account-polld (ignoring the Gone flag that was set). Therefore, it believes those are still being shown and doesn't display another one.

Related branches

Niklas Wenzel (nikwen) on 2015-05-04
Changed in ubuntu-push (Ubuntu):
assignee: nobody → Niklas Wenzel (nikwen)
Niklas Wenzel (nikwen) on 2015-05-04
Changed in ubuntu-push (Ubuntu):
status: New → In Progress
Niklas Wenzel (nikwen) wrote :

Sorry, that one was against the wrong branch. Here's the correct one now:

https://code.launchpad.net/~nikwen/ubuntu-push/gmail-messages-missed-fix/+merge/258207

Samuele Pedroni (pedronis) wrote :

first attempt at fix landing didn't pass QA

Niklas Wenzel (nikwen) wrote :

Yes, I haven't had time to look into it again but I'll do so as soon as possible.

Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → ww34-2015
status: New → Confirmed
assignee: nobody → Pat McGowan (pat-mcgowan)
Niklas Wenzel (nikwen) wrote :

Hi Pat,

I know I haven't worked on this for a while (mostly because of illness and other real life issues) but I am confident I will get this fixed within the next two or three weeks, so it should be there early enough to be included in OTA-6. ;)
I'd be glad if you let it assigned to me. (I already know how I want to fix it.)

Cheers,
Niklas

Niklas Wenzel (nikwen) on 2015-07-07
Changed in ubuntu-push:
assignee: nobody → Niklas Wenzel (nikwen)
Changed in ubuntu-push (Ubuntu Vivid):
assignee: nobody → Niklas Wenzel (nikwen)
Niklas Wenzel (nikwen) wrote :

Having a much better implementation sitting here right now. I'll just have to create one more unit test. :)

Niklas Wenzel (nikwen) on 2015-07-14
Changed in ubuntu-push:
status: New → In Progress
Niklas Wenzel (nikwen) wrote :

Here we go. :)
https://code.launchpad.net/~nikwen/ubuntu-push/gmail-missed-messages-fix-new/+merge/264765

Sadly, this MP is still against trunk instead of automatic as there are conflicts with automatic's r403. Therefore, I vote for reverting that revision and then merging the new branch.

Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Samuele Pedroni (pedronis) wrote :

we have packages with the latest iteration of the fix ready for testing in silo:

https://requests.ci-train.ubuntu.com/static/dashboard.html#?q=ubuntu%2Flanding-017

( https://requests.ci-train.ubuntu.com/static/dashboard.html#?q=ubuntu%2Flanding-023 as the wily landing of it )

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-push - 0.68+15.10.20150814.1-0ubuntu1

---------------
ubuntu-push (0.68+15.10.20150814.1-0ubuntu1) wily; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Samuele Pedroni (Canonical Services Ltd.) ]
  * address lp:1451510 aggressively finding gone notifications in Tags()
    truncate runtime.Stack result to size, otherwise we log \x00s or old
    stuff (LP: #1451510)

 -- CI Train Bot <email address hidden> Fri, 14 Aug 2015 14:05:16 +0000

Changed in ubuntu-push (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-push (Ubuntu Vivid):
status: New → Fix Released
Changed in ubuntu-push:
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers