[jaunty ppc ps3] System uses LOG OFF instead of RESTART when required

Bug #400403 reported by Mihai Olimpiu Cristian on 2009-07-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu PS3 Port
Undecided
Unassigned

Bug Description

I don't know if this BUG affects only PPC Platform - PS3 Especially but it happened to me more than one occasion!

If for example I use UPDATE MANAGER and it updates a critical SYSTEM COMPONENT and the system says "RESTART REQUIRED" even if on the dialog box that appears you press RESTART the system only LOGS OFF (not a FULL RESTART), and the dialog box with RESTART REQUIRED appears again!

This only happens when the system needs a restart, restarting the system manually usually work fine!
I have ignored this until now but it seems to be somehow related to the FAST USER SWITCH APPLET that sometimes behaves the same way but I just assumed I hit the wrong option so I ignored this until now! (HARD TO TEST IT ANYWAY) - When pressing restart it just did a log off (that can just be me hitting the wrong option tough)!

Arnaud Jeansen (ajeans) wrote :

Is this on latest jaunty or on a older version ?

Jaunty FINAL PS3 [PPC flavor]... with the latest updates!
Any other info you need (like hardware connected to PS3) just ask if you think it's important!

Arnaud Jeansen (ajeans) wrote :

Based on the update manager source code from jaunty, the logic to restart on a distribution upgrade looks good (it calls "reboot".

DistUpgrade/DistUpgradeController.py:1569

        if self._view.confirmRestart():
            p = subprocess.Popen("/sbin/reboot")
            sys.exit(0)

It seems that this code is also used when upgrading a system component (e.g. kernel), but I am not 100% sure about this.

I understand from your description that "Restart Now" from update manager fails to reboot properly, but can you be more clear on which reboot methods are successful?

If I choose restart from the FAST USER SWITCH applet the system restarts ok every time... or even from the command line it goes ok (don't know the cmd line because I'm new to linux)... This only happens when the dialog box with RESTART REQUIRED is shown!

This happened when I upgraded DBUS package yesterday (for example) and on every occasion the SYSTEM asked for a restart.

Thank you for your help...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers