[ps3_gelic] [2.6.28] Networkmanager does not autoconnect/connect on first try to wireless

Bug #309457 reported by Tim Kornhammar on 2008-12-18
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu PS3 Port
Medium
Dan Munckton

Bug Description

This only applies to Intrepid 8.10 with a 2.6.28-rc8 custom built kernel.

For the updated kernel:
http://www.ludd.ltu.se/~scuba/debs/

UPDATE: this now also applies to the official 2.6.28 based Jaunty kernel too (Dan).

When starting up Ubuntu network manager does not connect do "default auto" wireless network.

When trying to connect to a wireless network for the first time it just tries to connect but does not succeed.
Fix: Turn off wireless (in nm), turn it on, connect.

Will try to fix some logs that could pin down the problem.

On Thu, Jan 22, 2009 at 09:25:59AM -0000, Dan Munckton wrote:
> ** Summary changed:
>
> - Networkmanager does not autoconnect/connect on first try to wireless
> + [2.6.28-rc8] Networkmanager does not autoconnect/connect on first try to wireless
>

please add the chipset to summary too while you are at it ;)...

 - Alexander

Dan Munckton (munckfish) wrote :

... and with the 2.6.28-1.6 Ubuntu official kernel?

Dan Munckton (munckfish) wrote :

Right having closed bug 289982, I'm moving attention to this. Something in the sequence of events as NM tries to bring up both eth0 and wlan0 at boot/login is messing things up.

Attached is a syslog that hopefully documents the problem. I recompiled the kernel to enable debug printks in drivers/net/ps3_gelic_*.c so there's plenty of detail about what the gelic_wireless driver is doing.

Essentially this log shows

1. Boot - ending with eth0 being brought up and plenty of wlan scanning
2. Me logging in (search for pam_sm_authenticate)
3. NM trying to connect to my wifi network (search for "starting connection 'Auto munckfish'")
4. Then what seems to be repeated failures to connect/associate delimited by ...

Feb 23 13:34:48 ps3 NetworkManager: <info> (wlan0): supplicant connection state: associating -> disconnected
Feb 23 13:34:48 ps3 NetworkManager: <info> (wlan0): supplicant connection state: disconnected -> scanning

and sometimes

Feb 23 13:34:55 ps3 NetworkManager: <info> wlan0: link timed out.

5. Then at some point NM applet pops up the pasword dialog (search for "asking for new secrets"), and we run through the same loop all over again.

Dan Munckton (munckfish) wrote :

If I unplug the ethernet cable, then reboot to follow the same sequence of steps as above, the wifi connection connects perfectly as soon as I login.

So far I've had fairly random results when I plug the network cable back in, sometimes it looks like both interfaces are up but neither working, sometimes both can be pinged but no network services can be connected to. Sometimes nm-applet pops up a notification saying I'm connected to my wifi network but the tray icon goes back to the wired logo, and the wifi is clearly not working. I've not worked out the exact pattern for this yet.

Dan Munckton (munckfish) on 2009-02-23
description: updated
Tim Kornhammar (tim-kornhammar) wrote :

What happens for you if you do my "fix" above (if it works)? Maybe it will narrow down the search...

Better explained reproduce:
1. Log in
2. Wait a few seconds on NM.
3. Disable wifi.
4. Enable wifi.
5. Connect to your hotspot.

Michael Flaig (mflaig) wrote :

Regarding the problem when wire and wifi is used...
both interfaces have the same mac address if I remember correctly. They shoud not be used in parallel.

Dan Munckton (munckfish) wrote :

Thanks Michael. I'm going to start asking some questions upstream and also with the other distros to see how this should best be handled.

Dan Munckton (munckfish) wrote :

Am now getting some help on this from upstream

http://ozlabs.org/pipermail/cbe-oss-dev/2009-March/006472.html

Changed in ubuntu-ps3-port:
assignee: nobody → munckfish
importance: Undecided → Medium
milestone: none → ubuntu-9.04
status: New → In Progress
Dan Munckton (munckfish) wrote :

Hi folks, finally managed to collect the logs for the test scenarios Mokuno-san asked me to run with his patch. In the attached zip are syslogs for the following:

1 FAIL: both managed by NM, on the same segment
2 SUCCESS: wlan0 managed by NM, eth0 unplugged
3 FAIL: wlan0 managed by NM, eth0 manually configured, connect to different segments
4 SUCCESS: both manually configured to different segments
5 SUCCESS: both manually configured, connecting to the same segment

I've not analysed the logs in detail yet, but it appears the problem only occurs when NetworkManager manages the wifi connection and eth0 is already connected to any network.

Also, my wifi network uses WPA1, I've checked and the same problem occurs using WPA2.

I also noted an out of memory exception coming from an ioctrl call when running wpa_supplicant manually after logging in, but I need to go back and collect a log of that, as I ran out of time.

Dan Munckton (munckfish) wrote :

This problem appears to have been resolved by one of the recent updates, probably to NetworkManager. Tim can you confirm the problem is gone?

Using latest ports versions:
linux-image-2.6.28-5-powerpc64-smp (2.6.28-5.14)
network-manager (0.7.1~rc3.2.gitb8fc83a7-0ubuntu1)

It definitely works a lot better but it does not connect automatically (I need to turn off/on the wifi).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers