No LAN nor WLAN connection, Ubuntu 8.10 on Ps3

Bug #298661 reported by Heroknotten on 2008-11-16
6
Affects Status Importance Assigned to Milestone
Ubuntu PS3 Port
Undecided
Unassigned

Bug Description

No LAN nor WLAN connection, Ubuntu 8.10 on Ps3
I have installed ubuntu-8.10-alternate-powerpc+ps3.iso on m Ps3 (Ps3 is updated w latest software). And I have tried for a few days to get my Ps3 online. Both wireless and wired network works well when I use Ps3, but nothing works from Ubuntu on the Ps3.
I didn’t find any MD5Sum for the download, but the installastion seems fine.
1. The wireless never starts up. I see on the net that I should set it up as a hidden network (WEP), but I don’t find that option. It doesn’t help to turn WEP of on the network either.
2. The wired sends its MAC to router and get an IP addr back, but there it stops. This works without any probl from Ps3. But when I look at the Network Connection, it shows no acctivity last 8 hours.
3. When I try to ping the router, access the router or an other net, I get no connection. This is strange since it looks like I am connected to the router. The router even shows the Ubuntu name I choosed.
4. When I release the wired from the router, Device - Network Tools still shows IP addr = 192.168.1.194 and keeps counting received packets, here = 51, but the connection is released from the router.
5. And the Active Network Connections shows that I am connected.
6. Does Ps3 have 1 or 2 MAC addr (wired and wireless)? My computer has to diff, but I can only find one at the Ps3.

See Screen Dumps for details mentioned above.

All these makes me very confused. So please help.
What I want is to get the Ps3 Ubuntu online through wireless WLAN.

I see there is a securit update; linux-image-2.6.27-7.15 (Ubuntu Security Notice USN-661-1), but I don’t know which update to download, since there are so many of them. And the links listed on the page don’t work.

Sorry if I made this to long, but I am new to Linux and Ps3. So please help me out and be a bit detailed in your feedback.

No-gick from Norway

Heroknotten (stein-maka) wrote :
TJ Scott (rage-octane) wrote :

so far my internet is working fine with 8.10. Most guides on Intrepid installation say to opt for wired network connection first. the ubuntu install should detect it as eth0, and wlan0 under your choices. theoretically you need to set up your wireless connection there, but I haven't tried, manually setting up a wifi in terminal doesn't seem fun, :). For the best results so far I would recomend using the automatic network config during the installation of ubuntu 8.10 under the ethernet connection. I haven't got my wireless to work yet, but untill then I'm using a wirelessly bridged connection with a game adapter.

Dan Munckton (munckfish) wrote :

@Heroknotten is this still a problem? If so please recreate the issue and attach the following log here:

/var/log/daemon.log
/var/log/messages

Thanks

Heroknotten (stein-maka) wrote :

Hi TJ and Dan

The problem is still not solved. After reinstalling 8.10 several times I have found out that the wired works if I choose wired during the installation. If I choose wireless during the installation, I can’t get wireless nor wired to work even it looks like “Network connection” does allow me to choose it. I feel there must be a bug in the Network connection, but so far I haven’t made bug report for it.
But, I still want the Ps3 to be able to run on wireless, so please help out.

During the process of testing out different solutions, my Ps3 has hang several times and I have been forced to reinstall 8.10 several times, which takes hours. So first I need to find a way to avoid this, or find a way to restart my Ps3 on the old configuration. Please help me out on this one first, see bug/320025 for more details.

Thanks

qbix (the-rape-of-the-land) wrote :

Ubuntu 8.10 on Playstation 3 / PS3 WLAN works (some tags for the search engines)

I get wireless to work but only by doing a "Connect to Hidden Wireless Network..." (left-click the network manager icon in the top right corner of the screen). I use WEP encryption with 128 bit key, connecting to a D-LINK DI-624 54Mbps router/access point. It is important that the first network setup I do after boot is to (re-) connect to the WLAN using the save configuration. If I try to fiddle around with other wired/wireless connections (I have an "auto" connect flavor of my working WLAN connection which does not work), wireless will not work and I have to reboot and start again.

WLAN in PS3 XMB always worked perfect.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers