Sound not working via hdmi cable on ps3

Bug #290352 reported by damikki on 2008-10-28
4
Affects Status Importance Assigned to Milestone
Ubuntu PS3 Port
Undecided
Unassigned

Bug Description

I have just installed from the 27th Oct daily build of Ubuntu 8.10 for the PS3 everything works well except for sound. Although I have desktop sounds enabled and my user account is in the audio group I have no sound from within the gnome desktop. I have already ran a software update and rebooted but still no luck. Doing an lsmod shows the sound modules are loaded as expected and I am also able to change the volume level using the gnome volume applet.

Tim Kornhammar (tim-kornhammar) wrote :

I get sound when using OSS as audio module in Mplayer. Probably only something with Pulse-audio and not HDMI.

damikki (damikki) wrote :

I have set OSS for sound playback in gnome sound preferences but when I do a test I have no sound output ?

damikki (damikki) wrote :

Maybe this could explain the issue with pulse audio : -

root@ps3:/usr/lib# tail /var/log/messages | grep pulseaudio
Oct 29 08:53:37 ps3 pulseaudio[4855]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
Oct 29 08:53:37 ps3 pulseaudio[4855]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
Oct 29 09:21:16 ps3 pulseaudio[5251]: ltdl-bind-now.c: Failed to find original dlopen loader.
Oct 29 09:21:17 ps3 pulseaudio[5251]: pid.c: Stale PID file, overwriting.
Oct 29 09:21:17 ps3 pulseaudio[5251]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
Oct 29 09:21:17 ps3 pulseaudio[5251]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted

Dan Munckton (munckfish) wrote :

I fully updated my PS3 system last night and sound still worked fine for me. I also use an HDMI cable to connect to my TV.

damikki have you followed the instructions on the Sound Debugging page?

  https://wiki.ubuntu.com/DebuggingSoundProblems

If you still can't get it working could you run that also-info.sh script mentioned at the end of that page and upload the output here?

Could you please also upload your full /var/log/messages file?

Changed in ubuntu-ps3-port:
status: New → Incomplete
damikki (damikki) wrote :

Hi Dan,

Thanks for the quick reply, I have carried out the instructions in the wikki as requested, here's the results: -

damikki@ps3:~$ cat /proc/asound/cards
 0 [PS3 ]: PS3 - PS3
                      PS3 sound

Adding this options snd-usb-audio index=1 to the /etc/modprobe.d/alsabase causes all the sound devices listed in System -> Preferences -> Sound to fail during a test with a message that the device is already in use by another application. I have tested them all several times but none produce any sound and only pulseaudio fails with an error message: -

audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Failed to connect: Connection refused

I am in the Audio group so there is a tick in the Use Audio Devices item listed in groups.

The results of the alsa-info.sh script are attached as well as my messages file as requested.

Many Thanks

damikki (damikki) wrote :

My /var/log/messages

damikki (damikki) wrote :

Hi Dan,

Have you had a chance to look at this yet ? Or do you need any further information from me ?

Many Thanks

Mikki

Dan Munckton (munckfish) wrote :

Hi Mikki.

No sorry I haven't had a chance to get to this yet, and I probably won't get to it till I've dealt with the 2 wireless issues. In the meantime any footwork you can do to get to the bottom of it will help loads later (I'm only a volunteer too you see). Otherwise I'll get on to this as soon as I can.

Cheers

Dan

damikki (damikki) wrote :

Thanks Dan,

It appears to work if I power cycle my TV after Ubuntu has booted. I have a 19" Samsung Sync Master LCD TV, something during the boot process cause the TV's HDMI to initialise picture OK but the sound fails to sync correctly.

The TV worked fine in 7.10 and YellowDog 6 as this only occurs with Ubuntu 8.10

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers