no progress information while extracting templates

Bug #289973 reported by Dan Munckton on 2008-10-27
4
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
Ubuntu PS3 Port
Low
Unassigned
debconf (Ubuntu)
Medium
Unassigned

Bug Description

Using the alternate installer (daily build 2008-10-24, and previous others) progresses to the "Selecting and installing software" section and then hangs at 6% for about 20 minutes.

In this time there is a lot of CD-ROM disk activity. Watching the syslog (which I will attach later) nothing is logged for about 10mins then it starts the logging the following for a further 10 mins:

in-target: Extracting templates from packages: 18%
in-target: Extracting templates from packages: 36%
in-target: Extracting templates from packages: 55%
in-target: Extracting templates from packages: 73%
in-target: Extracting templates from packages: 92%
in-target: Extracting templates from packages: 100%

Dan Munckton (munckfish) wrote :

TODO: Need to attach logs.

Changed in ubuntu-ps3-port:
importance: Undecided → Low
status: New → Incomplete
Changed in debian-installer:
status: New → Incomplete
Dan Munckton (munckfish) wrote :

Suggested release note:

"The PS3 alternate installer will progress to the "Selecting and installing software" section and then hang at 6% for about 20 minutes. Please don't be concerned it is working successfully in the background."

Dan Munckton (munckfish) wrote :

Attaching the installer syslog. Seems the 20 min gap happens while the installer is "downloading" all the packages required for the install from the CD-ROM. I think all that would be needed is progress bar feedback that something is happening.

Changed in ubuntu-ps3-port:
status: Incomplete → Triaged
Changed in debian-installer:
status: Incomplete → Confirmed
Colin Watson (cjwatson) wrote :

While it's not actually quite the same bug, I think this is covered by the more general release note I wrote for bug 290234. Fixing this properly will probably require work in debconf.

Changed in ubuntu-release-notes:
status: New → Fix Released
Changed in debian-installer:
importance: Undecided → Medium
status: Confirmed → Triaged
Dan Munckton (munckfish) wrote :

Yeah I'm certain this is the same as bug 290234. However, I want to leave this one open just for a few weeks as it's title clearly describes the symptom on PS3, and will hopefully prevent folks who missed the release notes from re-raising this issue.

Colin Watson (cjwatson) wrote :

I was going to mark this as a duplicate of bug 290234, but it really isn't quite the same thing. That was about lack of progress information while downloading packages; I'm keeping this one for the lack of progress information while extracting templates from packages.

affects: debconf (Ubuntu) → apt (Ubuntu)
affects: apt (Ubuntu) → debconf (Ubuntu)
summary: - PS3 Alternate Installer: hangs at 6% for about 20 minutes
+ no progress information while extracting templates
JC Hulce (soaringsky) wrote :

The related bug has long since been fixed. Does this bug still exist?

Changed in debconf (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers