PS3: Immediate boot hang with blank screen

Bug #285218 reported by Dan Munckton on 2008-10-17
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
Ubuntu PS3 Port
Status tracked in Jaunty
Jaunty
Critical
Unassigned
kboot-installer (Ubuntu)
Medium
Colin Watson
Intrepid
Medium
Colin Watson
Jaunty
Medium
Colin Watson
usplash (Ubuntu)
Undecided
Dan Munckton
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned

Bug Description

Ok. Grrr. Intrepid was working fine only last week! Rant over.

SYMPTOMS

Fresh install from 2008-10-17 ps3 alternate disk for Intrepid.

Scenario 1: After kboot kexec's the target system the screen goes blank. Nothing happens. No disk activity. Nothing. Magic SysRq keys don't do anything.

Scenario 2: Booting without "quiet" and "splash" kernel args. This time kernel seems to boot ok, normal boot messages run by. However just as GDM starts screen goes blank. A couple of times I was able to use Magic SysRq keys to do a controlled reboot from here (not sure I can do that consistently). **UPDATE with the fix for bug #281610 X now starts fine in this scenario.**

Scenario 3: Boot using "single" arg to get into the recovery mode. Go to the root shell, run usplash -v. Blank screen.

LOGS

No obvious errors dmesg, messages, kern.log log file.

Dan Munckton (munckfish) on 2008-10-17
Changed in ubuntu-ps3-port:
assignee: nobody → munckfish
importance: Undecided → Critical
milestone: none → ubuntu-8.10
status: New → Confirmed
Dan Munckton (munckfish) wrote :

Using a newer version of ps3-kboot (from Geoff L's distro kit 20080609) doesn't improve the situation.

Dan Munckton (munckfish) wrote :

Every now and then the blank screen on boot is accompanied by a sustained high pitch tone. Ouch!

Dan Munckton (munckfish) wrote :

I believe the Xorg startup problems were caused by bug #281610 so we are probably just dealing with a usplash issue now.

description: updated
Dan Munckton (munckfish) on 2008-10-23
Changed in ubuntu-ps3-port:
status: Confirmed → In Progress
Changed in usplash:
assignee: nobody → munckfish
status: New → In Progress
Dan Munckton (munckfish) wrote :

Running usplash from the recovery shell (as root)

usplash -v -c > /root/usplash.log 2>&1

Screen goes blank, cannot switch VTs using Ctrl+Alt+F[1-8], machine doesn't respond to Magic SysRq keys. After a hard reset no log has been written to /root/usplash.log.

Investigation continues ...

Colin Watson (cjwatson) on 2008-10-24
Changed in kboot-installer:
assignee: nobody → kamion
importance: Undecided → Medium
milestone: none → ubuntu-8.10
status: New → Triaged
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kboot-installer - 0.0.1ubuntu8

---------------
kboot-installer (0.0.1ubuntu8) intrepid; urgency=low

  * Disable usplash, since it's currently broken (LP: #285218).

 -- Colin Watson <email address hidden> Fri, 24 Oct 2008 11:15:55 +0100

Changed in kboot-installer:
status: Fix Committed → Fix Released
Dan Munckton (munckfish) wrote :

Interesting thread in the upstream cbe-oss-dev list sort of shows something has changed in the ps3fb since the 2.50 firmware update. Apparently the ps3vram driver no longer works and hangs machine:

http://ozlabs.org/pipermail/cbe-oss-dev/2008-October/005735.html

So will not rule out the affects of this firmware upgrade on usplash, need to dig into the usplash code to try and see where the failure occurs.

Beyil (rjbgolding) wrote :

I just atempted to load in hte live CD install 27 oct 2008 build. I have the latest firmware release ... I also get this... the no splash option also had same result.. screen goes black after a few lines of tect go by then does a hard lock... ctrl alt f1-8 does nothing. I have to use the reset option on the ps/3 by holding its power to reboot it.

Dan Munckton (munckfish) wrote :

Suggested text for the release notes:

"The graphical boot splash (usplash) is disabled for the PS3 as it mysteriously stopped working shortly before the Intrepid Release Candidate milestone and now hangs the system. PS3 users upgrading from Hardy *MUST* edit their /etc/kboot.conf and change all occurrences of the "splash" boot parameter to "nosplash", otherwise it will be much more difficult (but not impossible) getting it to boot post upgrade. Users doing a fresh install will not need to change anything."

Bipin (bips3421) wrote :

I tried a fresh install from the image http://cdimage.ubuntu.com/ports/daily-live/current/intrepid-desktop-powerpc.iso and am stuck with the same problem. I tried different install options with different video modes but it always it goes into a blank screen with no response. I always have to power off and then press the PS3 button for few seconds to get back into XMB mode.

On Wed, 2008-10-29 at 16:48 +0000, Bipin wrote:
> Sorry.. correct link to installed image is
> http://cdimage.ubuntu.com/ports/daily-live/current/intrepid-desktop-
> powerpc+ps3.iso
>

The daily live is broken. Only the 'alternate' installer works. The
'live' or 'desktop' flavour will not be published in the final release.
We're so close now, I'd recommend waiting and downloading the final disk
when it's released. Look out for the link on the front of psubuntu.com.

Cheers

Dan

Colin Watson (cjwatson) wrote :

Release notes text added:

== PlayStation 3 upgrade issues ==

The graphical boot splash must be turned off when upgrading Play``Station 3 systems from Ubuntu 8.04 ([[https://launchpad.net/bugs/285218|bug 285218]]). See the [[http://psubuntu.com/wiki/IntrepidReleaseNotes|PS3 release notes]] for more details.

Changed in ubuntu-release-notes:
status: New → Fix Released

this problem is for controlators . you have to seek if your sistem have all controlators ready.

yes, is problem of drivers

Dan Munckton (munckfish) wrote :

Retested on Jaunty (now with 2.6.28 based kernel), problem with usplash still occurs.

Dan Munckton (munckfish) wrote :

No progress with this problem yet. GDB is broken on powerpc at the moment ...

https://bugs.launchpad.net/ubuntu-ps3-port/+bug/137312

... which hindered my last attempt. Will endeavor to get back onto this shortly.

Changed in kboot-installer (Ubuntu Jaunty):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Alex Valavanis (valavanisalex) wrote :

Intrepid Ibex reached end-of-life on 30 April 2010 so I am closing the
report. The bug is still marked as "In Progress" in later versions of Ubuntu.

Changed in usplash (Ubuntu Intrepid):
assignee: Dan Munckton (munckfish) → nobody
status: In Progress → Invalid
Alex Valavanis (valavanisalex) wrote :

Jaunty reached end-of-life on 23 October 2010, so this bug will not be fixed in that version of Ubuntu. It has been fixed in newer versions.

Changed in usplash (Ubuntu Jaunty):
assignee: Dan Munckton (munckfish) → nobody
status: In Progress → Won't Fix
Phillip Susi (psusi) wrote :

The usplash package has been superseded by plymouth and has been removed from the Ubuntu archive. Closing all related bugs.

Changed in usplash (Ubuntu):
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers