Crash at startup on PS3 (hardy)

Bug #217647 reported by Dan Munckton on 2008-04-15
6
Affects Status Importance Assigned to Milestone
Ubuntu PS3 Port
Critical
Dan Munckton
xorg-server (Ubuntu)
Undecided
Bryce Harrington

Bug Description

Running the hardy powerpc daily live build from Fri 11th April. When gdm tries to start it swaps to 7th tty and shows the following crash dump

*** glibc detected *** /usr/bin/X: free(): invalid pointer: 0x101f0000 ***
=========== Backtrace ===========
/lib/libc.so.6 ...
/lib/libc.so.6 (cfree+0xc8)
/lib/libc.so.6 (closedir+0x31)
/usr/bin/X (chooseVideoDriver+0x3a0)
/usr/bin/X (autoConfigDevice+0xf4)
/usr/bin/X (InitOutput+0x7ac)
/usr/bin/X (main+0x2e8)

(Note this was noted by hand, cause I'm short of time and couldn't work out how to redirect the X console error output)

Related branches

Dan Munckton (munckfish) wrote :
Dan Munckton (munckfish) wrote :
Dan Munckton (munckfish) on 2008-04-15
Changed in ubuntu-ps3-port:
assignee: nobody → munckfish
Dan Munckton (munckfish) wrote :

Here's the log from a run without config. Got same invalid pointer exception, and X doesn't run. No interesting differences in the log compared with configured version. Still tries to use vesa instead of fbdev.

Changed in xorg-server:
status: New → Confirmed
Changed in ubuntu-ps3-port:
status: New → Confirmed
status: Confirmed → In Progress
Changed in xorg-server:
status: Confirmed → In Progress
Dan Munckton (munckfish) wrote :

GDB backtrace as requested.

Bryce Harrington (bryce) wrote :

Looks like the dir is getting closed outside the check for if it's valid, which I guess could cause a failure like this. Here's a patch to move the close up higher, into the if test for the directory.

Dan Munckton (munckfish) wrote :

Bryce: your patch (attached) fixes this. Next issue to solve is why it tries to load vesa instead of fbdev, I'll raise that as a separate bug.

Changed in ubuntu-ps3-port:
importance: Undecided → Critical
Bryce Harrington (bryce) wrote :

Committed to our xserver git tree; it will go out in the next xserver upload (probably post-Hardy, but possibly sooner).

Changed in xorg-server:
status: In Progress → Fix Committed
Bryce Harrington (bryce) wrote :

Here's another patch jcristau suggested.

Bryce Harrington (bryce) wrote :

Dan - looks like this will go out for Intrepid. Is that okay or do you have a pressing need to see the fix in for Hardy as well?

Also, any comments on the non_pci_autoconfig.patch?

Bryce Harrington (bryce) on 2008-05-09
Changed in xorg-server:
assignee: nobody → bryceharrington
Dan Munckton (munckfish) wrote :

Bryce, the current plan is to having a running and installable hardy on PS3 for 8.04.1 [0], so I'd really appreciate it if we could find a way to get this in as an SRU. Is that possible?

Sorry I've been silent on this for a bit I've been working on LP #220524 which was even more of a show stopper than this. I've just got a fix for that now, so I'll turn my attention back to this and review that patch you attached.

[0] https://wiki.ubuntu.com/UbuntuPS3/HardySchedule

Dan Munckton (munckfish) wrote :

Bryce: I reviewed the non_pci_autoconfig.patch. It doesn't apply here, it fixes a slightly different bug upstream in debian. Also it's written against a much newer version of the code upstream at Xorg and doesn't physically patch in either. Therefore please go ahead with your closedir patch.

Thanks mate.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.4.1~git20080131-1ubuntu10

---------------
xorg-server (2:1.4.1~git20080131-1ubuntu10) intrepid; urgency=low

  [Timo Aaltonen]
  * 166_fix_lpl_monitors.diff:
    - fix LPL monitors properly (LP: #204065)

  [Martin-Eric Racine]
  * 167_xf86AutoConfig_geode_addition.diff:
    - Autodetect geode video devices (LP: #219630)

  [Bryce Harrington]
  * 166_fix_lpl_monitors.diff:
    - Modified to apply to Ubuntu
  * 168_closedir.patch:
    - Fix crash on PS3 due to closing a dir that wasn't successfully opened
      (LP: #217647)

 -- Bryce Harrington <email address hidden> Tue, 13 May 2008 00:03:40 -0700

Changed in xorg-server:
status: Fix Committed → Fix Released
Dan Munckton (munckfish) on 2008-05-13
Changed in ubuntu-ps3-port:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers