update ps3-kboot to 1.4.1

Bug #146230 reported by Colin Watson on 2007-09-28
12
Affects Status Importance Assigned to Milestone
Ubuntu PS3 Port
Undecided
Dan Munckton
ps3-kboot (Ubuntu)
Medium
Dan Munckton
Gutsy
Undecided
Ben Collins
Hardy
Medium
Dan Munckton

Bug Description

Binary package hint: ps3-kboot

ps3-kboot needs to be updated to the version from the 1.4.1 starter kit (though built against Linux 2.6.24) before release.

Colin Watson (cjwatson) on 2007-10-04
Changed in ps3-kboot:
assignee: nobody → ben-collins
Jeldert (jeldert) wrote :

Is this bug retaled to bug #146229 ?

Loïc Minier (lool) wrote :

It's related, but it's a different source package, so it's not the same bug.

Colin Watson (cjwatson) on 2007-10-12
Changed in ps3-kboot:
milestone: ubuntu-7.10-rc → ubuntu-7.10
Changed in ps3-kboot:
importance: Undecided → Medium
status: New → In Progress
Ben Collins (ben-collins) wrote :

Uploaded to gutsy-proposed.

Changed in ps3-kboot:
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

not yet in hardy, reopening.

Changed in ps3-kboot:
milestone: ubuntu-7.10 → hardy-alpha-1
status: Fix Released → In Progress
Martin Pitt (pitti) wrote :

Accepted into gutsy-proposed, please test.

Changed in ps3-kboot:
status: New → Fix Committed
Changed in ps3-kboot:
milestone: hardy-alpha-1 → hardy-alpha-2
Steve Langasek (vorlon) on 2007-12-15
Changed in ps3-kboot:
milestone: hardy-alpha-2 → ubuntu-8.04-beta
Martin Pitt (pitti) wrote :

gutsy-proposed upload FTBFSed

Changed in ps3-kboot:
assignee: nobody → benc
status: Fix Committed → Confirmed
assignee: benc → ben-collins
Martin Pitt (pitti) wrote :

Unless there is still some interest in this, I'll remove the broken source package from gutsy-proposed next week.

Martin Pitt (pitti) wrote :

11:40:46 INFO Removing candidates:
11:40:46 INFO ps3-kboot 20070824-1 in gutsy
11:40:46 INFO Removed-by: Martin Pitt
11:40:46 INFO Comment: dead and broken SRU
11:40:46 INFO 1 package successfully removed.

Unsubscribing ubuntu-sru. Please resubscribe once it is fixed in Hardy, actually builds, and is deemed relevant for Gutsy. Thank you!

Changed in ps3-kboot:
status: Confirmed → Won't Fix
Matt Zimmerman (mdz) on 2008-03-20
Changed in ps3-kboot:
milestone: ubuntu-8.04-beta → ubuntu-8.04
Steve Langasek (vorlon) wrote :

Ben, this has been marked as "in progress" since October - is it still on the radar for hardy?

Colin Watson (cjwatson) wrote :

Somebody does need to deal with it, as Hardy PS3 CDs are unbootable otherwise. That person may not be Ben, though. I'm going to point the new ubuntu-cell mailing list at this bug in the hope that somebody there will pick this up.

Dan Munckton (munckfish) wrote :

Hi, I'll have a go at doing this.

Changed in ps3-kboot:
assignee: ben-collins → munckfish
Dan Munckton (munckfish) on 2008-04-03
Changed in ubuntu-ps3-port:
assignee: nobody → munckfish
status: New → In Progress
Dan Munckton (munckfish) wrote :

UPDATE

I've got the current upstream source and this morning I got half way through compiling it on Ubuntu+PS3. It's changed a bit since it was first packaged by us, plus there are some redhat/fedora specific settings in the build scripts which need to be tweaked. Friday night is my best window of opportunity to work on this, I'll come back to report any progress I make.

  • unnamed Edit (189 bytes, application/pgp-signature; name=signature.asc)

Thank you Dan, for all your work. Keep us posted.

On Thu, 2008-04-03 at 08:28 +0000, Dan Munckton wrote:
> UPDATE
>
> I've got the current upstream source and this morning I got half way
> through compiling it on Ubuntu+PS3. It's changed a bit since it was
> first packaged by us, plus there are some redhat/fedora specific
> settings in the build scripts which need to be tweaked. Friday night is
> my best window of opportunity to work on this, I'll come back to report
> any progress I make.
>

Dan Munckton (munckfish) wrote :

UPDATE 2

 * Tonight I managed to get all the way through a compile.
 * Tested - gets to kboot prompt ok but won't boot my installed OS kernel which is at the moment 2.6.22-14. At next opportunity will build a 2.6.24 kernel and see if that helps.
 * Started updating packaging scripts, yet to test.

If anyone is feeling brave I uploaded the output here, and will leave them around until next week:

 * http://munckfish.net/tmp/otheros-20080130.bld
 * http://munckfish.net/tmp/otheros-20080130.bld.md5sum

Cheers

FYI, I successfully booted the install CD (from a daily snapshot of hardy as of today or so) using petitboot 0.2

correction... it boots, but after it switches to ncurses, I don't have any text displayed. I see the blue background,
I see the red of the active button, I see the blinking cursor in console mode, but it generally acts as if the
console font had been turned to ... nothing. I do see the text before it gets to the installer, it breaks about when
it starts the nucurses installer.

I haven't tried live as it clearly says it can't install from live due to lack of RAM.

Ben.

jiggles100 (jiggles) wrote :

maybe need some compiled in fonts in the kernel, I've seen this problem too

I've seen variants of this problem on other machines, and afaik it's been reported on amd64 too. Usually, the
installer loses fonts on the non-ncurses consoles after two switches back/forth... looks like it just got worse.

The kernel has at least one font since I see some messages at boot...

Dan Munckton (munckfish) wrote :

It would be great to get Petitboot packaged and usable too. Could someone raise a bug for that if there's not already one open?

Colin Watson (cjwatson) wrote :

Dan, could you post your source packages so that those can be reviewed, please?

description: updated
Dan Munckton (munckfish) wrote :

Colin, yes I will. Hopefully I can get the package scripts sorted tonight then I'll upload.

Dan Munckton (munckfish) wrote :

UPDATE 3

Sources uploaded to the ubuntu-ps3-dev team PPA:

https://launchpad.net/~ubuntu-ps3-dev/+archive

Tested with hardy daily live build from yesterday, boots.

It's late now, tomorrow I will follow the correct sponsor/review process.

Dan Munckton (munckfish) wrote :

UPDATE 4

Ok so the good news is, it builds ok, and it does now boot the kernel on the Hardy daily live.

The bad news is that there is a graphics problem. The kboot bit itself is fine. But the boot progress screen shows only it's first frame with dodgy colours then hangs. The OS does keep booting though, and eventually when X starts it shows it's red and blue ncurses error screen, but that is also corrupt as there is no text visible just the coloured background panes. Swapping to a pseudo terminal does work either - shows term text just once, swapping out to another term and back then all pseudo terms go blank.

Investigating. Any thoughts or suggestions welcome.

To aid review by others I have uploaded the .deb and the otheros.bld binary temporarily on my website:

http://munckfish.net/tmp/otheros-1.6-1.bld
http://munckfish.net/tmp/ps3-kboot_1.6-1_powerpc.deb

I don't know what's up with uslpash, but the problem with the text mode having no text (only background) has just been fixed in the kernel packages. (Some issue with the font save/restore code). Hopefully, the next build of the installer should pick up the fixed up kernel.

Dan Munckton (munckfish) wrote :

Ok, reviewing the comments I see that the same graphics problem happens booting using Petitboot too. So I'm going to presume the problem is not in kboot. I'm going to subscribe ubuntu-main-sponsors and see if we can get this into a daily live.

Steve Langasek (vorlon) wrote :

ps3-kboot has been updated to 1.6-2 in hardy.

Changed in ps3-kboot:
status: In Progress → Fix Released
Dan Munckton (munckfish) on 2008-04-19
Changed in ubuntu-ps3-port:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments