PPC64: "mbind: Invalid argument" still seen after 8175813

Bug #1705763 reported by bugproxy on 2017-07-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Ubuntu-power-systems project
Medium
Unassigned
openjdk-8 (Ubuntu)
Undecided
Tiago Stürmer Daitx
Xenial
Medium
Unassigned
Zesty
Medium
Unassigned

Bug Description

---Problem Description---
PPC64: "mbind: Invalid argument" still seen after 8175813

---Steps to Reproduce---
 see https://bugs.openjdk.java.net/browse/JDK-8181055

Dear maintainer, please consider applying the following fix to that issue already pushed uptream to jdk8u: http://hg.openjdk.java.net/jdk8u/jdk8u-dev/hotspot/rev/d3cc20285653 Thank you.

bugproxy (bugproxy) on 2017-07-21
tags: added: architecture-ppc64le bugnameltc-156910 severity-medium targetmilestone-inin16043
Changed in ubuntu:
assignee: nobody → Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage)
affects: ubuntu → openjdk-8 (Ubuntu)
Frank Heimes (fheimes) on 2017-07-21
Changed in ubuntu-power-systems:
importance: Undecided → Medium
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Steve Langasek (vorlon) on 2017-07-21
Changed in openjdk-8 (Ubuntu):
assignee: Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage) → Tiago Stürmer Daitx (tdaitx)
Changed in ubuntu-power-systems:
assignee: Canonical Foundations Team (canonical-foundations) → nobody
tags: added: triage-g
Changed in openjdk-8 (Ubuntu):
status: New → Confirmed
Changed in openjdk-8 (Ubuntu Xenial):
importance: Undecided → Medium
Changed in openjdk-8 (Ubuntu Zesty):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openjdk-8 - 8u141-b15-2

---------------
openjdk-8 (8u141-b15-2) unstable; urgency=high

  [ Matthias Klose ]
  * Update the m68k-support patch (Adrian Glaubitz). Closes: #864180.
  * Disable generation of jvmti.html on m68k (Adrian Glaubitz).
    Closes: #864205.
  * Disable the jamvm autopkg tests.
  * CVE-2017-10243 is also fixed in 8u141-b15 (S8182054).

  [ Tiago Stürmer Daitx ]
  * patches/hotspot-ppc64el-S8181055-use-numa-v2-api.patch: mbind invalid
    argument message is still seen after S8175813; use numa_interleave_memory
    v2 api when available. LP: #1705763.

 -- Matthias Klose <email address hidden> Mon, 24 Jul 2017 23:09:09 +0200

Changed in openjdk-8 (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package openjdk-8 - 8u131-b11-2ubuntu1.17.04.2

---------------
openjdk-8 (8u131-b11-2ubuntu1.17.04.2) zesty-security; urgency=medium

  * patches/hotspot-ppc64el-S8181055-use-numa-v2-api.patch: mbind invalid
    argument message is still seen after S8175813; use numa_interleave_memory
    v2 api when available. LP: #1705763.

openjdk-8 (8u131-b11-2ubuntu1.17.04.1) zesty-security; urgency=medium

  * Security fixes from 8u141:
    - CVE-2017-10102, S8163958: Improved garbage collection.
    - CVE-2017-10053, S8169209: Improved image post-processing steps.
    - CVE-2017-10067, S8169392: Additional jar validation steps.
    - CVE-2017-10081, S8170966: Right parenthesis issue.
    - CVE-2017-10078, S8171539: Better script accessibility for JavaScript.
    - CVE-2017-10087, S8172204: Better Thread Pool execution.
    - CVE-2017-10089, S8172461: Service Registration Lifecycle.
    - CVE-2017-10090, S8172465: Better handling of channel groups.
    - CVE-2017-10096, S8172469: Transform Transformer Exceptions.
    - CVE-2017-10101, S8173286: Better reading of text catalogs.
    - CVE-2017-10107, S8173697: Less Active Activations.
    - CVE-2017-10074, S8173770: Image conversion improvements.
    - CVE-2017-10110, S8174098: Better image fetching.
    - CVE-2017-10108, S8174105: Better naming attribution.
    - CVE-2017-10109, S8174113: Better sourcing of code.
    - CVE-2017-10115, S8175106: Higher quality DSA operations.
    - CVE-2017-10118, S8175110: Higher quality ECDSA operations.
    - CVE-2017-10116, S8176067: Proper directory lookup processing.
    - CVE-2017-10135, S8176760: Better handling of PKCS8 material.
    - CVE-2017-10176, S8178135: Additional elliptic curve support.
    - CVE-2017-10193, S8179101: Improve algorithm constraints implementation.
    - CVE-2017-10198, S8179998: Clear certificate chain connections.
    - S8174770: Check registry registration location.
    - S8174873: Improved certificate procesing.
    - S8176055: JMX diagnostic improvements.
    - S8176536: Improved algorithm constraints checking.
    - S8181420: PPC: Image conversion improvements.
    - S8182054: Improve wsdl support.
    - S8184185: Rearrange MethodHandle arrangements.
  * debian/rules:
    - enable apport hook on Ubuntu and derivatives only.
    - remove with_zenhai logic.
    - remove unused with_tzdata logic, move tzdata build dependency
      to control.in.
    - add Breaks:tzdata-java except for wheezy, jessie or trusty.
    - re-enable jamvm for Xenial only.
    - run debian/control before build so we won't build with a invalid
      control file.
    - remove logic to select between ttf or font packages and depend
      on fonts-wqy-microhei and fonts-wqy-zenhei instead
  * debian/apport-hook.py: add an apport hook to include conffiles
    modified by the user on any report and the hs_err log file on
    crash report only. LP: #1696886.
  * patches/fontconfig-arphic-uming.diff: only enabled when with_zenhai
    was false; not required since lenny.
  * patches/hotspot-ppc64el-S8175813-mbind-invalid-argument.patch: prevent
    invalid argument message when invoking UseNUMA on a system with
    non-consecutive numa topolo...

Read more...

Changed in openjdk-8 (Ubuntu Zesty):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.6 KiB)

This bug was fixed in the package openjdk-8 - 8u131-b11-2ubuntu1.16.04.2

---------------
openjdk-8 (8u131-b11-2ubuntu1.16.04.2) xenial-security; urgency=medium

  * Backport to 16.04.

openjdk-8 (8u131-b11-2ubuntu1.17.04.2) zesty-security; urgency=medium

  * patches/hotspot-ppc64el-S8181055-use-numa-v2-api.patch: mbind invalid
    argument message is still seen after S8175813; use numa_interleave_memory
    v2 api when available. LP: #1705763.

openjdk-8 (8u131-b11-2ubuntu1.16.04.1) xenial-security; urgency=medium

  * Backport to 16.04.

openjdk-8 (8u131-b11-2ubuntu1.17.04.1) zesty-security; urgency=medium

  * Security fixes from 8u141:
    - CVE-2017-10102, S8163958: Improved garbage collection.
    - CVE-2017-10053, S8169209: Improved image post-processing steps.
    - CVE-2017-10067, S8169392: Additional jar validation steps.
    - CVE-2017-10081, S8170966: Right parenthesis issue.
    - CVE-2017-10078, S8171539: Better script accessibility for JavaScript.
    - CVE-2017-10087, S8172204: Better Thread Pool execution.
    - CVE-2017-10089, S8172461: Service Registration Lifecycle.
    - CVE-2017-10090, S8172465: Better handling of channel groups.
    - CVE-2017-10096, S8172469: Transform Transformer Exceptions.
    - CVE-2017-10101, S8173286: Better reading of text catalogs.
    - CVE-2017-10107, S8173697: Less Active Activations.
    - CVE-2017-10074, S8173770: Image conversion improvements.
    - CVE-2017-10110, S8174098: Better image fetching.
    - CVE-2017-10108, S8174105: Better naming attribution.
    - CVE-2017-10109, S8174113: Better sourcing of code.
    - CVE-2017-10115, S8175106: Higher quality DSA operations.
    - CVE-2017-10118, S8175110: Higher quality ECDSA operations.
    - CVE-2017-10116, S8176067: Proper directory lookup processing.
    - CVE-2017-10135, S8176760: Better handling of PKCS8 material.
    - CVE-2017-10176, S8178135: Additional elliptic curve support.
    - CVE-2017-10193, S8179101: Improve algorithm constraints implementation.
    - CVE-2017-10198, S8179998: Clear certificate chain connections.
    - S8174770: Check registry registration location.
    - S8174873: Improved certificate procesing.
    - S8176055: JMX diagnostic improvements.
    - S8176536: Improved algorithm constraints checking.
    - S8181420: PPC: Image conversion improvements.
    - S8182054: Improve wsdl support.
    - S8184185: Rearrange MethodHandle arrangements.
  * debian/rules:
    - enable apport hook on Ubuntu and derivatives only.
    - remove with_zenhai logic.
    - remove unused with_tzdata logic, move tzdata build dependency
      to control.in.
    - add Breaks:tzdata-java except for wheezy, jessie or trusty.
    - re-enable jamvm for Xenial only.
    - run debian/control before build so we won't build with a invalid
      control file.
    - remove logic to select between ttf or font packages and depend
      on fonts-wqy-microhei and fonts-wqy-zenhei instead
  * debian/apport-hook.py: add an apport hook to include conffiles
    modified by the user on any report and the hs_err log file on
    crash report only. LP: #1696886.
  * patches/fontconfig-arphic-uming.diff: only enabled when with_zenhai
    was false; not requ...

Read more...

Changed in openjdk-8 (Ubuntu Xenial):
status: New → Fix Released
Manoj Iyer (manjo) on 2017-08-24
Changed in ubuntu-power-systems:
status: New → Fix Released
tags: added: id-59760cd06c1702079204cb71
tags: added: id-5971a858c08074bb21a8862f
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers