[DPMS] Display backlight turns back on almost immediately after being turned off

Bug #1231857 reported by Daniel van Vugt on 2013-09-27
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Mir
Fix Released
High
Alexandros Frantzis
The Ubuntu Power Consumption Project
Undecided
Unassigned
mir (Ubuntu)
High
Unassigned
xorg-server (Ubuntu)
High
Unassigned

Bug Description

Display backlight turns back on almost immediately after being turned off.

In theory DPMS support has landed in XMir, but it's not really working.

TEST CASE:
xset dpms force off
Expected: Screen turns off and stays off
Observed: Screen turns off and then immediately either:
  (a) turns back on fully; or
  (b) the backlight turns back on but the screen remains black.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: xserver-xorg-xmir 2:1.14.2.901-2ubuntu6
ProcVersionSignature: Ubuntu 3.11.0-8.15-generic 3.11.1
Uname: Linux 3.11.0-8-generic x86_64
ApportVersion: 2.12.4-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Fri Sep 27 16:25:33 2013
DistUpgraded: Fresh install
DistroCodename: saucy
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21da]
InstallationDate: Installed on 2013-06-11 (107 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130611)
MachineType: LENOVO 4286CTO
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-8-generic root=UUID=25c27832-0efa-4fc4-8a14-41af68d008dc ro quiet splash vt.handoff=7
SourcePackage: xorg-server
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/18/2013
dmi.bios.vendor: LENOVO
dmi.bios.version: 8DET69WW (1.39 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4286CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8DET69WW(1.39):bd07/18/2013:svnLENOVO:pn4286CTO:pvrThinkPadX220:rvnLENOVO:rn4286CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4286CTO
dmi.product.version: ThinkPad X220
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.10+13.10.20130920-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.46-1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.2-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.2-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.14.2.901-2ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu9
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.14-4ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
xserver.bootTime: Fri Sep 27 16:45:50 2013
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs: Output DP-0 DP-1 DP-2 HDMI-0 HDMI-1 HDMI-2 VGA-0
xserver.version: 2:1.14.2.901-2ubuntu6
xserver.video_driver: intel

Related branches

Daniel van Vugt (vanvugt) wrote :
summary: - Display backlight turns back on almost immediately after being turned
- off
+ [DPMS] Display backlight turns back on almost immediately after being
+ turned off
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Changed in mir:
status: New → Confirmed
Changed in ubuntu-power-consumption:
status: New → Confirmed
Changed in xmir:
status: New → Confirmed
tags: added: pm
Changed in mir:
importance: Undecided → High
Changed in xmir:
importance: Undecided → High
Changed in xorg-server (Ubuntu):
importance: Undecided → High
summary: - [DPMS] Display backlight turns back on almost immediately after being
- turned off
+ [DPMS] [XMir] Display backlight turns back on almost immediately after
+ being turned off

Even worse, using mir_demo_server_shell and Alt+P, I can see vsync is lost when the screen (incorrectly) turns back on.

Changed in mir:
milestone: none → 0.1.3
summary: - [DPMS] [XMir] Display backlight turns back on almost immediately after
- being turned off
+ [DPMS] mir_power_mode_off doesn't work at all. Display backlight turns
+ back on almost immediately after being turned off, and vsync is lost.

I've found an obvious related bug in mir_demo_server_shell, so moving that to bug 1255818.

summary: - [DPMS] mir_power_mode_off doesn't work at all. Display backlight turns
- back on almost immediately after being turned off, and vsync is lost.
+ [DPMS] Display backlight turns back on almost immediately after being
+ turned off
Daniel van Vugt (vanvugt) wrote :

That's interesting. I see this bug on X too (Ctrl+Alt+L). No Mir at all. Maybe the problem is my kernel/machine.

Changed in mir:
milestone: 0.1.3 → 0.1.4
Changed in mir:
milestone: 0.1.4 → 0.1.5
Changed in mir:
milestone: 0.1.5 → 0.1.6
Changed in mir:
milestone: 0.1.6 → none
kevin gunn (kgunn72) wrote :

so knowing that https://bugs.launchpad.net/mir/+bug/1255818 was fixed.
is this really an issue ?
even xmir I know we fixed this.
i too had similar display off issues w/o xmir installed.
calling this fixed, please reopen if i am wrong.
but please have updated repro instructions if reopened.

Changed in mir:
status: Confirmed → Fix Released
Changed in xmir:
status: Confirmed → Fix Released
Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Released
Changed in mir:
importance: High → Medium
importance: Medium → High
Daniel van Vugt (vanvugt) wrote :

This bug is still trivial to reproduce:
  1. mir_demo_server_shell
  2. Alt+P
Expected: Display turns off and stays off
Observed: Display turns off, and then immediately on again. Cursor is visible.

At least a simple test case should make it easy to fix, in theory.

Changed in mir:
status: Fix Released → Triaged
Changed in xmir:
status: Fix Released → Triaged
Changed in xorg-server (Ubuntu):
status: Fix Released → Triaged
Daniel van Vugt (vanvugt) wrote :

I just noticed this bug was fixed as a side-effect of r1546. Nice.

Changed in mir:
assignee: nobody → Alexandros Frantzis (afrantzis)
milestone: none → 0.1.9
status: Triaged → Fix Committed
Changed in ubuntu-power-consumption:
status: Confirmed → Fix Committed
Changed in mir:
status: Fix Committed → Fix Released
Changed in mir (Ubuntu):
importance: Undecided → High
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.1.9+14.10.20140430.1-0ubuntu1

---------------
mir (0.1.9+14.10.20140430.1-0ubuntu1) utopic; urgency=medium

  [ Daniel van Vugt ]
  * New upstream release 0.1.9 (https://launchpad.net/mir/+milestone/0.1.9)
    - mirclient ABI unchanged, still at 7. Clients do not need rebuilding.
    - mirserver ABI bumped to 19. Shells need rebuilding.
    - More libmirserver class changes and reorganization, including;
      . Moving things from shell:: to scene::
      . Rewriting/refactoring surface factories.
    - Added an id() to Renderable.
    - Scene/Renderer interfaces:
      . Scene is no longer responsible for its own iteration (no for_each
        any more). Instead you should iterate over the list returned by
        Scene::generate_renderable_list().
    - Bugs fixed:
      . Stale socket issue. (LP: #1285215)
      . Qt render gets blocked on EGLSwapBuffers. (LP: #1292306)
      . Lock order violated found in helgrind (potential deadlock).
        (LP: #1296544)
      . [regression] SwitchingBundle in framedropping mode can hang.
        (LP: #1306464)
      . [DPMS] Display backlight turns back on almost immediately after
        being turned off. (LP: #1231857)
      . Wrong frame is seen on wake up/resume/unlock. (LP: #1233564)
      . Nested platform is not testable (LP: #1299101)
      . [regression] mir_demo_server_shell crashes on display resume.
        (LP: #1308941)
      . Multi-threaded composition is actually mostly serialized by
        SurfaceStack::guard. (LP: #1234018)
      . Mirscreencast slows down compositing and makes it very jerky.
        (LP: #1280938)
      . Mirscreencast can cause clients to render faster than the screen
        refresh rate. (LP: #1294361)
      . Screen turns on when a new session/surface appears. (LP: #1297876)
      . mir-doc package is >56MB in size, expands to >100MB of files.
        (LP: #1304998)
      . [regression] Clang: 'mir::test::doubles::MockSurface::visible'
        hides overloaded virtual function [-Woverloaded-virtual].
        (LP: #1301135)
      . [regression] GLRenderer* unit tests have recently become noisy.
        (LP: #1308905)
      . FocusController::set_focus_to() no longer seems to raise a session
        to the top. (LP: #1302689)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Wed, 30 Apr 2014 13:26:58 +0000

Changed in mir (Ubuntu):
status: Triaged → Fix Released
Joseph Wakeling (webdrake) wrote :

Just to know -- is this fix expected to make it to Trusty, or only to Utopic?

Daniel van Vugt (vanvugt) wrote :

We are focusing all Mir work on the "next release", so that means all new work automatically goes into utopic. While trusty packages are not a priority for Mir development, we can update them if there's a demand. It would be per the usual SRU process, but that does require someone motivated to follow through: https://wiki.ubuntu.com/StableReleaseUpdates

no longer affects: xmir
tags: added: xmir
Daniel van Vugt (vanvugt) wrote :

XMir 1.0 (the old Xorg extension) is now deprecated and is not being maintained or fixed. It is replaced by the new 'Xmir' binary (package 'xmir') introduced in Ubuntu 15.10 wily.

Changed in xorg-server (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers