Apt update fails linux-firmware-raspi2

Bug #1839054 reported by FranksMCB on 2019-08-06
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu Pi Flavour Maker
Undecided
Unassigned

Bug Description

Ubuntu MATE 18.04 on Raspberry Pi 3B+

Try to run apt updates and the following occurs:

Hit:1 http://ppa.launchpad.net/ubuntu-pi-flavour-makers/ppa/ubuntu bionic InRelease
Hit:2 http://ports.ubuntu.com bionic InRelease
Hit:3 http://ports.ubuntu.com bionic-updates InRelease
Hit:4 http://ports.ubuntu.com bionic-security InRelease
Hit:5 http://ports.ubuntu.com bionic-backports InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
1 package can be upgraded. Run 'apt list --upgradable' to see it.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  linux-firmware-raspi2
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/3,612 kB of archives.
After this operation, 35.8 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 314093 files and directories currently installed.)
Preparing to unpack .../linux-firmware-raspi2_1.20190215-0ubuntu0.18.04.1_armhf.deb ...
Unpacking linux-firmware-raspi2 (1.20190215-0ubuntu0.18.04.1) over (1.20180919-0ubuntu0.18.04.2) ...
dpkg: error processing archive /var/cache/apt/archives/linux-firmware-raspi2_1.20190215-0ubuntu0.18.04.1_armhf.deb (--unpack):
 trying to overwrite '/lib/firmware/brcm/BCM43430A1.hcd', which is also in package bluez-firmware 1.2-4+rpt1~bionic1.0
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/linux-firmware-raspi2_1.20190215-0ubuntu0.18.04.1_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

FranksMCB (franksmcb) wrote :

Norbert has a workaround:

After performing an apt upgrade and getting this error, run this command:

sudo dpkg -i --force-all /var/cache/apt/archives/linux-firmware-raspi2_1.20190215-0ubuntu0.18.04.1_armhf.deb

Then continue the upgrade via sudo apt upgrade

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers