Ubuntu Packaging Guide

Add article "Python packaging"

Reported by Daniel Holbach on 2011-01-12
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu Packaging Guide
Wishlist
Dmitry Shachnev

Bug Description

Add article about "Python packaging". http://www.debian.org/doc/packaging-manuals/python-policy/ and friends would be good resources.

Changed in ubuntu-packaging-guide:
importance: Undecided → Wishlist
status: New → Triaged
Changed in ubuntu-packaging-guide:
assignee: nobody → Dmitry Shachnev (mitya57)
status: Triaged → In Progress

Hi Dmitry,

Thanks for working on this! I just wanted to point out http://wiki.debian.org/Python/LibraryStyleGuide Some of that might be helpful.

Dmitry Shachnev (mitya57) wrote :

I've almost finished that (see the linked branch). Initially it was based on http://wiki.ubuntu.com/PackagingGuide/Python, but that page was very outdated, so I've rewritten it almost from scratch. @Barry, Stefano: any suggestions/fixes?

@Andrew: that page is already linked (in "See also" section), thanks. By the way, is that expected that bullet lists have no styling (no indent, bullet marks not displayed) or that's a bug in the CSS? For example, compare http://ubuntuone.com/7KSQmXyFPdVEANE1yqmEOZ and http://ubuntuone.com/6tkmP24x64ICc061F6oHmK.

On Wed, Aug 1, 2012 at 6:47 AM, Dmitry Shachnev <email address hidden> wrote:
> By the way, is that expected that bullet lists have no styling (no indent,
> bullet marks not displayed) or that's a bug in the CSS?

It is a bug.

Dmitry Shachnev (mitya57) wrote :

It is caused by reset.css.
lp:~mitya57/ubuntu-packaging-guide/add-guide-css contains the fix.

Changed in ubuntu-packaging-guide:
status: In Progress → Fix Committed
Changed in ubuntu-packaging-guide:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers