4.2.2 is out of date, no longer works correctly

Bug #1569561 reported by Simon Quigley on 2016-04-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Packaging Guide
Medium
Simon Quigley

Bug Description

In 4.2.2, it states:

We use the bzr branch command to create a local branch of the package. We’ll name the target directory tomboy.dev just to keep things easy to remember:

$ bzr branch ubuntu:tomboy tomboy.dev

The tomboy.dev directory represents the version of Tomboy in the development version of Ubuntu, and you can always cd into this directory and do a bzr pull to get any future updates.

When I run that command, I get:

$ bzr branch ubuntu:tomboy tomboy.dev
bzr: ERROR: Not a branch: "bzr+ssh://bazaar.launchpad.net/+branch/ubuntu/tomboy/".

But doing the following works fine:

$ bzr branch ubuntu:m/tomboy xenial
Most recent Ubuntu Precise version: 1.10.1-0ubuntu1
Packaging branch status: CURRENT
Branched 65 revisions.

But it branches into the xenial folder.

When I try to do the following, it still doesn't work:

$ bzr branch ubuntu:xenial/tomboy xenial
bzr: ERROR: Not a branch: "bzr+ssh://bazaar.launchpad.net/+branch/ubuntu/xenial/tomboy/".

Related branches

Simon Quigley (tsimonq2) on 2016-04-12
description: updated
Dmitry Shachnev (mitya57) wrote :

That's because UDD is dead, see https://lists.ubuntu.com/archives/ubuntu-devel/2015-November/039010.html.

(Yes, that means that half of Ubuntu Packaging Guide is outdated.)

Simon Quigley (tsimonq2) on 2017-09-03
Changed in ubuntu-packaging-guide:
status: New → Fix Committed
assignee: nobody → Simon Quigley (tsimonq2)
importance: Undecided → Medium
Changed in ubuntu-packaging-guide:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers