Ubuntu Tour menu becomes unreadable when interrupting a tutorial

Bug #1019025 reported by Christopher Townsend
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Undecided
James M. Leddy
Precise
Undecided
James M. Leddy
Ubuntu Online Tour - OBSOLETE
Undecided
Anthony Dillon
ubuntu-online-tour (Ubuntu)
High
Unassigned
Declined for Precise by Micah Gersten
Quantal
High
Unassigned

Bug Description

[Impact]
* If a user wants to go back to the Ubuntu Online Tour menu after starting a tutorial, then the tutorial text is unreadable and renders the session useless.

[Test Case]
* Install the ubuntu-online-tour package. If on Precise, enable precise-backports.
  - apt-get install ubuntu-online-tour
* Click on the Dash home and type Ubuntu.
* Click on the "Ubuntu Tour" icon.
* Select a tutorial (like "How to play video")
* Click on the first couple of prompts.
* Click on the "Back to menu" icon in the lower right of the screen.
* Observe the "Welcome to the Ubuntu tour!" window appears and all text is NOT readable.

[Regression Potential]
* None identified.

---

Title: Ubuntu Tour menu becomes unreadable when interrupting a tutorial

Summary: When Ubuntu Tour is running a tutorial, if while in the middle of the tutorial you click on the menu icon in the lower right of the screen, the menu reappears but all the words are blurred to the point where they are unreadable.

Steps:
1) Build the OS in English
2) Log into the desktop
3) Click on Dash home and type [Ubuntu]
4) Click on the "Ubuntu Tour" icon
5) Select a tutorial (like "How to play video")
6) Click on the first couple of prompts.
7) Click on the "Back to menu" icon in the lower right of the screen.

Expected results: The "Welcome to the Ubuntu tour!" window appears and all text is readable.

Actual results: The "Welcome to the Ubuntu tour!" window appears and all text is NOT readable.

Revision history for this message
Christopher Townsend (townsend) wrote :

Screenshot of the unreadable menu.

summary: - This page contains Private information. Ubuntu Tour menu becomes
- unreadable when interrupting a tutorial
+ Ubuntu Tour menu becomes unreadable when interrupting a tutorial
Changed in ubuntu-online-tour:
assignee: nobody → Anthony Dillon (ya-bo-ng)
Revision history for this message
Anthony Wong (anthonywong) wrote :

Any progress of this bug? We are getting bug reports from our OEM partners and a fix is much needed.

Revision history for this message
Anthony Dillon (ya-bo-ng) wrote :

Very sorry this slipped the net. Picking this up

Changed in ubuntu-online-tour:
status: New → In Progress
Revision history for this message
Anthony Dillon (ya-bo-ng) wrote :

Updated the extended-tour branch with a fix.

Thank you,
Ant.

Changed in ubuntu-online-tour:
status: In Progress → Fix Committed
Revision history for this message
Christopher Townsend (townsend) wrote :

Are there any plans to upload an updated version of ubuntu-online-tour for Precise? This fix is necessary for many projects and an update in the archive would be the best way to get this.

Revision history for this message
Kent Baxley (kentb) wrote :

I just tested the following package from Timo's PPA:

https://launchpad.net/~timo-jyrinki/+archive/prerelease

..with this new package, I'm no longer able to reproduce the unreadable / blurred-out text issue that I saw with the previous release.

Revision history for this message
Anthony Dillon (ya-bo-ng) wrote :

Great, that sounds like a bug squashed.

Changed in ubuntu-online-tour:
status: Fix Committed → Fix Released
description: updated
Revision history for this message
Christopher Townsend (townsend) wrote :

For anyone willing to sponsor an upload, the branch we are interested in is lp:~timo-jyrinki/ubuntu-online-tour/fix_1019025.

Thanks!

Changed in ubuntu-online-tour (Ubuntu):
status: New → In Progress
importance: Undecided → High
Changed in ubuntu-online-tour (Ubuntu Quantal):
importance: Undecided → High
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-online-tour - 0.11-0ubuntu2

---------------
ubuntu-online-tour (0.11-0ubuntu2) raring; urgency=low

  * debian/patches/fix_lp1019025+translations.patch
    - Pick fix to tour becoming unreadable (LP: #1019025)
  * debian/patches/remove_redundant_desktopfile_option.patch:
    - Remove X-GNOME-Autostart-enabled=true (Delay is specified instead)
  * debian/patches/update-translations.patch:
    - Update translations form Launchpad
 -- Timo Jyrinki <email address hidden> Mon, 08 Oct 2012 16:32:05 +0300

Changed in ubuntu-online-tour (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Clint Byrum (clint-fewbar) wrote :

Timo, thanks for getting this fix ready for quantal. It pains me to say this, but I have to reject the upload to quantal-proposed. Please do not include unrelated changes without SRU justification. Specifically:

debian/patches/remove_redundant_desktopfile_option.patch

Either document this change with a bug report (including the appropriate SRU documentation) or remove it from the upload.

Please reference https://wiki.ubuntu.com/StableReleaseUpdates for more information.

Revision history for this message
Sebastien Bacher (seb128) wrote :

(reuploaded with the patch, it would be good if you could review it again soon, that's an OEM priority bug and avoiding a new 3 weeks delay would be better)

Revision history for this message
Clint Byrum (clint-fewbar) wrote : Please test proposed package

Hello Christopher, or anyone else affected,

Accepted ubuntu-online-tour into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubuntu-online-tour/0.11-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-online-tour (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Shih-Yuan Lee (fourdollars) wrote :

I have checked ubuntu-online-tour=0.11-0ubuntu1.1 and it works fine.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Colin Watson (cjwatson) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-online-tour - 0.11-0ubuntu1.1

---------------
ubuntu-online-tour (0.11-0ubuntu1.1) quantal-proposed; urgency=low

  * debian/patches/fix_lp1019025+translations.patch
    - Pick fix to tour becoming unreadable (LP: #1019025)
  * debian/patches/update-translations.patch:
    - Update translations form Launchpad
 -- Timo Jyrinki <email address hidden> Mon, 08 Oct 2012 16:32:05 +0300

Changed in ubuntu-online-tour (Ubuntu Quantal):
status: Fix Committed → Fix Released
Changed in precise-backports:
status: New → In Progress
Changed in oem-priority:
status: New → In Progress
assignee: nobody → James M. Leddy (jm-leddy)
Changed in oem-priority:
status: In Progress → Fix Released
Revision history for this message
Steve Magoun (smagoun) wrote :

oem-priority status is still 'in progress' because the fix is not released for the target OS (precise). I've adjusted the bug status accordingly.

Changed in oem-priority:
status: Fix Released → In Progress
no longer affects: precise-backports
Revision history for this message
James M. Leddy (jm-leddy) wrote :

The request for precise should be followed in bug 1095819

Revision history for this message
James M. Leddy (jm-leddy) wrote :

Closing since bug 1095819 is fixed

Changed in oem-priority:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers