cloud-images attempt load of acpiphp, causes failure of systemd-modules-load.service

Bug #1430323 reported by Scott Moser on 2015-03-10
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu on EC2
Medium
Dan Watkins
openstack-debian-images (Debian)
Fix Released
Unknown

Bug Description

as reported by pitti under bug 450463, the cloud-images have the following in /etc/modules:
  | # LP: #450463
  | acpiphp

That is written by http://bazaar.launchpad.net/~ubuntu-on-ec2/vmbuilder/automated-ec2-builds/view/head:/vmbuilder-cloudimg-fixes

The result is that the systemd-modules-load.service fails to load, and user sees messages like this on console (possibly other fallout).

| [[32m OK [0m] Started Nameserver information manager.
| resolvconf.service
| [ 4.808918] systemd[1]: systemd-modules-load.service: main process exited, code=exited, status=1/FAILURE
| [[1;31mFAILED[[ 4.810826] systemd[1]: Failed to start Load Kernel Modules.
| 0m] Failed to st[ 4.811754] systemd[1]: Unit systemd-modules-load.service entered failed state.
| art Load Kernel [ 4.812820] systemd[1]: systemd-modules-load.service failed.
| Modules.
| See "systemctl status systemd-modules-load.service" for details.

Ideally there would be a way to say "load this if it exists", or some other way that failed module loads could be marked as non-fatal.
That said, as Martin reports, the acpiphp module is no longer present in vivid (3.19.0-7-generic).

For reference:
utopic:
 $ find /lib/modules -iname "*acpi*" -type f
/lib/modules/3.16.0-31-generic/kernel/drivers/acpi/acpi_ipmi.ko
/lib/modules/3.16.0-31-generic/kernel/drivers/acpi/acpi_pad.ko
/lib/modules/3.16.0-31-generic/kernel/drivers/acpi/acpi_extlog.ko

trusty:
$ find /lib/modules -iname "*acpi*" -type f
/lib/modules/3.13.0-46-generic/kernel/drivers/acpi/acpi_pad.ko
/lib/modules/3.13.0-46-generic/kernel/drivers/acpi/acpi_ipmi.ko
/lib/modules/3.13.0-46-generic/kernel/drivers/acpi/acpi_extlog.ko

So we've been rid of acpiphp.ko since at least 14.04.

Scott Moser (smoser) on 2015-03-10
Changed in ubuntu:
status: New → Confirmed
importance: Undecided → Medium
tags: added: cloud-images cloud-images-build
description: updated
Changed in ubuntu:
assignee: nobody → Dan Watkins (daniel-thewatkins)
Dan Watkins (daniel-thewatkins) wrote :

For vivid, this is actually added by http://bazaar.launchpad.net/~ubuntu-on-ec2/livecd-rootfs/cpc/view/head:/live-build/ubuntu-cpc/hooks/999-cpc-fixes.chroot, as we've moved to using livecd-rootfs to build on the buildds.

I've made the change, and the PPA we use for livecd-rootfs (https://launchpad.net/~cloud-images-release-managers/+archive/ubuntu/cloud-image-tooling) is building it as we speak.

Once that's built, the next vivid daily build should fix this.

Changed in ubuntu:
status: Confirmed → Fix Committed
Dan Watkins (daniel-thewatkins) wrote :

Confirmed fixed in the latest trusty, utopic and vivid dailies.

Changed in ubuntu:
status: Fix Committed → Fix Released
Changed in openstack-debian-images (Debian):
status: Unknown → New
Changed in openstack-debian-images (Debian):
status: New → Fix Released
affects: ubuntu → ubuntu-on-ec2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.