XBMC UI random framerate drops from 30 FPS to 15FPS

Bug #915456 reported by ungoliant
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
Medium
Ricardo Salveti
linaro-landing-team-ti
Fix Released
Low
Unassigned
ubuntu-omap4-extras-multimedia
Undecided
Unassigned

Bug Description

Just installed XBMC following instrucctions from rsalveti (http://rsalveti.wordpress.com/2012/01/06/hw-video-decode-and-xbmc-ubuntu-linaro/) and i'm experiencing random FPS drops in both the UI and video decode.

You can get a better idea in this video:
http://www.youtube.com/watch?v=4DcdATFduII&context=C3f58d6bADOEgsToPDskIqTI_an28joYlQPhPC6vvG

Revision history for this message
Ricardo Salveti (rsalveti) wrote :

Can you update to the latest driver available (1.7.10.0.1.8-1linaro1), and then disable the drm polling to see if works better?

root@linaro-ubuntu-desktop:~# echo 0 > /sys/module/drm_kms_helper/parameters/poll

After disabling polling SGX is quite stable with my system, and it also behaves better when playing a video (without the sensation of loosing frames from time to time).

As robclark was saying at the IRC, this is probably because the way DVI is detected is by polling the i2c bus checking for a valid EDID, and for some reason the system will wait a timeout at the i2c driver, causing the frame drop.

Changed in ubuntu-omap4-extras-multimedia:
status: New → Confirmed
Changed in linaro-ubuntu:
status: New → Confirmed
assignee: nobody → Ricardo Salveti (rsalveti)
importance: Undecided → Medium
Revision history for this message
warmcat (andy-warmcat) wrote :

If disabling drm poll works around it I have a good idea what it might be, and a possible fix.

Revision history for this message
Ricardo Salveti (rsalveti) wrote :

Guess if we're able to probe DVI by a GPIO or something, the code logic can be changed to avoid I2C, but would need to check the schematic. Otherwise we'd need to disable dvi hotplug (or see if we can fix at the i2c code).

Revision history for this message
ungoliant (nobill) wrote :

Yes, disabling polling fixes the framerate drops. What effect does the polling disable have on the system?

Revision history for this message
warmcat (andy-warmcat) wrote :

DVI panel and so detect polling are disabled in tilt kernels, it's likely something else on hdmi poll path.

Revision history for this message
Ricardo Salveti (rsalveti) wrote : Re: [Bug 915456] Re: XBMC UI random framerate drops from 30 FPS to 15FPS

On Fri, Jan 13, 2012 at 12:19 AM, warmcat <email address hidden> wrote:
> DVI panel and so detect polling are disabled in tilt kernels, it's
> likely something else on hdmi poll path.

True, DVI is not even working with this kernel.

Revision history for this message
Ricardo Salveti (rsalveti) wrote :

On Fri, Jan 13, 2012 at 12:18 AM, ungoliant <email address hidden> wrote:
> Yes, disabling polling fixes the framerate drops. What effect does the
> polling disable have on the system?

None, and afaik it'll only affect monitor hotplug, so if you don't
change your monitor, you should be fine.

Revision history for this message
warmcat (andy-warmcat) wrote :

Right no real effect. But I think I have a fix for this shortly that won't require poll disable.

Revision history for this message
ungoliant (nobill) wrote :

Is it possible that this could be causing my LCD to go suddenly go black after a couple minutes? Sound still works, and If i'm using the UI I still hear the sound made by moving around, but the only way to get image back is by restarting lightdm.

Revision history for this message
ungoliant (nobill) wrote :

Sorry, by "this" I meant the polling disable workaround, not the bug itself (I've been experiencing this issue since I disabled drm polling on boot)

Revision history for this message
Keyan Mobli (persiansown) wrote :

I am also getting screen blackouts. The image returned one time, but it usually doesn't. The image will go black within 10 minutes usually and audio still works.

I don't know if it occurred without the polling change because as soon as I saw the sudden, frequent framerate drops I disabled it, but it definitely occurs with it disabled..

Revision history for this message
ungoliant (nobill) wrote :

I found out that the image going out within 10 minutes issue is caused by DPMS. There's some info in arch linux wiki on how to turn DPMS off, I just added it to the xbmc start-up script, and image stays always on on my xbmc.

Of course, if you use XBMC with keyboard and mouse, this shouldn't be the problem.

Revision history for this message
Keyan Mobli (persiansown) wrote :

@ungoliant: I tried doing that, but it doesn't seem to work for me. (xset -dpms s off)

Can you show me what you attempted to do to prevent your screen from going black and not returning?

Revision history for this message
Anmar Oueja (anmar) wrote :

Andy: Did you put in the fix from comment #8

Changed in linaro-landing-team-ti:
importance: Undecided → Low
Revision history for this message
ungoliant (nobill) wrote :

Sorry Keyan, hadn't notice your question till now: what I did was adding both at rc.local and xbmc startup script: xset -dpms;xset s off
Its working for me now.

Revision history for this message
warmcat (andy-warmcat) wrote :

We also changed the way we adapt DSS in tilt-3.4 that will remove delays on drm poll and edid request that should also impact this.

Changed in linaro-landing-team-ti:
status: New → Fix Released
Revision history for this message
Ricardo Salveti (rsalveti) wrote :

This is not the case anymore with the 3.4 based kernel from TI LT's, as commented by Andy on #16. Marking it as fixed released.

Changed in linaro-ubuntu:
status: Confirmed → Fix Released
milestone: none → 12.08
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers