OMAP4 Ubuntu Multimedia addons

OMAP4 Panda: HW MM h/w acceleration doesn't work after installed from PPA Update September 2012

Reported by Fang Bao on 2012-09-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-omap4-extras-multimedia
Undecided
Unassigned

Bug Description

Hi,

I'm running the official Ubuntu 1204 image on Pandaboard downloaded from https://wiki.ubuntu.com/ARM/OMAP/.

Last month, the HW MM h/w acceleration works on PPA Update August 2012.
But today HW MM h/w acceleration doesn't work after updating from PPA Update September 2012.
When running the totem to play a H264 1080p stream, there is an error:

libdce.c: 437: init info: attempting to open X11 connection
libdce.c: 515: init error: could not get plugin ioctl base: -22

The stream is played very slow because gstreamer is using software h264 decoder.

I updated system following the instruction (https://groups.google.com/forum/#!topic/pandaboard/ZnFoQkvD3Pg) without skipping a step.

Nicolas Dechesne (ndec) wrote :

can you share the output of the following command:

# dmesg
# dpkg -l
# uname -a
# lsmod
# gst-inspect
# md5sum /lib/firmware/ducati-m3-core0.xem

Also which graphical session/env are you using when logging into lightdm?

Fang Bao (fangbao) wrote :

dmesg log

Fang Bao (fangbao) wrote :

log from "# dpkg -l"

Fang Bao (fangbao) wrote :

log from "# gst-inspect"

Fang Bao (fangbao) wrote :

# uname -a
Linux bao-arm-desktop 3.4.0-1486-omap4 #9-Ubuntu SMP PREEMPT Thu Aug 30 15:29:24 UTC 2012 armv7l armv7l armv7l GNU/Linux

# md5sum /lib/firmware/ducati-m3-core0.xem
md5sum: /lib/firmware/ducati-m3-core0.xem: No such file or directory

I find another similar firmware file.

# md5sum /lib/firmware/ducati*
7a15454a89945bf0ac48ecee92a7a42d /lib/firmware/ducati-m3-core0.xem3

Fang Bao (fangbao) wrote :

I used Ubuntu 2D graphics session. Just select "Ubuntu 2D" on Ubuntu login screen.

Olivier Naudan (o-naudan) wrote :

Since the kernel command line is old (two "mem=" statements), it seems that the bootloaders, although installed in the file system, are not updated in the VFAT partition. Please run "sudo flash-kernel --update-bootloader".

Then the kernel command line will look like "ro elevator=noop console=ttyO2,115200n8 mem=1G@0x80000000 root=/dev/mmcblk0p2 fixrtc splash". This comes from /boot/boot.script.

Fang Bao (fangbao) wrote :

I flashed the bootloader again as following:

$ sudo flash-kernel --update-bootloader
Using u-boot partition: /dev/mmcblk0p1
/usr/lib/u-boot/omap4_panda/MLO is already installed in the boot partition.
/usr/lib/u-boot/omap4_panda/u-boot.bin is already installed in the boot partition.
Creating backups of boot files ... done.
Generating kernel u-boot image... done.
Generating Initramfs u-boot image... done.
Generating u-boot configuration from /boot/boot.script... done.

But in next booting, there is no change. The kernel command line read from dmesg is same:

[ 0.000000] Kernel command line: ro elevator=noop vram=40M mem=456M@0x80000000 mem=512M@0xA0000000 root=UUID=4dd037b6-24e8-4602-9caa-f13574fb6709 fixrtc quiet splash

And the hw codec doesn't work also.

Xavier Boudet (x-boudet) wrote :

You need in fact to edit as root the file /boot/boot.script
update the bootargs line as follow:
setenv bootargs ro elevator=noop mem=1G@0x80000000 root=UUID=4dd037b6-24e8-4602-9caa-f13574fb6709 fixrtc quiet splash

You will then need to execute: sudo flash-kernel
Finally reboot

Fang Bao (fangbao) wrote :

I edited the /boot/boot.script manually, and flash the boot image again.
After reboot, I find the correct kernel command in dmesg log.

But when I run totem to play H264 stream, there is a new error:

$ totem XXXXXXX.MP4
libdce.c:437: init info: attempting to open X11 connection
** Message: Error: Could not decode stream.
gstducatividdec.c(1081): gst_ducati_viddec_chain (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20/GstDucatiH264Dec:ducatih264dec0:
process returned error: -1 08008000

When I tried again, there is no error printed. But totem can't play stream also.

So the HW MM codec doesn't work.

Olivier Naudan (o-naudan) wrote :

hmm, there is not enough traces. Please provide the output of the following:
DISPLAY=:0 GST_DEBUG=*:2,duc*:5,dri2*:5 totem foo.mp4
And also provide traces from /sys/kernel/debug/remoteproc/remoteproc1/trace0

Fang Bao (fangbao) wrote :

The debug trace of "DISPLAY=:0 GST_DEBUG=*:2,duc*:5,dri2*:5 totem XXX"

Fang Bao (fangbao) wrote :

The traces from /sys/kernel/debug/remoteproc/remoteproc1/trace0

Fang Bao (fangbao) wrote :

Hi Olivier,

Any progress?

Olivier Naudan (o-naudan) wrote :

Please try again with PPA Update of October 2012, it includes an update of H264 decoder and numerous bug fixes.
If this big_buck_bunny_1080p_H264_AAC_25fps_7200K.MP4 is still not working, please share it so we can have a closer look.
-- Olivier

Daniel Berlin (dberlin) wrote :

I'm having the exact same problem/error code, but with slightly different symptoms:

Dmesg shows the kernel (CMA) is claiming it can't allocate 128 meg contiguous memory for the ipu.

Trying to playback using gst-launch directly or totem is giving the DCE error -22

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers