GeschiktVoor macro sorteert versies verkeerd

Bug #538554 reported by Timo Vanwynsberghe on 2010-03-13
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu-NL Website
Undecided
Unassigned

Bug Description

De GeschiktVoor macro op de wiki sorteert de Ubuntu versies niet meer chronologisch door de komst van 10.04 (en verder).

Ik voeg een patch toe die het probleem oplost.

Zie ook eventueel dit topic: http://forum.ubuntu-nl.org/documentatie/geschiktvoor-macro-niet-geschikt-voor-10-04-lts/

Timo Vanwynsberghe (timovwb) wrote :
CeesSluis (testcees) wrote :

Voor wat het waard is: De patch heb ik getest op mijn lokale MoinMoin wiki en werkt hier goed.

Changed in ubuntu-nl-website:
status: New → Confirmed
CeesSluis (testcees) wrote :

Tot deze patch is aangebracht kan een work-around toegepast worden om documentatie voor 10.04 in de wiki te plaatsen.

Deze work-around komt er op neer dat de geschikte versienummers als 1 parameter op worden gegeven zodat deze niet gesorteerd worden. Kort gezegd moet de komma(s) tussen de versienummers worden weggelaten.

Normaal gebruik van de macro:
<<GeschiktVoor("ubuntu, kubuntu, server","9,04, 9.10, 10.04 LTS")>>

Work-around:
<<GeschiktVoor("ubuntu, kubuntu, server","9.04 9.10 10.04 LTS")>>

De versienummers moeten in de gewenste volgorde worden opgegeven en worden nu niet meer gesorteerd door de macro.

Ondanks deze work-around blijft het gewenst de patch aan te brengen.

Ronnie (ronnie.vd.c) on 2011-09-10
tags: added: server
CeesSluis (testcees) on 2011-11-02
Changed in ubuntu-nl-website:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers