Manual install causes fastboot to go to disk sleep when flashing userdata image

Bug #1093291 reported by Abhijeet Anand on 2012-12-23
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-nexus7
High
Unassigned

Bug Description

Installing the current image `raring-preinstalled-desktop-armhf+nexus7.img` fails consistently.

Steps followed:
1. Download the *.bootimg and *.img.gz
2. Verify SHA256SUM : OK for both
3. Gunzip *.img.gz
4. fastboot erase boot and fastboot erase userdata
5. fastboot flash boot *.bootimg
6. fastboot flash userdata *.img
    sending 'userdata' (705701 KB)...

The fastboot process gets stuck here every time and top shows it is in `disk sleep`. Can't kill the process either and the device needs to be unplugged and restarted.

Problem: The size is different between manual and script install
File size reported by fastboot when installing manually: 705701 KB
File size reported by fastboot when using the installer: 692481 KB

Changed in ubuntu-nexus7:
importance: Undecided → High
Pham Thanh Nam (alophone2003) wrote :

Please check md5sum for raring-preinstalled-desktop-armhf+nexus7.img after unzip. I realized that copying that big file over USB flash drive altered it somehow, and got problem to flash it to Nexus. I tried to download directly on my working PC instead of copying and it worked!
md5sum for working raring-preinstalled-desktop-armhf+nexus7.img (version 24-Apr-2013, after unzip) is:
ad9557c50f947e0f3dcfe13e0e31bc70

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers