Nexus7 hangs when attempting to switch apps using Alt Tab

Bug #1082101 reported by Asim Pereira on 2012-11-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Onboard
Undecided
Unassigned
ubuntu-nexus7
Undecided
Unassigned

Bug Description

open two or more apps. i had firefox and terminal open.
now from the keyboard press Alt key followed by Tab key (shown as -->| )
this shows the open app but clicking on any apps freezes the device.
only way to recover is via a hard reset.

[sent via firefox on ubuntu nexus7]

Sean Feole (sfeole) wrote :

verified and able to reproduce , opened up firefox and gedit , by pressing alt -> tab hangs the device. Will attempt to further diagnose tomorrow.

tags: added: mobile nexus7
Changed in ubuntu-nexus7:
status: New → Confirmed
Sean Feole (sfeole) wrote :

After going through some tests heres what I have found:

The hanging only occurs when using Onboard as the keyboard.

This problem does not appear to exist when using a USB mouse and keyboard as the input device. After opening 4 applications and minimizing 3 of them I was able to alt-tab amongst each one successfully with the usb keyboard/mouse. As soon as I tried pressing Alt-Tab via Onboard the device hung.

I will look into the Onboard project and triage appropriately

Sean Feole (sfeole) wrote :

I didn't see much in the Onboard project. This bug will most likely fall into Unity / Desktop since the problem is with the app/task switcher

marmuta (marmuta) wrote :

Confirming too. This seems to be another pointer grab issue. Onboard is able to send Alt + Tab-press, the switcher launches and cuts off Onboard from further pointer events. The switcher waits for the release of the tab key, but this never happens. The device isn't completely frozen, as I can close the alt-tab switcher with synergy.

One way out I see is to allow tapping of the switcher's icons. This can already be done with static application switcher from the compiz plugins package, but not with unity's built-in one.

Until there is a better fix, we could perhaps blacklist this key combination in Onboard. What do you think, Sean?

Sean Feole (sfeole) wrote :

Hey marmuta,

Lets see how the raring release goes before making any decisions. I'll run some tests with the app switcher from the compiz plugins package and let you know how it goes.

marmuta (marmuta) wrote :

Sean, I've added that blacklist feature recently, the Nexus configurators can then decide which keys to block. The default for Onboard is to block CTRL+LALT+Fn, the virtual terminal switchers, there's usually no way back. The Nexus 7 configuration we're going to suggest has LALT+TAB blocked too. Nothing is hard-coded, though, it's all in gsettings and can be configured away.
I'll leave Onboard's task open for now, but blocking is probably the best we can do at the moment.

Sean Feole (sfeole) wrote :

I'll take a look at this tonight marmuta, thanks for the feedback. if that works then I'll suggest it and we can make it happen.

Sean Feole (sfeole) wrote :

I see the updates you made: to onboard-defaults.conf.example.nexus7

http://bazaar.launchpad.net/~onboard/onboard/trunk/revision/1183,

I'll try the blacklist syntax you made at the bottom of the file and let you know how i turn out

marmuta (marmuta) wrote :

Yep, that's the file. I think Francesco even packaged it.
Note that the blacklist at the moment only knows of Onboard's key id's, basically the "id" tags in the *.onboard layout files. There's no translation from layout-independent keysyms or characters going on. Things like LALT-TAB should be fine, letter combos like CTRL-d and similar won't be recognized, though.

Francesco Fumanti (frafu) wrote :

marmuta is right: the system defaults file for the nexus 7 is part of the alpha1 source package released yesterday.

But I have also updated the ubuntu-defaults-nexus7 package that is currently available in the Ubuntu repositories with the new system defaults file for Onboard. The updated package is waiting for sponsorship here:
https://bugs.launchpad.net/ubuntu/+source/onboard/+bug/1089396

marmuta (marmuta) wrote :

Onboard's fix for bug #905636 helps here too. I can't reproduce the hangs anymore.

Changed in onboard:
status: New → Fix Committed
Francesco Fumanti (frafu) wrote :

Hi,

I have uploaded a snapshot of the current development status of Onboard containing a fix for this bug and other new features to our main PPA:
https://launchpad.net/~onboard/+archive/ppa

The snapshot is available for raring and for saucy.

Have a nice day.

Changed in onboard:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers