gksu does not accept sudo password on the Nexus7

Bug #1078696 reported by Ara Pulido on 2012-11-14
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-nexus7
Low
Unassigned

Bug Description

Some applications use "gksu" to gain root access when needed.

Right now, gksu is not accepting the default root password in the Nexus 7

Steps to reproduce:

1) Open a terminal
2) Type "gksu"
3) A dialog opens asking you what application you want to open and with which user
4) Select "gedit" as the application and "root" as the user
5) A dialog to type sudo password appears
6) Type the default sudo password

Expected behaviour:
Gedit opens as "root" user

Actual behaviour:
Wrong password error happens

Matt Fischer (mfisch) wrote :

gksu is unusable without a keyboard for me, did you manage to touch type into the password box?

Chris Wayne (cwayne18) wrote :

I'm not able to reproduce this. Using both 'gksu gedit' and following your steps resulted in gedit opening for me.

@Matt

It worked for me.

Changed in ubuntu-nexus7:
status: New → Incomplete
Matt Fischer (mfisch) wrote :

For my issue, I found an upstream:
#421660 gksu's modal password prompt prevents OnBoard's virtual keyboard input, causing accessibility issues

Matt Fischer (mfisch) wrote :

I switched to using vnc so I don't have the issue with onboard. For me, gksu -w fails (su mode), but gksu -S works (sudo mode).

This matches with running su by itself, which also doesn't work

Matt Fischer (mfisch) wrote :

If I set a password for the root user by doing sudo passwd root, then gksu works fine.

Chris Wayne (cwayne18) wrote :

So mine was defaulting to running gksu in sudo mode, rather than su mode, which is why mine worked. It does not work if I force su mode, although I think this is expected, as root has no password.

Changed in ubuntu-nexus7:
status: Incomplete → Confirmed
importance: Undecided → Low
Sean Feole (sfeole) on 2012-11-23
Changed in ubuntu-nexus7:
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
summary: - gksu does not accept sudo password
+ gksu does not accept sudo password on the Nexus7
Sebastien Bacher (seb128) wrote :

unassiging the team from the desktop team, we are not working on it

Changed in ubuntu-nexus7:
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers