Cannot dual boot Ubuntu and Android on Nexus 7

Reported by scccpj on 2012-11-13
88
This bug affects 17 people
Affects Status Importance Assigned to Milestone
ubuntu-nexus7
Wishlist
Unassigned

Bug Description

Need the ability to run both Ubuntu and Android 4.2 on the Nexus 7. As far as I can tell, dual booting currently isn't possible. Please add this as a wishlist or feature request.

Chris Wayne (cwayne18) on 2012-11-13
Changed in ubuntu-nexus7:
importance: Undecided → Wishlist
status: New → Confirmed
Matt Fischer (mfisch) on 2012-11-13
summary: - Cannot daul boot Ubuntu and Android on Nexus 7
+ Cannot dual boot Ubuntu and Android on Nexus 7
Brian Li (brianxp7) wrote :

There's a little something going on in XDA that might do this:
http://forum.xda-developers.com/showthread.php?t=2011403

Of course, it's very experimental. ALWAYS backup your data.

Till Kamppeter (till-kamppeter) wrote :

Brian, I have tried this with 13.04 but I did not succeed. Worked only well for me with 12.10. We probably need to wait some days until MultiBoot version 3 is ready ...

Brian Li (brianxp7) wrote :

Actually, it works fine for me. I have stock, ParanoidAndroid, and Ubuntu 13.04 running without any issues related to multi boot. The installation instructions were a bit confusing at first, though. What are you having trouble with?

Till Kamppeter (till-kamppeter) wrote :

Brian,m I tried in MultiBoot 2 times, I did not try with MultiBoot 3 yet. Are you using MultiBoot 3? Has the Raring kernel kexec hardboot support?

Brian Li (brianxp7) wrote :

Yeah, I'm using MultiROM 3. I just flashed the MultiROM ZIP and kexec-hardboot (CyanogenMod 10 Kernel) like any other flashable ZIP and it works fine. This is my current setup:

Internal (Stock 4.2.1)
CyanogenMod10 (CyanogenMod 10)
CyanogonMod10.1 (CyanogenMod 10.1 Nightly)
ParanoidAndroid (ParanoidAndroid 2.99 Beta 9)
AOKP (AOKP Milestone 1)
MIUI (MIUI 2.12.21)
Ubuntu (Ubuntu 13.04)

They told me I was crazy with that many ROMs.

Brian Li (brianxp7) wrote :

I forgot to mention it's updated in December 20. You're probably using the old files from a previous download.

Till Kamppeter (till-kamppeter) wrote :

I am using MultiROM 4 and the dual boot of Android 4.2 and Ubuntu 13.04 works perfectly for me. I have restored the device back to Android at first, in my case by restoring a backup. The I have installed MultiROM and after that the modified recovery (needs to be updated for the new MultiROM), after that I have installed the kexec-hardboot kernel into Android 4.2 and then installed the daily image of Ubuntu 13.04 via the "Add ROM" functionality of MultiROM. Now I can both test Ubuntu and also use the Nexus 7 like a normal tablet (and trsy Android apps) with Android. See link to the XDA thread with detailed instructions in comment #1.

What needs still to be done is updating the Ubuntu Nexus 7 Wiki. This would encourage more people to test Ubuntu as they can do it without losing their Android.

Till Kamppeter (till-kamppeter) wrote :

Marking fix released as a solution is available.

Changed in ubuntu-nexus7:
status: Confirmed → Fix Released
Jackson Doak (noskcaj) wrote :

is it possible to include this in the image?

Marius B. Kotsbak (mariusko) wrote :

See bug #1212210 for support for MultiROM when using image based updates.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers