gnome-screenshot isn't run via hotkey when menus open

Bug #1077743 reported by Mirzet Kadic on 2012-11-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gnome Screenshot
Expired
Medium
ubuntu-nexus7
Low
Unassigned

Bug Description

gnome-screenshot can't capture all elements, for example the suggestion list.

Desktop version also affected.

Here are some more details:
https://docs.google.com/presentation/d/1z3Zz5h70qZ-3LjNyk8KC6WQ6XXwD-q01vS6ZqqWtnJ8/edit

Alex Chiang (achiang) wrote :

Caracal,

Your bug reports are appreciated. However, please do not include links to google documents.

You can easily take a photo with your camera, then attach the image here in Launchpad.

Thanks.

Chris Wayne (cwayne18) wrote :

Caracal,

Can you please elaborate on what the actual bug is? Is it that running gnome-screenshot closes those elements, or that they somehow just don't show up in the resulting image? It's a known bug that it won't work when indicators menu's are selected.

Changed in ubuntu-nexus7:
status: New → Incomplete
Chris Wayne (cwayne18) wrote :

I believe I know what you're saying now. I've opened an upstream bug, and will link it here.

summary: - gnome-screenshot can't capture all elements
+ gnome-screenshot isn't run via hotkey when menus open
Changed in ubuntu-nexus7:
status: Incomplete → Confirmed
Chris Wayne (cwayne18) on 2012-11-12
Changed in ubuntu-nexus7:
importance: Undecided → Low
Mirzet Kadic (caracal-enl) wrote :

Hi guys,

I am very sorry for the inconvenience.
I couldn't imagine that Google Docs couldn't be welcome. But I am sure there must be a good reason. In my future bug reports I am going to add it as a attachment in the bug report

What I am trying to explain is that: Running gnome-screenshot or releasing the hotkey closes the indicator menu's before they can be captured.
But the indicator menus can be captured using other tools and/or platforms. It is necessary for creating manuals or how-to's.

Chris Wayne (cwayne18) wrote :

Hi Carcal,

Thanks for the update. I've logged an upstream bug for this. As a workaround, you can run gnome-screenshot with -d to have a delay, and then open the menu you want and wait until it's taken.

Mirzet Kadic (caracal-enl) wrote :

Yep, that's a good workaround!
Thank you!

gnome-screenshot with -d

Changed in gnome-screenshot:
importance: Unknown → Low
status: Unknown → Invalid
Sean Feole (sfeole) wrote :

Updating BUG URL since #688135 is a dup

Changed in gnome-screenshot:
importance: Low → Unknown
status: Invalid → Unknown
Changed in gnome-screenshot:
importance: Unknown → Medium
status: Unknown → New
Sean Feole (sfeole) wrote :

assigning this bug to desktop-team although theres not much more to do with it, it is filed in upstream and has been open for over a year.

Changed in ubuntu-nexus7:
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Sebastien Bacher (seb128) wrote :

Thanks but that limitation is due to how xorg and grabs work, that's here for as long as ubuntu (and still not fixed for a reason): see bug #10905

Not something we are going to solve this cycle, unassigning from canonical desktop team...

Changed in ubuntu-nexus7:
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
Changed in gnome-screenshot:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.