Bad multicore performance

Bug #1076793 reported by Mirzet Kadic on 2012-11-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-nexus7
High
Unassigned

Bug Description

I ran a couple of cpu and video recording tests with some onboard tools.

I realized that almost everything is runing on one core. In best case are two cores used.

Here is a presentation:
https://docs.google.com/presentation/d/1jyxGkxqJLp5-WOpmaCva8Mkwc0ivJp0ZtC91gCmrMQI/edit

Why that?

You can download all files fom the presentation here: https://docs.google.com/open?id=0B4yEtafZsxezaUpURjRyTUxFMG8

tags: added: nexus7
Matt Fischer (mfisch) wrote :

Can you provide some comparison between the N7 and another device? I'd like to confirm that this is or is not platform specific.

Hi,

Can you clarify that what you mean is that all the cores are not being used effectively? This may be a bit too wide-ranging a bug, but I'll let someone else make that call.

Changed in ubuntu-nexus7:
status: New → Incomplete
Chris Wayne (cwayne18) wrote :

I'm not able to reproduce this. Running htop while running different programs, I'm seeing all cores being used. Please provide more information on how to reproduce.

Changed in ubuntu-nexus7:
status: Incomplete → Confirmed
status: Confirmed → Incomplete
Mirzet Kadic (caracal-enl) wrote :

I am not a hacker or dev. I don't no if this is a problem of the kernel or the apps. Could it be that the benchmarks aren't optimized for multicore?. I compared the Tablet with my Desktop with Core 2 Duo and I used PowerTOP. Here are the new results:
https://docs.google.com/presentation/d/12ZXc5dhkZbDxElL3frRrltyYgDBtQt3nJnMaGjkandk/edit

However my feeling in general is that the response of the tablet is very low. Recording a video and and voice using RecordMyDesktop or Kazam was painfully slow on this monster machine with 4 CPU Cores and 8 GPU Cores. The CUP Benchmarks were faster on my Desktop than N7.

How to reproduce:
Run the same apps as I used and see if you get the same results. :-|

tags: added: mobile
Matt Fischer (mfisch) on 2012-11-13
Changed in ubuntu-nexus7:
status: Incomplete → New
Anders Østerholt (diebels) wrote :

Caracal,
can you run multiple instances of hardinfo simultaneously to see if more cores gets used?

By the way, Tegra3 is not that powerful, more like Intel Atom level of performance.

Chris Wayne (cwayne18) wrote :

I ran sysbench --test=cpu --num-threads=4 on this system and on my i5 laptop. The i5 shows the following:

Test execution summary:
    total time: 3.3385s
    total number of events: 10000
    total time taken by event execution: 13.3466
    per-request statistics:
         min: 1.21ms
         avg: 1.33ms
         max: 15.67ms
         approx. 95 percentile: 1.38ms

Threads fairness:
    events (avg/stddev): 2500.0000/38.70
    execution time (avg/stddev): 3.3367/0.00

While the nexus 7 results are attached. Notice the enormous difference (total time: i5 is 3.3, nexus7 is 48.8)

Due to these results, marking back as confirmed.

Changed in ubuntu-nexus7:
status: New → Confirmed
importance: Undecided → High
Mirzet Kadic (caracal-enl) wrote :

I'm really relieved...
Thank you Chris.
Cannot provide you with future test results for a couple of days due to 4.2 :-|

Oliver Grawert (ogra) wrote :

We switched to the interactive cpufreq governor a while ago which should act a lot more fine grained ... could someone check if the issue still exists with a recent image

Changed in ubuntu-nexus7:
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments