When in portrait mode, mouse movement glitches rightward intermittently

Bug #1076627 reported by Bryce Harrington on 2012-11-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-nexus7
High
Unassigned
xorg-server (Ubuntu)
High
Bryce Harrington

Bug Description

[Steps to reproduce]
1. Open terminal
2. Run /usr/bin/xrotate
3. Touch and hold on the dialog titlebar
4. Drag the dialog up and down the screen

Expected behavior: Dialog window moves smoothly across screen
Actual behavior: Dialog window occasionally flickers and jumps around the screen

[Discussion]
The window appears to jump some fixed amount when dragging, although the amount it jumps varies from one drag to the next. Primarily the jumps seem to be +X (rightward) jumps of ~200 pixels, although occasionally there will be larger +Y (downward) jumps of 300-400 pixels. If one of these downward jumps occurs when the dialog is partially off the bottom of the screen it can result in the entire window moving to the next workspace down.

Chris Wayne (cwayne18) wrote :

I can confirm this following the given steps

Changed in ubuntu-nexus7:
status: New → Confirmed
Chris Wayne (cwayne18) on 2012-11-12
Changed in ubuntu-nexus7:
importance: Undecided → High
Chris Wayne (cwayne18) on 2012-11-16
description: updated
Bryce Harrington (bryce) wrote :

Fix uploaded to staging ppa.

Changed in ubuntu-nexus7:
status: Confirmed → Fix Committed
Sean Feole (sfeole) wrote :

Loaded xorg 2:1.13.0-0ubuntu6.1~nexus7.1 from staging. Looks like the issue has been fixed

1. Open terminal
2. Run /usr/bin/xrotate
3. Touch and hold on the dialog titlebar
4. Drag the dialog up and down the screen

Expected behavior: Dialog window moves smoothly across screen
Actual behavior: Dialog window moves smoothly across screen

Bryce Harrington (bryce) wrote :

Variant of the patch was accepted upstream but is not yet in the xserver we include in raring, so will need to include a backport of it there.

Changed in xorg-server (Ubuntu):
assignee: nobody → Bryce Harrington (bryce)
importance: Undecided → High
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.13.1.901-0ubuntu2

---------------
xorg-server (2:1.13.1.901-0ubuntu2) raring; urgency=low

  * Add 237_dix_save_touchpoint_last_coords_before_transform.patch:
    Fix sensitive touch settings on Nexus 7 when input is transformed.
    (LP: #1075415, #1076567, #1076627)
 -- Bryce Harrington <email address hidden> Tue, 22 Jan 2013 13:51:16 -0800

Changed in xorg-server (Ubuntu):
status: In Progress → Fix Released
Bryce Harrington (bryce) on 2013-01-28
Changed in ubuntu-nexus7:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers