Screen is corrupted between rotations

Bug #1073096 reported by Brendan Donegan on 2012-10-30
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
X.Org X server
New
Undecided
Unassigned
ubuntu-nexus7
High
Alex Chiang

Bug Description

When X is instructed to rotate the display, there is screen corruption inbetween each rotation. This can easily be reproduced by installing Checkbox and running /usr/share/checkbox/scripts/rotation_test

Eric Zig (zuric) wrote :

When I run /usr/share/checkbox/scripts/rotation_test
I've got this error:

Traceback (most recent call last):
  File "/usr/share/checkbox/scripts/rotation_test", line 31, in <module>
    from checkbox.contrib import xrandr
ImportError: No module named checkbox.contrib

And nothing happens

It's a little odd that /usr/share/checkbox/scripts/ can exist but not the checkbox.contrib.xrandr module. Can you confirm a few things?

1.) dpk -s checkbox
2.) ls /usr/lib/python3/dist-packages/checkbox/contrib/

Changed in ubuntu-nexus7:
status: New → Incomplete
tags: added: mobile
Chris Wayne (cwayne18) wrote :

What if it is simply run with xrotate?

Eric Zig (zuric) wrote :

Yes (I believe..), i have checkbox.contrib.xrandr

When I run ls /usr/lib/python3/dist-packages/checkbox/contrib/
I have

bpickle.py glock.py persist.py REThread.py
gdk.py __init__.py __pycache__ xrandr.py

Eric Zig (zuric) wrote :

I did rotation with the display settings, I have screen corruption just with normal and 180 degrees rotation (so in the portrait screen) other it's fine

Chris Wayne (cwayne18) wrote :

Please try running /usr/bin/xrotate. At this point, any other test should be considered incomplete

Eric Zig (zuric) wrote :

Yes /usr/bin/xrotate result also a screen corruption

Chris Wayne (cwayne18) wrote :

Thank you, moving this bug to Confirmed.

Changed in ubuntu-nexus7:
status: Incomplete → Confirmed
Matt Fischer (mfisch) on 2012-11-05
tags: added: needs-upstream nexus7
Matt Fischer (mfisch) on 2012-11-05
tags: removed: needs-upstream
Bryce Harrington (bryce) wrote :

Yep, this is presumably a tegra bug. Should be escalated to nvidia.

Bryce Harrington (bryce) on 2012-11-08
tags: added: tegra3
Chris Wayne (cwayne18) on 2012-11-13
Changed in ubuntu-nexus7:
importance: Undecided → High
Sean Feole (sfeole) wrote :

Assigning to Alex , tegra3 related, still Confirmed in Raring, Needs escalation to Nvidia.

Changed in ubuntu-nexus7:
assignee: nobody → Alex Chiang (achiang)
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1073096

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers