Hitting power button should suspend system, rather than popup shutdown menu

Bug #1071185 reported by Chris Wayne on 2012-10-25
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-nexus7
Low
Unassigned
ubuntu-defaults-nexus7 (Ubuntu)
Low
Oliver Grawert
Raring
Low
Oliver Grawert

Bug Description

Image: 20121025-1

Summary:
When using a tablet, the general use case for hitting the power button is to just 'sleep' (or suspend). Right now, the shutdown menu is popped up instead. This default action should be changed.

Note:
This may be a gconf key at apps/gnome-power-manager/buttons/power

Chris Wayne (cwayne18) on 2012-10-25
Changed in newark:
status: New → Confirmed
importance: Undecided → Low
tags: added: nexus7
Matt Fischer (mfisch) on 2012-10-26
information type: Proprietary → Public
affects: newark → ubuntu-nexus7
Michael Hall (mhall119) on 2012-10-26
tags: added: mobile
Jani Monoses (jani) wrote :

gsettings set org.gnome.settings-daemon.plugins.power button-power 'suspend' does it here.

Jani Monoses (jani) wrote :

If the touchscreen bug occurs and we cannot bring up on the system menu via tapping, this dialog that now shows up when pressing the power button still allows us to restart/shutdown (it handles taps in a way immune to the bug it seems).
So maybe we should only enable suspend on button press after we fix the tap issue.

Oliver Grawert (ogra) on 2012-11-27
Changed in ubuntu-defaults-nexus7 (Ubuntu Raring):
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Oliver Grawert (ogra)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-defaults-nexus7 - 0.35

---------------
ubuntu-defaults-nexus7 (0.35) raring; urgency=low

  * make powerbuuton suspend immediately instead of showing an interactive
    popup (LP: #1071185)
  * set the default form factor in unity to "netbook", which is closer to a
    tablet than "desktop"
 -- Oliver Grawert <email address hidden> Tue, 27 Nov 2012 13:42:21 +0100

Changed in ubuntu-defaults-nexus7 (Ubuntu Raring):
status: Confirmed → Fix Released
Sean Feole (sfeole) wrote :

Default action for the raring build is to bring up the shutdown/reboot screen. Due to the touchscreen bug we will keep this behavior for now.

Oliver Grawert (ogra) on 2013-02-11
Changed in ubuntu-nexus7:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers