physical rotation doesn't rotate screen and input automatically

Bug #1068442 reported by Matt Fischer on 2012-10-19
70
This bug affects 14 people
Affects Status Importance Assigned to Milestone
ubuntu-nexus7
High
Jani Monoses
gnome-settings-daemon (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Once Bug# 1092952 is solved and we are able to listen for rotate events from the kernel, then we need to hook this signal in with the gnome-settings-daemon code that tracks rotation status and performs the xinput and xrandr rotation events.

Bryce has written an xrotate script that maybe we could attach to the rotation events, but in theory we shouldn't need it.

Bryce adds, "Theoretically there should be code in gnome-settings-daemon (or gnome-desktop) which listens for xrandr events and rotates the input. So when we have proper handling of the sensor we can hook that to the gtk events and let g-s-d rotate the input, and then xrotate simply becomes a debugging tool."

Matt Fischer (mfisch) on 2012-10-19
Changed in newark:
assignee: nobody → Jani Monoses (jani)
status: New → Confirmed
importance: Undecided → High
Bryce Harrington (bryce) on 2012-10-23
summary: - rotation doesn't work
+ physical rotation doesn't rotate screen and input automatically
Matt Fischer (mfisch) on 2012-10-25
tags: added: nexus7
Matt Fischer (mfisch) on 2012-10-26
information type: Proprietary → Public
tags: added: mobile
affects: newark → ubuntu-nexus7
Bryce Harrington (bryce) wrote :

Really, this bug report should be split into two pieces: First, the kernel needs to communicate the rotation events up. This is probably going to require plumbing in the sensor driver. Second is the task of hooking this signal in with the g-s-d code that tracks rotation status and performs the xinput and xrandr rotation events.

description: updated
Changed in gnome-settings-daemon (Ubuntu):
status: New → Triaged
importance: Undecided → High
Robert Bruce Park (robru) wrote :

So, as per Bryce's advice, I've split this bug into two pieces. Bug# 1092952 is for the kernel half of this bug, and this bug is now just for the g-s-d half.

Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Changed in ubuntu-nexus7:
status: Confirmed → Triaged
Jani Monoses (jani) wrote :

The kernel already had this just was not entirely obvious.
https://blueprints.launchpad.net/ubuntu/+spec/desktop-r-arm-input-sensor-drivers

So the remaining task is hooking up g-s-d instead of using a standalone daemon as in the test app linked from the blueprint.

Braxton Plaxco (braxtonplaxco) wrote :

Issue seems to have been resolved because physical rotation does rotate my screen

Oliver Grawert (ogra) wrote :

it has been worked around by some scripts ...
nontheless it should be properly fixed in gnome-settings-daemon instead, closing the nexus7 task but leaving g-s-d open....

ubuntu-defaults-nexus7 (0.41) raring; urgency=low

  * add acceld.conf upstart job, acceld binary to /usr/bin
    and 95-acceld_start XSession.d file this enables auto-rotation of
    the screen. it can be disabled by editing /etc/default/acceld

-- Oliver Grawert <email address hidden> Mon, 21 Jan 2013 16:48:47 +0100

Changed in ubuntu-nexus7:
status: Triaged → Fix Released
tags: added: raring
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers