Unity panels don't display visuals

Reported by Bryce Harrington on 2012-10-11
64
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Nux
Critical
Unassigned
ubuntu-nexus7
Critical
Chris Halse Rogers

Bug Description

Screenshot at https://wiki.canonical.com/BryceHarrington/UnityBringUp

Current thinking is that it's a video driver bug with transparency. We think we need to either engage with NVIDIA over the bug, or investigate ways to work around it in nux. Currently, we're trying to boil it down to a simpler nux test case.

Matt Fischer (mfisch) on 2012-10-17
Changed in newark:
importance: Undecided → Critical
status: New → Confirmed
Alex Chiang (achiang) wrote :

nux (3.8.0-0ubuntu1nexus7.1) quantal; urgency=low

  * Hack out all attempts to attach a depth texture to a FBO; tegra
    does not support depth textures.
 -- Christopher James Halse Rogers <email address hidden> Fri, 19 Oct 2012 04:55:33 +0000

Changed in newark:
status: Confirmed → Fix Committed
Chris Wayne (cwayne18) wrote :

Verified fixed

tags: added: cqa-verified
Alex Chiang (achiang) wrote :

This was fixed in Newark with a hack, but it needs to be fixed properly upstream for R.

Re-opening and marking as affecting nux.

Changed in newark:
status: Fix Committed → Confirmed
information type: Proprietary → Public
no longer affects: newark
Alex Chiang (achiang) wrote :

This was confirmed for Nux 3.8.0 as shipped in 12.10.

Changed in ubuntu-nexus7:
status: New → Confirmed
importance: Undecided → Critical
Omer Akram (om26er) wrote :

I have attached the screenshot from the wiki here. can't test to confirm though.

Changed in nux:
importance: Undecided → High
importance: High → Critical
Mirzet Kadic (caracal-org) wrote :

I am not sure if my problem is the same as you are talking about? Please see my attached file.

Alex Chiang (achiang) wrote :

Same issue.

nux is attempting to attach a depth buffer to an FBO and you get this corruption. I bet you upgraded to the latest nux even though we said not to. ;)

In any case, this is a known issue in upstream nux and we're simply waiting for a fix from that team.

Mirzet Kadic (caracal-org) wrote :

Yep, i did update because i didn't know if my issue is effected by this nux bug. I reflashed my N7 and installed again all updates excluded the nux updates and everything works well now. thank you.

Chris, What would it take to get this patch properly upstream asap?

Changed in ubuntu-nexus7:
assignee: nobody → Chris Halse Rogers (raof)
Omer Akram (om26er) wrote :

That patch was actually a hack as it says in changelog so I think now it needs to be really fixed in nux.

On Wed, Nov 14, 2012 at 03:56:17PM -0000, Omer Akram wrote:
> That patch was actually a hack as it says in changelog so I think now it
> needs to be really fixed in nux.

That's correct. The patch just disables some functionality which
doesn't work on the tegra3.

The proper fix for this would be to either #ifdef this code to disable
it on tegra3, or replace it with something more suitable. I understood
that PS in reviewing Chris' patch has taken the action to implement the
correct fix upstream.

Alex Chiang (achiang) wrote :

Hi,

I talked with Tim Penhey and Jay Taoko. They are preparing a nux branch for upload this week (11/14/2012). If we don't see an update from them, I'll ping again.

Thanks.

Matt Fischer (mfisch) on 2012-11-16
Changed in ubuntu-nexus7:
status: Confirmed → In Progress
Victor Tuson Palau (vtuson) wrote :

any updates on this bug?

Omer Akram (om26er) on 2012-11-22
Changed in nux:
assignee: nobody → Jay Taoko (jaytaoko)
status: New → Confirmed
Alex Chiang (achiang) wrote :

This is hung up in testing, as Jay targeted nux 4.x, and that is proving to be difficult to backport to test in 12.10.

https://code.launchpad.net/~unity-team/nux/nux.depth-texture-detection-support/+merge/134729

Lukasz Zemczak is working on providing us some packages to test with.

Alex Chiang (achiang) wrote :

Subscribed sil2100, but wasn't able to assign to him.

Accidentally unsubscribed Jay Taoko, can't reassign back.

Changed in nux:
assignee: Jay Taoko (jaytaoko) → nobody
Sean Feole (sfeole) wrote :

sil200 provided us with unity and nux 4.x which are available in the ~unity-team ppa

https://launchpad.net/~unity-team/+archive/ppa/?field.series_filter=quantal

Nux 4.x and Unity 6.12 both installed perfectly on Quantal. And appear to be functioning as expected.

After installing Quantal on the Nexus7 add: ' ppa:unity-team/ppa ' and please upgrade unity & nux.

Felix Albrecht (ftalbrecht) wrote :

Having the same problem as Mirzet Kadic on the 32GB 3G variant. Since installation of quantal does not work for 3G I tried several raring images, i.e. the one from 02. Dez. 2012. After installation panel and dash are not shown correctly, functionality is there. Adding the unity-team ppa (for quantal) and updating nux and unity did not resolve the issue. Happy to carry out further tests, if needed!

Oliver Grawert (ogra) wrote :

yes, this is bug 1065638, feel free to subscribe to it, we were promised a fix for nux in raring for this week

Oliver Grawert (ogra) wrote :

err, oops, the last comment was supposed to go to bug 1079729, sorry, mixed up browser tabs

Sean Feole (sfeole) wrote :

Removing cqa-verified tag until we see this confirmed fix on raring

tags: removed: cqa-verified
Sean Feole (sfeole) wrote :

As of yesterday the raring fixes are available in the unity-team daily ppa. Speaking with Ogra he hopes these land in the nexus7 raring daily tomorrow. At this time I have successfully installed the patch onto raring daily from 12/04. Unity panels are looking good so far.

Eleni Maria Stea (hikiko) wrote :

I ve seen that the status https://bugs.launchpad.net/ubuntu-nexus7/+bug/1079729 is now "fix-released", does the same apply for this bug too?

Oliver Grawert (ogra) wrote :

yes, this one is long gone

Changed in ubuntu-nexus7:
status: In Progress → Won't Fix
status: Won't Fix → Fix Released
Changed in nux:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers