twitter web service in moblin is unreliable

Bug #440482 reported by Omer Akram on 2009-10-02
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-moblin-remix
Medium
Unassigned

Bug Description

there are no fields to enter username or password for logging in to twitter

Omer Akram (om26er) wrote :
Omer Akram (om26er) wrote :

here is the other one

Omer Akram (om26er) wrote :

by clicking log me in i get the second field and nothing else

Ying-Chun Liu (paulliu) wrote :

hmm. Really strange.

Sorry I'm not a twitter user. But when I click the log-in button.
The Web browser starts automatically and wants me to login with username and password.

However I don't have a twitter account. So I use another PC to register a new account of twitter.

After input my newly registered account and password in my moblic netbook, it asks me to deny/allow Moblin to use my twitter account.
I choose allow.
And it gives me a PIN code.
It's a sequence of numbers but I can't remember it. Seems useless.

And after that I press the continue button in bisho (setting window) (your second screenshot)

And in myzone, I found the right-part contains a lot of twitter messages.
So I think it does work.

This is my screenshot.

Omer Akram (om26er) wrote :

ok my default browser was changed to google chrome when i changed it to moblin-web-browser from preferred application the web browser opened

Changed in ubuntu-moblin-remix:
status: New → Fix Released
status: Fix Released → Invalid

It doesn't work for me!

I can log-in to twitter, then allow moblin the access and I get the PIN code;
I then return to the "Webservices" and I click continue (filling in the field with the PIN or leaving it empty)
but nothing happens. The button now says "Log me out" but I cannot set any status and no feeds are shown

Changed in ubuntu-moblin-remix:
status: Invalid → Incomplete
Omer Akram (om26er) wrote :

no... you have to go to the status panel to change your status

Omer Akram (om26er) wrote :

i reported this bug because when i got into this bug my default browser was changed to chrome so i was not getting the web page to login and get the pin code. but when the default browser was changed to moblin-web-browser everything became ok.

Changed in ubuntu-moblin-remix:
status: Incomplete → Invalid

The status panel continues to say that I need to setup a Web Service!
I cannot manage to set up a web service in any way, any hints?

I did the following:

1) go to Web Services; choose twitter and click "Log me in"
2) the browser pop-up and I can log-in and allow access to moblin
3) the browser shows me a PIN code
3) I then go back to Web Services and click "Continue"

Nothing happens now, my status is off-line (in the status panel)
and the web services panel is the same as step 1.

Omer Akram (om26er) wrote :

do you paste the pin code in the web services before clicking continue?

sure! I did. I'm trying to clean up browser cache and repeat all those steps just to be sure that it is reproducible

so that's what I come up with:

1) go to Web Services; choose twitter and click "Log me in"
2) the browser pop-up and I can log-in and allow access to moblin
3) the browser shows me a PIN code
4) paste the PIN code to Web Service
5) Web Service now shows me a "Log me out" button
6) If I go to the status panel it says I need to set up a web service

Omer Akram (om26er) wrote :

plz do the following:
sud

Omer Akram (om26er) wrote :

ignore the last comment i thought i was using a termianl
sudo apt-get update && sudo apt-get dist-upgrade

I got nothing to update/upgrade:

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded

Omer Akram (om26er) wrote :

alright, this bug is confirmed. now i am unable to use twitter too

Changed in ubuntu-moblin-remix:
status: Invalid → Confirmed
Omer Akram (om26er) wrote :

matteo, after a reboot i can change my status but they dont appear in myzone. but i can see em on twitter.com

Omer Akram (om26er) wrote :

and now after all my status is also available in myzone so not exactly a big for me

Omer Akram (om26er) wrote :

and now after all my status is also available in myzone so not exactly a bug for me

still nothing new here on my side: I'm always unable to either set my status or to see tweets on myzone.

I'm trying to update and upgrade now, I saw that there were some updates available.
I'll report back if something new happen.

I've rebooted but I have always the same issue.
Something I could try to do in order to help with the debug?

I'm still suffering this bug, any news someone?

Bill Filler (bfiller) wrote :

this is working for me. The part that is confusing is tweets don't show up on myzones until you accept a prompt (that sometimes get hidden behind myzones) that is asking if Mojito can have access to your keyring. After I accept this dialog I get the tweets. Not sure why mojito is prompting, this needs to be investigated.

I've never seen such a dialog. I'll re-try to add my twitter account using the WebServices application.

I've just tried to set my twitter account on the WebService but still the same issue:
nothing shows up in myzone, no dialogs appear (neither above nor below myzone) and
the status says that I'm off-line and I need to set a Web Service

Omer Akram (om26er) wrote :

this is not a bug. not now not before

Changed in ubuntu-moblin-remix:
status: Confirmed → Invalid

so do you think it an issue related to my own installation? or what else?

Ok, this is not a bug and it has not ever been.... anyway I'm still not able
to make my status panel to work: it always says I need to set up an account
using the Web Services application.

I forgot to mention that also in myzone nothing appears from my twitter account

Omer Akram (om26er) wrote :

matteo, there are many moblin panels related bug that i don't think are gonna get fixed even before release date.

1 the bug related to twitter is not invalid. first create twitter account and then restart on the next boot it will ask you permissions to always allow. when done permissions restart again then you will see in the status panel that you can change your twitter status but it will update almost 5mins later when you will be connected to twitter. then restart again and see in myzone your status. this is a bug and no boot should be required.

2 you cannot change status for any of you empathy account from status panel

3. you cannot see any of you online contacts in people panel

4. pasteboard dont save anything.

summary: - no way to login to twitter
+ login to twitter is complex like hell
Changed in ubuntu-moblin-remix:
status: Invalid → Confirmed

internet panel appears late at boot. it thumbnails are not fullscreen.

thank you very much! I'll try the workaround you described right now.

Paul Larson (pwlars) wrote :

I'm able to confirm this. I can manage to see the updates on myzone after clicking on the keyring authorization Bill mentioned in comment #24. However, this authorization is not even prompted for until several minutes after setting up the web service. I closed everything and it finally popped up on it's own several minutes later. At this point, the updates to myzone work, but not status changes. The status change screen still says I need to set up a web service.

summary: - login to twitter is complex like hell
+ twitter web service in moblin is unreliable
Changed in ubuntu-moblin-remix:
importance: Undecided → Medium
Efrain Valles (effie-jayx) wrote :

I can confirm this still happens.

I am able to authenticate in the twitter website.
I write the number in the web services dialog

I get no status updates anor i can update my status

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers