APT error during installer

Bug #439485 reported by Loïc Minier on 2009-09-30
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
Undecided
Loïc Minier
ubuntu-moblin-remix
High
Loïc Minier
apt-setup (Ubuntu)
Undecided
Unassigned
ubiquity (Ubuntu)
Low
Unassigned

Bug Description

Hi

I get an APT error in a popup during install (see screenshot).

I can still install though

Bye

Loïc Minier (lool) wrote :
Omer Akram (om26er) wrote :

i thought that was a universal karmic problem

Marchombre (princestark) wrote :

Is there any harm in there ?

Paul Larson (pwlars) wrote :

screenshot of some /var/log/messages output on a system where I saw this

Paul Larson (pwlars) wrote :

Marking this low. It blocks progress until you ok it, but it doesn't seem to prevent the install from succeeding.

Changed in ubuntu-moblin-remix:
importance: Undecided → Low
status: New → Triaged
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Loïc Minier (lool) wrote :

Patrice, what lets you think it's a bug in ubiquity?

Patrice Vetsel (vetsel-patrice) wrote :

@Loïc : nothing specifically. I get this bug during desktop amd64 installation process (using ubiquity). So it's not only an "ubuntu-moblin-remix" bug, but may be a problem with ubiquity.

Loïc Minier (lool) wrote :

Interesting, thanks

Matt Zimmerman (mdz) wrote :

This may not block installation, but still needs to be fixed for 9.10

Changed in ubiquity (Ubuntu):
milestone: none → ubuntu-9.10
Phil Norbeck (ptn107) wrote :

I can't reproduce this with the beta image (ubuntu-9.10-beta-desktop-amd64.iso) or the latest daily 10-13-2009 (karmic-desktop-amd64.iso). Tried with both my test machines and a vm.

Tobin Davis (gruemaster) wrote :

I am able to reproduce this with today's (20091015) karmic-moblin-remix-i386.iso image.

Paul Larson (pwlars) wrote :

setting importance to high, because this really does need to be addressed before release and still exists in daily builds. It doesn't seem to prevent the install from finishing, but can give the impression that the install is failing

Changed in ubiquity (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in ubuntu-moblin-remix:
importance: Low → High
Omer Akram (om26er) wrote :

have any1 tested the live cd from a cd/dvd rom because the error comes when scanning for cd-rom

Evan (ev) wrote :

This is triggered by the Moblin CD not having any packages in pool/. APT checks for Packages and Sources files to indicate a valid Debian CD, neither of which are present on the Moblin CD.

Michael Vogt (mvo) wrote :

Could we simply make ubiquity or apt-setup ignore this error condition? It seems to me like making apt-cdrom accept CDs without Packages should issue a error, but the installer should just ignore it in this case.

Loïc Minier (lool) wrote :

I checked the debian-cd code, it seems we added code to strip empty Packages files from live CDs in r829; I'm clarifying with Colin whether it's ok to keep them or at least keep one such file.

@Michael: is there a way to distinguish this error condition from others? e.g. we want to fail on I/O errors, but I don't think we want to add logic to check for Packages file before calling APT as it would kind of duplicate the logic.

Loïc Minier (lool) wrote :

I've included a workaround in debian-cd to keep the Packages file for this project.

Changed in ubuntu-moblin-remix:
status: Triaged → Fix Committed
assignee: nobody → Loïc Minier (lool)
Changed in ubuntu-cdimage:
status: New → Fix Released
assignee: nobody → Loïc Minier (lool)
Loïc Minier (lool) on 2009-10-20
Changed in ubuntu-moblin-remix:
status: Fix Committed → Fix Released
Omer Akram (om26er) wrote :

fixed in 20091019.1?? 20091020 is not out at cdimage

Loïc Minier (lool) wrote :

Dailies are disabled until release, but slangasek planned a rebuild of moblin remix for today already.

Loïc Minier (lool) wrote :

I didn't see this bug in RC candidates testing.

Paul Larson (pwlars) wrote :

Marking the rest of the tasks invalid, this is fixed and working fine in the daily images now

Changed in ubiquity (Ubuntu):
status: Triaged → Invalid
Paul Larson (pwlars) on 2009-10-21
Changed in apt-setup (Ubuntu):
status: New → Invalid
Loïc Minier (lool) wrote :

I reopened the tasks -- I merely added a workaround in the moblin images which is quite crude.

Probably one of apt-setup or ubiquity should be fixed to ignore CDs with no Packages files, not sure which. I changed the debian-cd scripts to not strip empty Packages files from the CD for the moblin-remix project.

Changed in ubiquity (Ubuntu):
status: Invalid → Triaged
importance: High → Low
milestone: ubuntu-9.10 → none
Changed in apt-setup (Ubuntu):
status: Invalid → Triaged
Loïc Minier (lool) wrote :

(I did lower priority and dropped the milestone though)

Krisi (krisi1992) wrote :

I'm installing Ubuntu 9.10 from USB, and I got this error.

tags: added: iso-testing
Changed in apt-setup (Ubuntu):
status: Triaged → Fix Committed
status: Fix Committed → New
Steve Langasek (vorlon) on 2011-07-23
Changed in apt-setup (Ubuntu):
status: New → Triaged
Tobin Davis (gruemaster) wrote :

Is this still valid for either apt-setup or ubiquity? Closing as incomplete otherwise.

Changed in ubiquity (Ubuntu):
status: Triaged → Incomplete
Changed in apt-setup (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers