Claws Mail - Shortcut keys are non-functional

Bug #223840 reported by Chris Gregan on 2008-04-28
4
Affects Status Importance Assigned to Milestone
Claws Mail
Invalid
Undecided
Unassigned
Ubuntu Mobile Edition
Medium
Unassigned
claws-mail (Ubuntu)
Undecided
Unassigned

Bug Description

<Build: UME Daily 20082504>
<Environment: Jax10>

Summary:
The CTRL keys listed in the various drop down menus are non-functional. When using the CTRL keys they actually switch values. Minimally that should have static values

Steps to Reproduce:
1) Launch Claws Mail
2) Tap to open App Menu
3) Tap Edit
4) Open keyboard and type Shift+Ctrl+F
5) Type Alt+S

Expected result:
Folder Search is launched

Actual result:
The text "Shift+Ctrl+F" moves up to Copy. When Alt+S is pressed, the text is replaced with Alt+S

Chris Gregan (cgregan) on 2008-04-28
Changed in ubuntu-mobile:
importance: Undecided → Medium
status: New → Confirmed
Colin Leroy-Mira (colin-colino) wrote :

This actually works correctly on Desktop versions of Claws Mail as well as on Maemo. The bug is probably in the unofficial, unsubmitted-upstream UME patch from Ubuntu.

Changed in claws-mail:
status: New → Invalid
Michael Terry (mterry) on 2008-06-03
Changed in acton:
assignee: nobody → mterry
status: New → In Progress
Michael Terry (mterry) wrote :

Chris, it looks like you found the "customisable menu shortcuts" feature of Claws. This lets you change the keyboard shortcut for menu items by hovering over them and pressing the new shortcut.

This functionality is built into GTK+, and controlled in GNOME by the non-exposed gconf key /desktop/gnome/interface/can_change_accels, which defaults to off. Claws has its own setting for this, which is turned on by default.

I'd propose that it would be nice for Claws to change the default to off. I think most users are used to this being off and would be surprised (as Chris was) that the shortcut changed when they were pressing buttons.

But, Chris, even with that feature off, pressing the shortcut while the menu is up wouldn't activate it the desired menu item. You need to press the key combo when the menu is not popped up.

Loïc Minier (lool) wrote :

I think we want to disable this by default in the regular Gtk+ version as well.

Michael Terry (mterry) on 2008-06-04
Changed in acton:
status: In Progress → Fix Committed
Michael Terry (mterry) wrote :

Here's a debdiff for intrepid. I'm not sure I bumped the version number correctly (from -build1 to -build1ubuntu1).

Changed in claws-mail:
status: New → Confirmed
Colin Leroy-Mira (colin-colino) wrote :

You actually plan on disabling this feature by default in all Claws Mail builds?
That will very probably be greeted by a few bug reports about how the feature doesn't work anymore, by people who actually use it.

I don't recommend applying this patch. Closing this bug as invalid and pointing the submitter to "Preferences/Other/Enable customizable keyboard shortcuts" seems more sane.

The "Steps to reproduce" described above don't even work, in when gtk-can-change-accel is set to off. Tested with Firefox, tapping on Edit and hitting Ctrl-Z does not undo. The correct sequence is:
1. Hit Alt-E (opens the Edit menu)
2. Hit S (runs Folder search)

Loïc Minier (lool) wrote :

GNOME disables this support for all GNOME and Gtk+ by default, why would it be sensible to diverge for claws-mail?

Loïc: can you please take a look at it?

Michael Terry (mterry) on 2008-06-12
Changed in acton:
milestone: none → rc0
status: Fix Committed → Fix Released
Loïc Minier (lool) wrote :

Michael, thanks, uploaded with minor changes:
  * Tweak above changelog entry to clarify actual change.
  * Tune Ubuntu revision.
  * Update upload date.

Concerning the Ubuntu version, you don't need to keep the "build1" in the revision, we use it when we don't need to keep the Ubuntu changes if a new Debian revision appears, but otherwise we use regular ubuntuN revisions.

Colin, I notice you're an upstream Claws Mail developper, I hope you'll understand the following rationale from Ubuntu and UME point of views.

I can understand that Claws Mail has power users who benefit from the usefulness of redefining keyboard shortcuts, still I weighted these arguments in favor of the change:
1) the GNOME / Ubuntu desktop defaults to disabling this Gtk+ feature for all apps; Claws Mail is just an alien when mixed with others here
2) this feature is only rarely useful; you redefine your keyboard shortcuts on very rare occasions where you are ready to dig into the preferences (and enable this feature back), but then you don't want it to change by accident

I personally wouldn't encourage allowing to change keyboard shortcuts in an application too easily as it prevents you from immediately using the same application from another computer, and it is likely to cause differences in keyboard shortcuts for the same action in different apps on the same desktop (e.g. you don't want really want to redefine Save ^S or Print ^P or Exit ^Q, these are just expected in all apps).

I think users who use this feature and rely on the default will naturally react by opening the prefs when they want to change accels again. Would I be using this feature, I'd personally edit my keyboard shortcuts, then turn keyboard shortcut edition to read-only.

NB: I could reproduce with the steps indicated by Chris; it's hard to hit small menu items in UME, so it's tempting to switch to typing the keybinding when you just read what it is in the menu that you just opened.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package claws-mail - 3.4.0-2ubuntu1

---------------
claws-mail (3.4.0-2ubuntu1) intrepid; urgency=low

  [ Michael Terry ]
  * New patch, 12disable_can_change_accels_by_default, let
    the gtk_can_change_accels pref which allows to change keyboard shortcuts
    from Gtk+ menus default to false for consistence with the GNOME default
    and other UME apps; LP: #223840.

  [ Loic Minier ]
  * Tweak above changelog entry to clarify actual change.
  * Tune Ubuntu revision.
  * Update upload date.

 -- Michael Terry <email address hidden> Tue, 17 Jun 2008 23:07:14 +0200

Changed in claws-mail:
status: Confirmed → Fix Released
Loïc Minier (lool) wrote :

Michael, would you be tempted to backport the change to claws-mail 3.3.1-1ubuntu6 in the ubuntu-mobile ppa?

AmenophisIII (amenophisiii) wrote :

sorry for this late reply... but since i was puzzled why i could not change shortcuts in claws-mail but can in sylpheed, and this bug report made clear to me, that the gtk feature can be disabled per application, id like to add my 2cts:

its ok to disable it globaly (although i dont think thats a wise choice...) and its ok to enable its globaly.
but it does absolutely not make any sense for the user, if a gtk app does not behave like all others.
that would make it a bug in claws-mail: the default should be no application specific setting for this, but inherent the gtk wide setting.

Michael Terry (mterry) on 2009-10-20
tags: added: oem
Michael Terry (mterry) on 2009-10-28
tags: added: oem-services
removed: oem
Barry Warsaw (barry) wrote :

I want to drop this patch in 12.10 so that we can re-sync with Debian. It's the only delta we carry, and I'm not convinced it's worth the divergence any more. I'd like to simply sync to Debian's 3.8.1-1. Any objections?

Michael Terry (mterry) wrote :

I still think it's a good patch, but whether the patch is worth it or not.. I don't have strong feelings about it.

Barry Warsaw (barry) wrote :

This is a test, please ignore.

Liam Young (gnuoy) on 2012-07-20
no longer affects: acton
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches