v19.10 update to kernel version 5.3.0-26-generic fails

Bug #1859097 reported by George Ganoe on 2020-01-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu MATE
Undecided
Unassigned

Bug Description

When I ran the Software updater on Jan 8, 2020, a security update from kernel version 5.3.0-24-generic to 5.3.0-26-generic was installed. When I rebooted the system, I was dumped to the boot-loaders busy-box prompt. I tried also under the Advanced options for Linux where normal and recovery mode versions of both v5.3.0-26-generic and v5.3.0-24-generic were available. Both of the 5.3.0-26-generic options also sent me to the busy-box prompt. However, when I tried the 5.3.0-24-generic option I was able to get the system started, and it seems to work normally.

Some additional observations:

While watching the messages when trying to get the 5.3.0-26 version going I noticed that it was not able to find the file system for my Ubuntu-Mate installation.

I also noticed that the size of the initrd.img-5.3.0-26-generic is about 4 MBytes smaller than the initrd.img-5.3.0-24-generic.

Since the Ubuntu-Mate file system is in a LVM partition, I am wondering if the initrd.img-5.3.0-26-generic lacks the capability to see the LVM partition.

I have tried to figure out how to unpack the two initrd.img files to see what the differences are, but none of the information I have seen on the web about how to do this works on the Ubuntu versions of the file.

My computer is a Dell XPS-13-9370.

George Ganoe (geoganoe) wrote :

After continuing the search, I have found the unmkinitramfs command and unpacked the two initrd.img files mentioned above. I can verify that the initrd.img-5.3.0-24-generic does contain the lvm capability, and that the initrd.img-5.3.0-26-generic does not have it. If this is an intended change in the ubuntu-mate support, I will need to find a substitute OS to use as I find the lvm capability invaluable to my Linux experience.

I tried running the "update-initramfs -u" to generate an updated initrd.img file, but it still didn't enable access to the lvm capability even though the messages displayed indicated that lvm would be required:

root@george-xps:~# update-initramfs -u
update-initramfs: Generating /boot/initrd.img-5.3.0-26-generic
I: The initramfs will attempt to resume from /dev/dm-1
I: (/dev/mapper/vg0-swapspace)
I: Set the RESUME variable to override this.
root@george-xps:~#

and the initramfs /proc/cmdline is:

BOOT_IMAGE=/boot/vmlinuz-5.3.0-26-generic root=/dev/mapper/vg0-matesys ro recovery nomodeset

At the end of the boot attempt, the following line is printed before the shell prompt:

ALERT! /dev/mapper/vg0-matesys does not exist. Dropping to a shell!

That alert, even though when booting using the initrd.img-5.3.0-24-generic option, the /dev/mapper/vg0-matesys partition is found without problem and boots normally.

I can post a picture of the final screen of messages if it would help solve the problem.

George Ganoe (geoganoe) on 2020-01-10
tags: added: eoan
George Ganoe (geoganoe) on 2020-01-10
tags: added: boot
George Ganoe (geoganoe) on 2020-01-17
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers