Dropbox install requires using Nautilus-Dropox, not Caja-Dropbox

Bug #1852500 reported by Sam Mowrer on 2019-11-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu MATE
Undecided
Unassigned

Bug Description

I installed Caja-Dropbox from the Software Boutique. After launching, the icon sits in my Plank dock for 10 seconds and then goes away with nothing happening. No prompts or error messages. I ran apt --fix-missing install && apt --fix-broken install. I tried launching caja-dropbox from the terminal. It fed me a bunch of commands I could use for Dropbox, which I tried, then it said Dropbox is not installed and prompted me to install Nautilus-Dropbox. I installed Nautilus-Dropbox and it worked. Dropbox is working in Caja and all behavior is as intended however it seems a bit strange since I know caja-dropbox was developed specifically for working with Caja. I've included a screenshot of my terminal for reference. Thanks for your time!

Sam Mowrer (mowie128) wrote :
FranksMCB (franksmcb) wrote :

This is a bug with Dropbox not Ubuntu MATE.

This is the work-around from the release notes.

Caja dropbox does not start.
The libdropbox_apex.so shared object, as distributed by Dropbox, has the wrong file permissions.
The workaround is to open a terminal and run the following command:

sudo chmod a+rx /var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-*/libdropbox_apex.so

Changed in ubuntu-mate:
status: New → Invalid
Sam Mowrer (mowie128) wrote :

Great, thank you for the help!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers