With kernel 5.0.0-11-generic and nouveau, Ubuntu MATE has wrong colors and can't control brightness

Bug #1824815 reported by Alexander Browne on 2019-04-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu MATE
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

With the latest kernel (5.0.0-11-generic) my MacBook with nouveau shows wrong colors and can't control brightness while running Ubuntu MATE. For example, Ubuntu MATE green appears as teal and orange like in the Firefox logo and window decorations is blue. This includes the plymouth boot logo, but not the desktop wallpaper.

Screen brightness can't be controlled at all, neither with the keyboard keys (which have always worked automatically) nor in the Control Center > Power Management because no brightness slider appears at all.

This also occurs in a live session from the latest daily build (20190413.3).

It does NOT occur in a live session of the latest (20190413.2) Ubuntu Desktop (GNOME).

By editing /etc/default/grub to boot the previous kernel (5.0.0-8-generic), it works normally again.
---
ProblemType: Bug
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu-mate 1784 F.... pulseaudio
CasperVersion: 1.403
CurrentDesktop: MATE
DistroRelease: Ubuntu 19.04
IwConfig:
 lo no wireless extensions.

 enp0s10 no wireless extensions.
LiveMediaBuild: Ubuntu-MATE 19.04 "Disco Dingo" - Alpha amd64 (20190413.3)
MachineType: Apple Inc. MacBook5,1
Package: linux (not installed)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
 SHELL=/bin/bash
ProcFB: 0 EFI VGA
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/username.seed boot=casper quiet splash ---
ProcVersionSignature: Ubuntu 5.0.0-11.12-generic 5.0.6
RelatedPackageVersions:
 linux-restricted-modules-5.0.0-11-generic N/A
 linux-backports-modules-5.0.0-11-generic N/A
 linux-firmware 1.178
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
Tags: disco
Uname: Linux 5.0.0-11-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 04/27/09
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MB51.88Z.007D.B03.0904271443
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-F42D89C8
dmi.board.vendor: Apple Inc.
dmi.board.version: Proto
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F42D89C8
dmi.modalias: dmi:bvnAppleInc.:bvrMB51.88Z.007D.B03.0904271443:bd04/27/09:svnAppleInc.:pnMacBook5,1:pvr1.0:rvnAppleInc.:rnMac-F42D89C8:rvrProto:cvnAppleInc.:ct10:cvrMac-F42D89C8:
dmi.product.family: MacBook
dmi.product.name: MacBook5,1
dmi.product.sku: System SKU#
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
---
ProblemType: Bug
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu-mate 1784 F.... pulseaudio
 /dev/snd/pcmC0D0p: ubuntu-mate 1784 F...m pulseaudio
CasperVersion: 1.403
CurrentDesktop: MATE
DistroRelease: Ubuntu 19.04
IwConfig:
 lo no wireless extensions.

 enp0s10 no wireless extensions.
LiveMediaBuild: Ubuntu-MATE 19.04 "Disco Dingo" - Alpha amd64 (20190413.3)
MachineType: Apple Inc. MacBook5,1
Package: linux (not installed)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
 SHELL=/bin/bash
ProcFB: 0 EFI VGA
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/username.seed boot=casper quiet splash ---
ProcVersionSignature: Ubuntu 5.0.0-11.12-generic 5.0.6
RelatedPackageVersions:
 linux-restricted-modules-5.0.0-11-generic N/A
 linux-backports-modules-5.0.0-11-generic N/A
 linux-firmware 1.178
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
Tags: disco
Uname: Linux 5.0.0-11-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 04/27/09
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MB51.88Z.007D.B03.0904271443
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-F42D89C8
dmi.board.vendor: Apple Inc.
dmi.board.version: Proto
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F42D89C8
dmi.modalias: dmi:bvnAppleInc.:bvrMB51.88Z.007D.B03.0904271443:bd04/27/09:svnAppleInc.:pnMacBook5,1:pvr1.0:rvnAppleInc.:rnMac-F42D89C8:rvrProto:cvnAppleInc.:ct10:cvrMac-F42D89C8:
dmi.product.family: MacBook
dmi.product.name: MacBook5,1
dmi.product.sku: System SKU#
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
---
ProblemType: Bug
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu-mate 1784 F.... pulseaudio
CasperVersion: 1.403
CurrentDesktop: MATE
DistroRelease: Ubuntu 19.04
IwConfig:
 lo no wireless extensions.

 enp0s10 no wireless extensions.
LiveMediaBuild: Ubuntu-MATE 19.04 "Disco Dingo" - Alpha amd64 (20190413.3)
MachineType: Apple Inc. MacBook5,1
Package: linux (not installed)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
 SHELL=/bin/bash
ProcFB: 0 EFI VGA
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/username.seed boot=casper quiet splash ---
ProcVersionSignature: Ubuntu 5.0.0-11.12-generic 5.0.6
RelatedPackageVersions:
 linux-restricted-modules-5.0.0-11-generic N/A
 linux-backports-modules-5.0.0-11-generic N/A
 linux-firmware 1.178
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
Tags: disco
Uname: Linux 5.0.0-11-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 04/27/09
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MB51.88Z.007D.B03.0904271443
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-F42D89C8
dmi.board.vendor: Apple Inc.
dmi.board.version: Proto
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F42D89C8
dmi.modalias: dmi:bvnAppleInc.:bvrMB51.88Z.007D.B03.0904271443:bd04/27/09:svnAppleInc.:pnMacBook5,1:pvr1.0:rvnAppleInc.:rnMac-F42D89C8:rvrProto:cvnAppleInc.:ct10:cvrMac-F42D89C8:
dmi.product.family: MacBook
dmi.product.name: MacBook5,1
dmi.product.sku: System SKU#
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
---
ProblemType: Bug
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu-mate 1784 F.... pulseaudio
CasperVersion: 1.403
CurrentDesktop: MATE
DistroRelease: Ubuntu 19.04
IwConfig:
 lo no wireless extensions.

 enp0s10 no wireless extensions.
LiveMediaBuild: Ubuntu-MATE 19.04 "Disco Dingo" - Alpha amd64 (20190413.3)
MachineType: Apple Inc. MacBook5,1
Package: linux (not installed)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
 SHELL=/bin/bash
ProcFB: 0 EFI VGA
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/username.seed boot=casper quiet splash ---
ProcVersionSignature: Ubuntu 5.0.0-11.12-generic 5.0.6
RelatedPackageVersions:
 linux-restricted-modules-5.0.0-11-generic N/A
 linux-backports-modules-5.0.0-11-generic N/A
 linux-firmware 1.178
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
Tags: disco
Uname: Linux 5.0.0-11-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 04/27/09
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MB51.88Z.007D.B03.0904271443
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-F42D89C8
dmi.board.vendor: Apple Inc.
dmi.board.version: Proto
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F42D89C8
dmi.modalias: dmi:bvnAppleInc.:bvrMB51.88Z.007D.B03.0904271443:bd04/27/09:svnAppleInc.:pnMacBook5,1:pvr1.0:rvnAppleInc.:rnMac-F42D89C8:rvrProto:cvnAppleInc.:ct10:cvrMac-F42D89C8:
dmi.product.family: MacBook
dmi.product.name: MacBook5,1
dmi.product.sku: System SKU#
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1824815

tags: added: iso-testing

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1824815

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: disco

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Alexander Browne (elcste) wrote :

Sorry for the duplicate apport info! It didn't seem like it was working on this machine, but it looks like it was uploading after all!

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → New

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Alexander Browne (elcste) wrote :

With new kernel 5.0.0-13-generic, colors and brightness are working normally.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-mate:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers