mate 18.04.1 xserver won't open caja on local machine

Bug #1815318 reported by Michael Dooley
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MATE Desktop
Ubuntu MATE
caja (Ubuntu)
openssh (Ubuntu)

Bug Description

Steps to reproduce:
1. Have installed Ubuntu MATE 18.04 LTS (you know its hostname and IP - i.e.
2. Install SSH server on Ubuntu MATE 18.04 LTS
3. Open terminal on other remote system (client) and execute command to run Caja over X forwarding:

   ssh -X user@ caja

Expected results:
* Caja is shown on remote (client) screen with window title *folder (on hostname)*

Actual results:
* Caja is not shown on remote (client) screen, but launches on server locally.

Note: this works normally if server runs Ubuntu MATE 16.04 LTS, but fails with 18.04 LTS.

Original description below:

I can open a remote terminal using ssh -X All other gui's that I've tested opened locally except the file manager Caja. When issuing caja in the remote terminal, I get nothing locally. Caja does open on the remote machine however, just not locally. The ssh -X 18.04.1 client still works connecting to a mate 16.04 server. I've tested this on numerous mate 18.04 clients, two 16.04 servers and two 18.04 servers, all mate. Something is wonky with caja on an 18.04.1 server.

Please let me know if I can provide any more information. The only file manager I've tested that works is an X file manager, xfimage. X2go works and connects to servers, SSH Connect to Server works, why isn't the remote X terminal working using caja?

Norbert (nrbrtx)
tags: added: bionic
Norbert (nrbrtx)
description: updated
Revision history for this message
Norbert (nrbrtx) wrote :

I can confirm the issue using Ubuntu MATE 18.04 LTS as server and Ubuntu MATE 16.04 LTS as client.

Applications work (open on client as expected): atril, brasero, charmap, cheese, gnome-disks, engrampa, eom, firefox, gdebi-gtk, libreoffice, mate-system-log, mate-calculator, mate-color-select, mate-dictionary, mate-font-viewer, mate-search-tool, mate-system-monitor, mate-terminal, pluma, mate-power-statistics, rhythmbox, shotwell, simple-scan, mate-screenshot, thunderbird, transmission-gtk, vlc, nautilus .

Applications which do not work (open on server instead of on client): caja, deja-dup, blueman-manager .

Revision history for this message
Norbert (nrbrtx) wrote :

Also happens with Ubuntu MATE 18.04 LTS as server and Ubuntu 18.04 LTS as client.

So it is 18.04 LTS issue about SSH <-> Caja connection.

Norbert (nrbrtx)
no longer affects: blueman (Ubuntu)
no longer affects: deja-dup (Ubuntu)
Revision history for this message
Andreas Hasenack (ahasenack) wrote :

I believe this is just a different behavior in caja itself. You see, in both cases there is already a caja process running. In bionic's version, if you run caja again, it doesn't bring up a new copy, but instead uses the existing one to spawn the new windows:

ubuntu@bionic-mate:~$ ps fxaw|grep caja|grep -v grep
10308 ? Sl 0:01 \_ caja
ubuntu@bionic-mate:~$ caja
ubuntu@bionic-mate:~$ ps fxaw|grep caja|grep -v grep
10308 ? Sl 0:01 \_ caja
ubuntu@bionic-mate:~$ caja
ubuntu@bionic-mate:~$ ps fxaw|grep caja|grep -v grep
10308 ? Sl 0:01 \_ caja

But I have many new windows opened already.

In xenial, I do get new processes:
ubuntu@xenial-mate:~$ caja &
[1] 2764
ubuntu@xenial-mate:~$ Initializing caja-open-terminal extension
/usr/lib/python2.7/dist-packages/gi/overrides/ RuntimeWarning: You have imported the Gtk 2.0 module. Because Gtk 2.0 was not designed for use with introspection some of the interfaces and API will fail. As such this is not supported by the pygobject development team and we encourage you to port your app to Gtk 3 or greater. PyGTK is the recomended python module to use with Gtk 2.0
  warnings.warn(warn_msg, RuntimeWarning)
sys:1: PyGIWarning: Caja was imported without specifying a version first. Use gi.require_version('Caja', '2.0') before import to ensure that the right version gets loaded.
Initializing caja-main-menu extension
** Message: Initializing gksu extension...
ps fxaw|grep caja|grep -v grep
 2764 pts/8 Sl 0:00 \_ caja
 2338 ? Sl 0:00 \_ caja

This is definitely not a problem with openssh, and one could argue caja is behaving like intended, but I'll leave that for others to decide. Marking the openssh task as invalid.

Changed in openssh (Ubuntu):
status: New → Invalid
Revision history for this message
Martin Wimpress  (flexiondotorg) wrote :

Does using either of these help?

  * caja --browser
  * caja --no-desktop

Changed in caja (Ubuntu):
status: New → Incomplete
Changed in ubuntu-mate:
status: New → Incomplete
status: Incomplete → Invalid
Revision history for this message
Michael Dooley (mdooley) wrote :

I used ssh -X and gained admittance to the remote system as shown below:

Welcome to Ubuntu 18.04.3 LTS (GNU/Linux 4.15.0-60-generic x86_64)

 * Documentation:
 * Management:
 * Support:

 * Canonical Livepatch is available for installation.
   - Reduce system reboots and improve kernel security. Activate at:

0 packages can be updated.
0 updates are security updates.

Last login: Fri Sep 6 14:52:58 2019 from

I then tried michael@longitude:~$ caja --browser
and next tried michael@longitude:~$ caja --no-desktop

Neither displayed a local caja; neither helped.

Thanks for investigating this problem Martin.

Norbert (nrbrtx)
tags: added: eoan focal
removed: 18.04
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for caja (Ubuntu) because there has been no activity for 60 days.]

Changed in caja (Ubuntu):
status: Incomplete → Expired
Revision history for this message
Norbert (nrbrtx) wrote :

Still happens on 20.10.

tags: added: groovy
removed: eoan
Changed in caja (Ubuntu):
status: Expired → Confirmed
Changed in mate-desktop:
status: Unknown → New
Norbert (nrbrtx)
tags: added: hirsute
Norbert (nrbrtx)
tags: removed: groovy
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.