cpu100% systemd-udevd

Bug #1779549 reported by Bored Individual on 2018-07-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu MATE
Undecided
Unassigned

Bug Description

ubuntu-mate 18.04 lts (no problems when installing 17.10)

dell e6400 core2duo (other dell laptops presumably)

systemd-udevd climbs to 100% cpu usage in minutes, making it verify diffcult and horrible to install, if one can manage to find the patience, only to find out that this problem persists after the installation.

workaround:
1.
boot into the iso,open a terminal:

systemctl disable systemd-udevd.service
systemctl disable systemd-udevd-control.socket
systemctl disable systemd-udevd-kernel.socket
systemctl stop systemd-udevd.service
systemctl stop systemd-udevd-control.socket
systemctl stop systemd-udevd-kernel.socket

2.
then kill -9 any systemd-udevd process that remains active

3.
check if you cpu load has dropped to normal values.

4.
continue installation as normal.

5. after first boot run systemctl commands from step 1. and reboot.

(6. hope they patch this bug and after enable systemd-udevd.)

Its a bit like this one:
https://askubuntu.com/questions/1028883/ubuntu-18-04-systemd-udevd-uses-high-cpu-conflict-with-wifi

but i have problems with or without wifi

description: updated
tags: added: 18.04 mate
Bored Individual (karnemelk) wrote :

screenshots of installation

Bored Individual (karnemelk) wrote :

better screenshots:
just booted into 18.04lts let it go for 60 secs
and systemd-udevd claims most of the cpu.

description: updated
Bored Individual (karnemelk) wrote :

disabling bluetooth in the bios does not work
disabling wireless in the bios works to some extend, systemd-udevd takes around ~50% cpu
downgrade to a 4.13 kernel does not work

Bored Individual (karnemelk) wrote :

And i was being a complete retard, downgrade to 4.13 kernel worked like a charm.
Previous attempt was done incorrect.

So this thing can be closed.

Abu Sakib (apollonius) on 2018-07-12
Changed in ubuntu-mate:
status: New → Invalid
Y S Gupta (ysg) wrote :

Workaround
==========

Soon after booting, run the following commands-

sudo systemctl stop systemd-udevd systemd-udevd-kernel.socket systemd-udevd-control.socket

sudo systemctl start systemd-udevd systemd-udevd-kernel.socket systemd-udevd-control.socket

It solved all the problems in my Dell laptop.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers