nm-applet symbol not displayed on mate (18.04)

Bug #1754458 reported by Michael on 2018-03-08
100
This bug affects 21 people
Affects Status Importance Assigned to Milestone
ubuntu-mate
Undecided
Unassigned
indicator-application (Ubuntu)
Undecided
Unassigned
mate-indicator-applet (Ubuntu)
Undecided
Unassigned
network-manager-applet (Ubuntu)
Undecided
Unassigned
ubuntu-mate-settings (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading to Ubuntu 18.04, the network manager applet symbol isn't displayed any longer. The other functionality (asking for credentials) is working. I also see other symbols.

aptitude show network-manager-gnome
Paket: network-manager-gnome
Version: 1.8.10-2ubuntu1
Neu: ja
Zustand: Installiert

stdout/stderr:
Gtk-Message: 21:28:14.411: Failed to load module "appmenu-gtk-module"
Gtk-Message: 21:28:14.431: Failed to load module "topmenu-gtk-module"
Gtk-Message: 21:28:14.431: Failed to load module "appmenu-gtk-module"
Gtk-Message: 21:28:14.432: Failed to load module "topmenu-gtk-module"

** (nm-applet:29524): WARNING **: 21:28:14.668: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(nm-applet:29524): nm-applet-WARNING **: 21:28:15.987: Cannot grab information for modem at /org/freedesktop/ModemManager1/Modem/6: No ModemManager support

(nm-applet:29524): nm-applet-WARNING **: 21:28:16.124: ModemManager is not available for modem at /org/freedesktop/ModemManager1/Modem/6

(nm-applet:29524): Gtk-WARNING **: 21:28:16.127: Can't set a parent on widget which has a parent

(nm-applet:29524): Gtk-CRITICAL **: 21:28:16.141: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:29524): Gtk-CRITICAL **: 21:28:16.141: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:29524): Gtk-WARNING **: 21:28:16.171: Can't set a parent on widget which has a parent

(nm-applet:29524): Gtk-CRITICAL **: 21:28:21.500: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:29524): Gtk-CRITICAL **: 21:28:21.500: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:29524): Gtk-WARNING **: 21:28:21.570: Can't set a parent on widget which has a parent

(nm-applet:29524): Gtk-CRITICAL **: 21:28:24.517: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:29524): Gtk-CRITICAL **: 21:28:24.517: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

(nm-applet:29524): Gtk-WARNING **: 21:28:24.655: Can't set a parent on widget which has a parent

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: network-manager-gnome 1.8.10-2ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-10.11-generic 4.15.3
Uname: Linux 4.15.0-10-generic x86_64
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
CurrentDesktop: MATE
Date: Thu Mar 8 21:27:56 2018
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
SourcePackage: network-manager-applet
UpgradeStatus: No upgrade log present (probably fresh install)
WpaSupplicantLog:

nmcli-nm:
 RUNNING VERSION STATE STARTUP CONNECTIVITY NETWORKING WIFI-HW WIFI WWAN-HW WWAN
 running 1.10.4 connected started full enabled enabled enabled enabled enabled

Michael (3-ueuntu-4) wrote :
Martin Matuska (mm-vx) wrote :

I experience the same problem.

- if you run nm-applet as root via sudo, the icon appears
- the error message:
    Failed to load module "appmenu-gtk-module"
  can be suppressed by installing appmenu-gtk3-module (this does not fix the issue)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mate-desktop (Ubuntu):
status: New → Confirmed
Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
Martin Matuska (mm-vx) on 2018-03-19
summary: - applet symbol not displayed on mate (18.04)
+ nm-applet symbol not displayed on mate (18.04)
Leo (leo4ward) wrote :

Hi,
This problem also affect other applications like shutter (it also appears if launched by root).
Thanks

Vlad Orlov (monsta) on 2018-04-05
affects: mate-desktop (Ubuntu) → ubuntu-mate

FYI: please don't run graphical programs with plain `sudo`, see https://askubuntu.com/a/270019/549800

Pär Lindfors (paran) wrote :

For me this was due to my panel no longer having an indicator applet. Adding it back did not work. I managed to "fix" it by resetting the panel config (right click on the panel, select 'Reset Panel').

That got me an indicator appled, with the nm-appled being displayed correctly.

(I do get an error message once on each login about the applet crashing, but clicking reload works. That should probably should be a separate bug.)

Wally (ubuntuwally) wrote :

Same problem here. I had nm-applet icon showing up just fine on 17.04. After upgrading to 17.10 it disappeared, but I was able to get it back by using MATE Tweak to revert to a saved panel layout. Now, after upgrading to 18.04, it disappeared again. I am still able to recover it by reverting to a saved panel layout, but now I have to do it every single time I restart my computer.

If I add the Indicator Applet, I can get *a* network icon to show up, but it isn't the same as nm-applet, as it lacks a lock icon when using a VPN (and likely other differences).

If I run sudo nm-applet, I get similar error messages to the ones already posted, though the icon does display while I have the terminal open and the command running.

Here's my error message when running sudo nm-applet (running it without sudo generates no error, but also doesn't bring back the icon):

(nm-applet:2874): Gtk-WARNING **: 09:19:30.075: Can't set a parent on widget which has a parent

(nm-applet:2874): Gdk-CRITICAL **: 09:19:30.274: gdk_window_thaw_toplevel_updates: assertion 'window->update_and_descendants_freeze_count > 0' failed

I'm getting the same problem with Telegram and Steam, both packages were installed in the same way on both systems.
Indicator was visibile prior to upgrade, is not after upgrade, works in a clean install of bionic.

Even the basic example in http://candidtim.github.io/appindicator/2014/09/13/ubuntu-appindicator-step-by-step.html does not work on the upgraded system.

André Pirard (a.pirard) wrote :

After installing a 18.04 that couldn't be fresher,
I added the applet Indicator Applet Complete
and now I've got in a bunch:
that Network Manager applet that was missing (that of 16.04.4 was badly working after suspend)
a Battery applet that was missing too
a duplicate Sound applet
a Mixed applet (Monitor, Help, Settings, Lock/Switch, users, Log out…, Suspend…, Shutdown)

I once suggested that there should be a Fix/Workaround Panel beside Bug Description.
Just to spare having to read down to here.
They replied "No": the systems must be up-to-date.
Mine couldn't be more.

termajik (termajik) wrote :

Pär Lindfors (paran) wrote on 2018-04-17:
 I managed to "fix" it by resetting the panel config (right click on the panel, select 'Reset Panel').

It is working for me too.
nm-applet, blueman-applet and some others is working fine now.
Thanks.

Yes I found this bug too. The bug arose after I did a clean full install of Mate 18.04LTS, but I re-used my old Mate 16.04 home partition. So it's probably confused by my old style configuration files which were imported from Mate16.04 to Mate 18.04.

The workaround of using Mate Tweak to switch the panel style to something else and then back to Traditional fixed the problem for me.

JamesRogers (james-rogers-n) wrote :

The offered solution of changing the panel style did not persist after restart. The following has solved the problem for me, with the solution persisting across sessions/restarts.

I discovered I had two version of the file: "indicator-application.desktop", apparently one from an earlier install. I removed the old version:

sudo rm /usr/share/indicator-application/upstart/xdg/autostart/indicator-application.desktop

I'm not sure if this actually contributed to the solution, the main fix was to start up the indicator applet with dbus-launch. I edited the other file:

sudo pluma /usr/share/mate/autostart/indicator-application.desktop

I changed the following line:

Exec=/usr/lib/x86_64-linux-gnu/indicator-application/indicator-application-service

To instead say this:

Exec=dbus-launch /usr/lib/x86_64-linux-gnu/indicator-application/indicator-application-service

That fixed the missing nm-applet icon in the tray. I had a program that automatically starts that puts an icon in the tray. Its icon was still not appearing in the tray, so I set it so that it is delayed at startup for 10 seconds until the tray and indicator applet is loaded. This seemed to fix the problem. To do this, from the Control Center, select "Startup Applications" (or directly edit the file in ~/.config/autostart). Edit the command that Ubuntu Mate uses to execute the program using the following code (and you can change 10 to whatever delay in seconds you'd like):

sh -c "sleep 10 && NAME_OF_PROGRAM"

Created a new account and works fine.
So after a little bit of digging, the only relevant difference was dconf.

dconf reset -f /org/mate/panel/
And it still works after a reboot.

Stefan Tauner (stefanct) wrote :

I ran into this after an update from 16.04. I had a custom panel as well but I found a way to show the notification panel again without resetting the dconf configuration. I had three indicator-application.desktop files (and I IIRC likewise as many probably competing running instances of it):

/usr/share/mate/autostart/indicator-application.desktop
/etc/xdg/autostart/indicator-application.desktop
/usr/share/indicator-application/upstart/xdg/autostart/indicator-application.desktop

Only the last one seems to be the current one. I have removed (renamed) the first two. I have not tested if that alone works already but edited the remaining (third) file. I have added MATE to the list of shown-in DEs:

OnlyShowIn=Unity;MATE;

After a reboot the new notification popped up where it is supposed to including all expected apps.

Changed in network-manager-applet (Ubuntu):
status: Confirmed → Invalid

idk

Changed in ubuntu-mate:
assignee: nobody → bryce aaron smith (brycesmith1.)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-application (Ubuntu):
status: New → Confirmed
Changed in mate-indicator-applet (Ubuntu):
status: New → Confirmed
Changed in ubuntu-mate-settings (Ubuntu):
status: New → Confirmed
Joseph Brown (1st2be) wrote :

https://launchpad.net/~james-rogers-n fix, to insert dbus-launch worked for me.

[quote]
/usr/share/mate/autostart/indicator-application.desktop

I changed the following line:

Exec=/usr/lib/x86_64-linux-gnu/indicator-application/indicator-application-service

To instead say this:

Exec=dbus-launch /usr/lib/x86_64-linux-gnu/indicator-application/indicator-application-service
[/quote]

Changed in ubuntu-mate:
assignee: bryce aaron smith (brycesmith1.) → nobody
To post a comment you must log in.