mate panel freezes when clicking on fcitx icon in the notification area while having a text field selected

Bug #1731524 reported by Shuhao on 2017-11-10
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ubuntu MATE
Undecided
Unassigned
fcitx (Ubuntu)
Undecided
Unassigned
mate-panel (Ubuntu)
Undecided
Unassigned

Bug Description

FCITX is enabled by default on Ubuntu Mate. If you click on a textbox, the notification area will show a keyboard icon with the label "us" beside it.

When you click on that icon at this moment, a blank menu will pop up and the entire desktop environment freezes until you switch to tty1 and do killall mate-panel.

If the us label is not beside the keyboard icon for fcitx (anytime when you don't have a text field focused), clicking on the icon shows the regular fcitx menu as normal.

Shuhao (shuhao) on 2017-11-10
affects: systemd (Ubuntu) → mate-desktop (Ubuntu)
Vlad Orlov (monsta) on 2018-04-05
affects: mate-desktop (Ubuntu) → ubuntu-mate
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mate-panel (Ubuntu):
status: New → Confirmed
A (awaren) wrote :

This CRITICAL bug has advanced to MATE 18.04 LTS release.

Changed in mate-panel (Ubuntu):
status: Confirmed → Fix Released
A (awaren) wrote :

I am new to the site, I changed the status to 'Fix Released' by mistake. My bad.

kolokolovorot (vutil) wrote :

I is not a MATE bug. I have the same on LXDE too

A (awaren) wrote :

Ok, fcitx not longer a problem since it gets removed during full installation process. Fcitx only exists in Live USB version.

Shuhao (shuhao) on 2018-05-13
Changed in mate-panel (Ubuntu):
status: Fix Released → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fcitx (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers