keyboard layout indicator sometimes doesn't appear on session start

Bug #1720363 reported by suslikk on 2017-09-29
60
This bug affects 9 people
Affects Status Importance Assigned to Milestone
ubuntu-mate
Undecided
Unassigned
mate-panel (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:
1. Install Ubuntu 17.10 MATE final (ubuntu-mate-17.10-desktop-i386.iso, SHA256SUM Checksum 209553ca1a73f67bb309f84fadd5bc4e445ebc1cdf7a75b8448e6106fb85a8cf) and set Russian keyboard layout during installation in Ubiquity.
2. Boot installed system and log-in to it.

Expected results:
* "ru"/"en" text is shown in `mate-panel`

Actual results:
* "ru"/"en" text is not shown in `mate-panel`

APolihron (apolitech) wrote :

Please update your system or reinstall using the latest iso! I have En and Ro and i have the indicator. And i tested in all the panel layouts!

Changed in ubuntu-mate:
status: New → Invalid
Changed in ubuntu-mate:
status: Invalid → Won't Fix
status: Won't Fix → Incomplete
suslikk (suslikkreal) wrote :

update system today, without result... I have 3 users on PC and all dont have keyboard layout indicator.

suslikk (suslikkreal) wrote :

Today try remove in keyboard settings En layout and add it again. After that keyboard layouts appeared. But after relogin or reboot it disappeared.

Changed in ubuntu-mate:
status: Incomplete → Confirmed
Vlad Orlov (monsta) on 2017-10-16
tags: added: artful
summary: - Layout keyboar indicator
+ keyboard layout indicator sometimes doesn't appear on session start
Vlad Orlov (monsta) wrote :

Here's an update to an existing patch, in the debdiff format. Should fix the problem.

Alternatively, a new patch can be added from:
https://github.com/mate-desktop/mate-settings-daemon/commit/603e331e6cf480d2f9aed1e7d096333df39215aa.patch

Norbert (nrbrtx) wrote :

Got this bug on fresh Ubuntu 17.10 MATE installation:

mate1710@mate1710:~$ cat /etc/os-release
NAME="Ubuntu"
VERSION="17.10 (Artful Aardvark)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 17.10"
VERSION_ID="17.10"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=artful
UBUNTU_CODENAME=artful
mate1710@mate1710:~$ cat /etc/default/keyboard
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="us,ru"
XKBVARIANT=","
XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll"

BACKSPACE="guess"

description: updated
tags: added: apport-collected

ApportVersion: 2.20.7-0ubuntu3
Architecture: i386
CurrentDesktop: MATE
DistroRelease: Ubuntu 17.10
InstallationDate: Installed on 2017-10-21 (0 days ago)
InstallationMedia: Ubuntu-MATE 17.10 "Artful Aardvark" - Release i386 (20171018)
Package: mate-panel 1.18.4-2
PackageArchitecture: i386
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Tags: artful
Uname: Linux 4.13.0-16-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True

apport information

apport information

apport information

apport information

description: updated

The attachment "Debdiff with the fix for Artful" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mate-panel (Ubuntu):
status: New → Confirmed
Robert Tari (robert-tari) wrote :

Confirmed. No keyboard layout indicator on 17.10.

Robert Tari (robert-tari) wrote :

Update:

The bug is in the mate-settings-daemon. Although it is running, it very often fails to display the indicator. The only workaround for me right now is to kill it, which causes it to reload itself. Repeat until the keyboard indicator is displayed.

killall mate-settings-daemon

Ivan (brokoli) wrote :

Same for me. UM 17.10 x64_86

Vlad Orlov (monsta) wrote :

It's finally fixed in 17.10 with mate-settings-daemon 1.18.1-2ubuntu1.

Changed in ubuntu-mate:
status: Confirmed → Fix Released
Changed in mate-panel (Ubuntu):
status: Confirmed → Invalid
Matej Kohár (ohtarelenion) wrote :

I have updated, but still get no layout indicator on booting up. Not sure why.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers