mate-indicator-applet-complete crashed with SIGABRT in g_assertion_message()

Bug #1706803 reported by APolihron on 2017-07-26
164
This bug affects 35 people
Affects Status Importance Assigned to Milestone
Ubuntu MATE
Undecided
Unassigned
mate-indicator-applet (Ubuntu)
Medium
Unassigned

Bug Description

System: Host: a-desktop Kernel: 4.11.0-10-generic x86_64 (64 bit)
           Desktop: MATE 1.18.0
PC Setup: http://paste.ubuntu.com/25179894/

Problem: Error
Applet: Indicator applet complete 1.18.0
OS setup: Mate tweak->Panel->Redmond+Panel Features enable
                     ->Windows->Windows manager (tested all)
Workarownd: -
Reproduce: Random

ProblemType: Crash
DistroRelease: Ubuntu 17.10
Package: mate-indicator-applet 1.18.0-0ubuntu1
ProcVersionSignature: Ubuntu 4.11.0-10.15-generic 4.11.8
Uname: Linux 4.11.0-10-generic x86_64
ApportVersion: 2.20.6-0ubuntu4
Architecture: amd64
CurrentDesktop: MATE
Date: Thu Jul 27 01:53:29 2017
ExecutablePath: /usr/lib/mate-indicator-applet/mate-indicator-applet-complete
InstallationDate: Installed on 2017-07-26 (0 days ago)
InstallationMedia: Ubuntu-MATE 17.10 "Artful Aardvark" - Alpha amd64 (20170725.1)
ProcCmdline: /usr/lib/mate-indicator-applet/mate-indicator-applet-complete
Signal: 6
SourcePackage: mate-indicator-applet
StacktraceTop:
 g_assertion_message () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? ()
 ?? ()
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: mate-indicator-applet-complete crashed with SIGABRT in g_assertion_message()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

APolihron (apolitech) wrote :
information type: Private → Public
affects: mate-indicator-applet (Ubuntu) → ubuntu-mate
Changed in ubuntu-mate:
status: New → Invalid

StacktraceTop:
 g_assertion_message (domain=domain@entry=0x5651821cb21c "Indicator-Applet-Complete", file=file@entry=0x5651821cb622 "applet-main.c", line=line@entry=173, func=func@entry=0x5651821cbaf0 <__func__.53871> "place_in_menu", message=message@entry=0x565182bc3dd0 "assertion failed: (io != NULL)") at ../../../../glib/gtestutils.c:2433
 g_assertion_message_expr (domain=0x5651821cb21c "Indicator-Applet-Complete", file=0x5651821cb622 "applet-main.c", line=173, func=0x5651821cbaf0 <__func__.53871> "place_in_menu", expr=<optimized out>) at ../../../../glib/gtestutils.c:2456
 place_in_menu (widget=0x565182d69730, user_data=0x7ffe8a2360c0) at applet-main.c:173
 entry_added (io=0x565182a9f600, entry=0x565182da23b0, menubar=0x565182d56830) at applet-main.c:355
 g_closure_invoke (closure=0x565182c88db0, return_value=return_value@entry=0x0, n_param_values=2, param_values=param_values@entry=0x7ffe8a2362d0, invocation_hint=invocation_hint@entry=0x7ffe8a236250) at ../../../../gobject/gclosure.c:804

Changed in mate-indicator-applet (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Ubucolors (ubucolors) wrote :

Had problem that battery icon disappears while clicking right on it to add remaining battery time.
After a while the icon returns with this crash message.
For now, it is working ok.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mate-indicator-applet (Ubuntu):
status: New → Confirmed
APolihron (apolitech) wrote :

This problem persists in 18.04 daily

tags: added: bionic
Xmetal (xmetalfanx) wrote :

this is happening in 18.04 daily for me too

Purderaf (purderaf) on 2018-03-25
Changed in ubuntu-mate:
status: Invalid → Opinion
status: Opinion → Invalid
status: Invalid → Incomplete
oldrocker99 (fhwri99) wrote :

My indicator applet vanished and couldn't be reloaded, which disabled sound completely. I use my laptop to perform a college radio show, and this made it impossible today. Fortunately, the station has a computer, so I used YouTube to play the Kinks live.

Still...

tags: added: cosmic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers