Errors: flip_done timed out during boot-up; slow boot

Bug #1685442 reported by Bart Anderson on 2017-04-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-mate
Undecided
Unassigned

Bug Description

I had been running Ubuntu 16.04 LTS on many laptop computers (especially Dell D620, D630, E6400) with no problem.

I created a Live USB with Ubuntu 16.04.2 LTS and tried it on a Dell D630. It was very slow to boot up (about 90 seconds) as opposed to the 30-45 seconds it usually takes. For a few seconds there were error messages that included the phrase "flip_done timed out".

When the Ubuntu desktop appeared, the mouse cursor hung for a while, but then came back to life. I didn't do much testing from there. I did a Live session with the 16.04.2 LTS on a different D630 laptop, and the same problem occureed.

I Googled the problem, and found several hits.
-----------------
On an Arch forum, someone reported the problem on a Dell D630, like mine. It also occured on other laptops:
https://bbs.archlinux.org/viewtopic.php?id=218581

The suggestion was that the bug was related to kernel version 4.8.x and the 965GM chipset, which is what the D630 has.

So I tried Ubuntu Mate 16.04.2 on a Dell D620 (with a 945GM chipset) and the problem DID NOT occur.
-------------------
For a similar boot-up problem, Ubuntu Forum suggested going back to an earlier version of Ubuntu.
https://ubuntuforums.org/showthread.php?t=2348892

I tried Ubuntu Mate 16.04.1 (with the 4.4.0-31-generic kernel), and the problem did NOT occur.

So I'm solving the problem for myself by using Ubuntu Mate 16.04.1 LTS rather than 16.04.2.

Bart Anderson (bart-umate) wrote :
Download full text (5.0 KiB)

System info and dmesg text before error message:

$ inxi -F
System: Host: ubuntu-mate Kernel: 4.8.0-36-generic x86_64 (64 bit)
           Desktop: MATE 1.12.1 Distro: Ubuntu 16.04 xenial
Machine: System: Dell product: Latitude D630
           Mobo: Dell model: 0KU184 Bios: Dell v: A03 date: 07/23/2007
CPU: Dual core Intel Core2 Duo T7100 (-MCP-) cache: 2048 KB
           clock speeds: max: 1801 MHz 1: 1200 MHz 2: 1800 MHz
Graphics: Card: Intel Mobile GM965/GL960 Integrated Graphics Controller (primary)
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa)
           Resolution: 1440x900@60.00hz
           GLX Renderer: Mesa DRI Intel 965GM GLX Version: 2.1 Mesa 12.0.6
Audio: Card Intel 82801H (ICH8 Family) HD Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.8.0-36-generic
Network: Card-1: Broadcom NetXtreme BCM5755M Gigabit Ethernet PCI Express
           driver: tg3
           IF: enp9s0 state: up speed: 100 Mbps duplex: full
           mac: 00:1c:23:1b:d9:49
           Card-2: Intel PRO/Wireless 4965 AG or AGN [Kedron] Network Connection
           driver: iwl4965
           IF: wlp12s0 state: down mac: 00:21:5c:40:17:f1
Drives: HDD Total Size: 96.0GB (2.1% used)
           ID-1: /dev/sda model: FUJITSU_MHV2080B size: 80.0GB
           ID-2: USB /dev/sdb model: Cruzer_Glide size: 16.0GB
Partition: ID-1: swap-1 size: 2.14GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: None detected - is lm-sensors installed and configured?
Info: Processes: 183 Uptime: 6 min Memory: 917.2/1990.4MB
           Client: Shell (bash) inxi: 2.2.35

==========
dmesg
...
[ 20.990839] ------------[ cut here ]------------
[ 20.990864] WARNING: CPU: 0 PID: 114 at /build/linux-hwe-eyfT8D/linux-hwe-4.8
.0/drivers/gpu/drm/drm_irq.c:1224 drm_wait_one_vblank+0x1b6/0x1c0 [drm]
[ 20.990866] vblank wait timed out on crtc 0
[ 20.990867] Modules linked in: uas psmouse usb_storage firewire_ohci firewire
_core i915 crc_itu_t tg3 pata_acpi i2c_algo_bit ptp drm_kms_helper pps_core sysc
opyarea sysfillrect sysimgblt wmi fb_sys_fops drm video
[ 20.990892] CPU: 0 PID: 114 Comm: kworker/u4:3 Tainted: G W 4.8.
0-36-generic #36~16.04.1-Ubuntu
[ 20.990893] Hardware name: Dell Inc. Latitude D630 /0KU184,
 BIOS A03 07/23/2007
[ 20.990897] Workqueue: events_unbound async_run_entry_fn
[ 20.990900] 0000000000000286 0000000087ba6e01 ffff88cff97bb898 ffffffff83c2d7b3
[ 20.990906] ffff88cff97bb8e8 0000000000000000 ffff88cff97bb8d8 ffffffff8388313b
[ 20.990911] 000004c800000296 ffff88cff9a60000 0000000000000000 0000000000000000
[ 20.990916] Call Trace:
[ 20.990920] [<ffffffff83c2d7b3>] dump_stack+0x63/0x90
[ 20.990924] [<ffffffff8388313b>] __warn+0xcb/0xf0
[ 20.990927] [<ffffffff838831bf>] warn_slowpath_fmt+0x5f/0x80
[ 20.990931] [<ffffffff838c7025>] ? finish_wait+0x55/0x70
[ 20.990954] [<ffffffffc01a1b96>] drm_wait_one_vblank+0x1b6/0x1c0 [drm]
[ 20.990957] [<ffffffff838c74d0>] ? wake_atomic_t_function+0x60/0x60
[ 20.991017] [<ffffffffc031fcd7...

Read more...

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers