Adding Opera Browser from Software Boutique breaks apt in Ubuntu Mate 16.04.1

Bug #1663523 reported by Mimmo on 2017-02-10
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu MATE
Undecided
Unassigned
ubuntu-mate-welcome (Ubuntu)
Undecided
Unassigned

Bug Description

Adding Opera Browser from Software Boutique breaks apt.
A new file, opera-stable.list got added to
/etc/apt/sources.list.d/opera-stable.list
with broken content:

# This file makes sure that Opera Browser is kept up-to-date
# as part of regular system upgrades

deb https//:deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)

PLEASE NOTE: https//:

I can confirm this report.

Reading package lists... Done
E: The method driver /usr/lib/apt/methods/https// could not be found.
E: Failed to fetch https//://deb.opera.com/opera-stable/dists/stable/InRelease
E: Some index files failed to download. They have been ignored, or old ones used instead.

Changed in ubuntu-mate:
status: New → Confirmed

16.04 is affected. Not sure about 16.10.

Changed in ubuntu-mate-welcome (Ubuntu):
status: New → Confirmed
APolihron (apolitech) wrote :

The same problem is in 17.04 alfa!!!

This looks like importance of this bug should be at least 'high' since it breaks the update process.

Luke Horwell (lah7) wrote :

It appears Software Boutique does add this source correctly, but Opera's packaging has a typo in their "postinst" script which overwrites this file.

This needs reporting to Opera to be fixed in their packaging upstream, otherwise the other choice is to drop it from Software Boutique.

Luke Horwell (lah7) wrote :

Opera has been temporarily removed from Software Boutique.
https://bitbucket.org/ubuntu-mate/ubuntu-mate-welcome/commits/708a166baec9916386697142a8c3b3630493ea96

The packages have been updated for the upcoming 17.04, but also 16.04 and 16.10 via the PPA (by clicking on "subscribe for updates" within Welcome/Boutique).

Once Opera has fixed this issue, we'll be able to feature this application again.

Changed in ubuntu-mate:
status: Confirmed → Fix Released
Changed in ubuntu-mate-welcome (Ubuntu):
status: Confirmed → Fix Released
Luke Horwell (lah7) wrote :

It should be noted that for Opera users in the meantime, you should disable the auto-update feature within Opera and manually correct the "https://" typo in /etc/apt/sources.list.d/opera-stable.list as root.

For example, from the terminal:

$ sudo pluma /etc/apt/sources.list.d/opera-stable.list

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers