print-notifications: Don't show error for job in progress

Bug #1656790 reported by jorno on 2017-01-16
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu MATE
Undecided
Unassigned
mate-settings-daemon (Ubuntu)
Undecided
Unassigned
system-config-printer (Ubuntu)
Undecided
Unassigned

Bug Description

Running Ubuntu MATE 16.04.1 LTS

Every single time I print something, I get an error notification.

Unfortunly, I'm running a Norwegian desktop, so this will be a translation of what I suppose the notification says on an English desktop:

Printer error
Printer 'NAME':'cups-waiting-for-job-completed'

It is a bit annoying, but it disappears after a couple of seconds, when the print job is done.

After a bit of Googling, I found this is a known error from earlier, with gnome-settings-daemon. I guess the fix never have been included in mate-settings-daemon ?

This is the bug in Red Hat for the same problem:
https://bugzilla.redhat.com/show_bug.cgi?id=1207154

This is the patch for gnome-settings-daemon from May 20 2015 :
https://mail.gnome.org/archives/commits-list/2015-May/msg03447.html

The 'cups-waiting-for-job-completed' is a notification in Cups, which should not be ignored by gnome-settings-daemon.

Martin Wimpress (flexiondotorg) wrote :

Could you please also raise this issue upstream:

  * https://github.com/mate-desktop/mate-settings-daemon

Thanks!

summary: - [mate-settings-daemon] print-notifications: Don't show error for job in
- progress
+ print-notifications: Don't show error for job in progress
jorno (jorn-odberg) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mate-settings-daemon (Ubuntu):
status: New → Confirmed
kolya (mar-kolya) wrote :

I think this is actually bug in system-config-printer package that is used by ubuntu mate to control printers.

jorno (jorn-odberg) wrote :

The workaround I´m using right now is the following in a startup script:

echo 'X-MATE-Autostart-enabled=false' >> /home/bruker/.config/autostart/print-applet.desktop

The reason I needed to find a workaround is, I manage hundreds of kiosk-PCs in public libraries. When every single user who tries to print something is presented with what looks like an error message popping up on screen after a print, they try again. So almost every print job is sent twice.

This workaround works in these cases, since they don´t receive the notification. It´s a poor workaround for other use cases, since the users won't receive notification about low paper, low ink and such. But these users won´t need these types of notifications.

The "print-applet.desktop" comes from the package: system-config-printer-gnome

Till Kamppeter (till-kamppeter) wrote :

The system-config-printer developers have fixed this in the last days. I have taken the fix into the Ubuntu package now.

Changed in system-config-printer (Ubuntu):
status: New → Fix Committed
Till Kamppeter (till-kamppeter) wrote :

Fixed in system-config-printer 1.5.9+20170825-0ubuntu1.

Changed in system-config-printer (Ubuntu):
status: Fix Committed → Fix Released
Vlad Orlov (monsta) on 2017-09-04
Changed in mate-settings-daemon (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-mate:
status: New → Invalid
JerryFu (zxf2jt19) wrote :

We found the same problem on Ubuntu 16.04.5LTS recently.

In order to solve this problem, we tried to upgrade the system-config-printer package which installed on the system from [system-config-printer 1.5.7] to [system-config-printer 1.5.9+20170825-0ubuntu1] which has solved this problem, but it failed.

Could you tell me whether Ubuntu 16.04.5LTS only support system-config-printer 1.5.7, so we can't upgrade to system-config-printer 1.5.9+20170825-0ubuntu1?

Till Kamppeter (till-kamppeter) wrote :

JerryFu, there is nothing known which prevents system-config-printer 1.5.9 from running on 16.04. Please tell what you exactly did (build package, run program, restart desktop, ...) and when and where an error occured. Also post the screen output, error messages, ...

JerryFu (zxf2jt19) wrote :

Dear Till,

Thank you very much for your fast reply.

We downloaded a deb package (system-config-printer_1.5.9+20170825-0ubuntu1_all.deb) from the following address:
https://ubuntu.pkgs.org/17.10/ubuntu-main-amd64/system-config-printer_1.5.9+20170825-0ubuntu1_all.deb.html

When we tried to install this deb package on Ubuntu 16.04, an error occurred. Please refer to the attached picture for details.

In addition, we also tried to upgrade the system-config-printer component with the [sudo apt-get upgrade] command, but the version is still 1.5.7 after the upgrade.

Could you tell us how to install system-config-printer 1.5.9 on Ubuntu 16.04?

First, keep in mind that one source package (upstream project) can have several binary packages in Ubuntu, each containing a certain component of the project. To get the complete project installed you need to install all binary packages, if you do not need all of the functionality you can leave out one or another binary package.

Also take into account that you cannot combine binary packages of different version. You need to install all of the binary packages.

So let us see which binary packages of system-config-printer you have installed:

dpkg -l | grep 1.5.7+2016

You will see a list of some packages. You have to update all of them, all at once, with a single "dpkg -i ..." command line.

So look at the binary packages of the desired newer version:

https://launchpad.net/ubuntu/+source/system-config-printer/1.5.9+20170825-0ubuntu1
https://launchpad.net/ubuntu/+source/system-config-printer/1.5.9+20170825-0ubuntu1/+build/13297396

See the section "Built files" under the last link.

Download all .deb files from here and install the ones form which you have the old version installed with a single command line, like for example:

dpkg -i python3-cupshelpers_1.5.9+20170825-0ubuntu1_all.deb system-config-printer-common_1.5.9+20170825-0ubuntu1_all.deb system-config-printer-gnome_1.5.9+20170825-0ubuntu1_all.deb system-config-printer-udev_1.5.9+20170825-0ubuntu1_amd64.deb system-config-printer_1.5.9+20170825-0ubuntu1_all.deb

This will most probably work. If not, we need to rebuild the source package for your distribution version, but try this first and tell whether this works. If not, I will show you how to do the rebuild.

JerryFu (zxf2jt19) wrote :

Dear Till,

Thank you very much for your confirmation and solutions.

We tried to install [system-config-printer 1.5.9+20170825] as the method you suggested, but it failed. Please refer to the attachment for details of the error message.

Best regards!

JerryFu (zxf2jt19) wrote :

Add attachment for details of the error message when install system-config-printer 1.5.9+20170825.

Try the following:

sudo dpkg -P --force-depends python3-cupshelpers system-config-printer-common system-config-printer-gnome system-config-printer-udev system-config-printer

sudo dpkg -i python3-cupshelpers_1.5.9+20170825-0ubuntu1_all.deb system-config-printer-common_1.5.9+20170825-0ubuntu1_all.deb system-config-printer-gnome_1.5.9+20170825-0ubuntu1_all.deb system-config-printer-udev_1.5.9+20170825-0ubuntu1_amd64.deb system-config-printer_1.5.9+20170825-0ubuntu1_all.deb

Please post/attach the output here.

Does the installation now work? Are you able to start system-config-printer? Do the notifications go away?

JerryFu (zxf2jt19) wrote :

We tried it according to the order recorded in #14, and post/attach the output. Please refer to the attachment for details.

After installing the missing package gir1.2-polkit-1.0 with [sudo apt-get install gir1.2-polkit-1.0] command and executing the [sudo dpkg -i python3...] command again, system-config-printer 1.5.9 can be successfully installed.

After executing these commands, we can start system-config-printer normally. However, the notifications is still displayed.

First, run the following commands to check whether your system-config-printer got completely upgraded:

dpkg -l | grep 1.5.7+2016
dpkg -l | grep 1.5.9+2017
dpkg -l | grep system-config-printer

Is this the case? If so, please log out and log in again to assure that there are no stale processes in your running desktop. If you still get the notifications, reboot. If you still get the notification also after this, it seems that they do not come from system-config-printer, but perhaps from Mate's desktop.

JerryFu (zxf2jt19) wrote :

Dear Till,

I am so sorry to trouble you that we did not described the phenomenon clearly.
The notification [Waiting for job to complete] is not displayed at Mate's desktop, but displayed in CUPS page (localhost:631) -> [Printers] tab -> [Status] column.
*Please refer to the attachment image for details.

By the way, we have confirmed that this problem does not be occured on Ubuntu 18.04LTS.
So we judge this is a CUPS/OS issue.Could you help us to confirm it again?

Thank you in advance!

JerryFu (zxf2jt19) wrote :

Dear Till,
I am sorry to trouble you again and again.

About this phenomenon, there are two problems that need you help us to confirm.

1. Is this notification is only displayed on the Mate's desktop? Is the notification content displayed on Mate's desktop the same as the content displayed on the CUPS page (localhost:631) -> [Printers] tab -> [Status] column? Is this method that upgrade system-config-printer is only for desktop notification of Mate?

2. Please help us to confirm is there any bad influence after upgrading system-config-printer with this method?

Because we plan to provide this upgrade method to our customers tomorrow, could you help us to confirm it as soon as possible?

Thank you in advance!

I am not familiar with Mate and so I do not know whether something concerning these notifications is specific to Mate. I also do not know whether there are any undesired print status pop-ups on Mate's desktop.

I only know that after the system-config-printer fix any undesired pop-ups disappeared on standard Ubuntu Linux.

For the CUPS web interface as how by your screen shot I do not see the status messages as a problem. The show which printers are busy doing a job (did they actually do a job when you have taken the screenshot?). They are not marked as errors and they are not annoying pop-ups which interrupt the user's workflow.

If they are not there anymore in newer Mate/Ubuntu/CUPS versions then the upstream developers of CUPS have done changes.

Note that the changes in system-config-printer only eliminate annoying desktop pop-ups, they do not change anything in the web admin interface of CUPS. So recommend the system-config-printer upgrade only if the user is complaining about desktop pop-ups. Doing the update does not cause any known regression or side effect, so updating is no problem.

bastux (bastux) wrote :

Would it be possible to solve the issue for Ubuntu 16.04 as well?

The latest version of system-config-printer-gnome availabe for Ubuntu 16.04 is 1.5.7+20160212-0ubuntu2

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.